2019-08-22 11:35 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0005744Spring engineGeneralpublic2017-09-08 22:25
ReporterGoogle_Frog 
Assigned ToKloot 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Version103.0 +git 
Target VersionFixed in Version 
Summary0005744: 103.0.1-1336 index 0 out of bounds
DescriptionHere is the infolog: https://github.com/ZeroK-RTS/CrashReports/issues/1949

Here is the other infolog from the same game that I have received. It looks like the error caused the desync. https://github.com/ZeroK-RTS/CrashReports/issues/1950
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0018337

Kloot (developer)

Last edited: 2017-09-03 14:29

View 3 revisions

rts/System/Platform/Win/CrashHandler.cpp:185
rts/System/Platform/Win/CrashHandler.cpp:347
rts/Sim/Units/CommandAI/BuilderCAI.cpp:531
rts/Sim/Units/CommandAI/CommandAI.cpp:1599
rts/Sim/Units/CommandAI/MobileCAI.cpp:1021
rts/Sim/Units/CommandAI/BuilderCAI.cpp:1264
rts/Sim/Units/CommandAI/BuilderCAI.cpp:527
/opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/bits/stl_vector.h:416
rts/Sim/Units/CommandAI/BuilderCAI.cpp:526
rts/Sim/Units/CommandAI/CommandAI.cpp:1130
rts/Sim/Units/CommandAI/CommandAI.cpp:902
rts/Sim/Units/CommandAI/BuilderCAI.cpp:495
rts/Game/SelectedUnitsHandler.cpp:694
rts/Net/NetCommands.cpp:675
rts/Game/Game.cpp:1062
rts/System/SpringApp.cpp:855
rts/System/SpringApp.cpp:886
rts/System/Main.cpp:43
rts/System/Main.cpp:92


trace of the eventual crash that resulted from this

rts/Sim/Units/BuildInfo.cpp:72
rts/Game/SelectedUnitsHandler.cpp:629
rts/Rendering/WorldDrawer.cpp:292
rts/Rendering/WorldDrawer.cpp:242
rts/Game/Game.cpp:1327
rts/System/SpringApp.cpp:856
rts/System/SpringApp.cpp:886
rts/System/Main.cpp:43
rts/System/Main.cpp:92

~0018338

Kloot (developer)

demo needed

~0018339

Kloot (developer)

desync seems unrelated since the index-out-of-bounds error occurs for all players and continues after MouthOfMadness was kicked due to:

[f=0011758] [Game::ClientReadNet][LOGMSG] sender="MouthOfMadness" string="could not load model "hoverassault_dead.s3o" (reason: [S3OParser] could not find model-file objects3d/hoverassault_dead.s3o)"
[f=0011758] Sync error for MouthOfMadness in frame 11744 (got 2ffd316c, correct is 75044020)

~0018341

Google_Frog (reporter)

This should be the game: http://zero-k.info/Battles/Detail/467891

~0018343

Kloot (developer)

wrong game (ID aee7ab590736032083f4acaffcda2bf2), the crash happened in game with ID 17ecab598102d7d443ad37fefcda2bf2

~0018351

Kloot (developer)

it seems this demo isn't going to surface so a fix will have to wait for another.

~0018361

Kloot (developer)

Fix 3e5409e92c2acde6f0b3fa51c1a5c2efa0b13b04 committed to develop branch: fix 0005744, repo: spring changeset id: 8732
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2017-09-03 14:07 Google_Frog New Issue
2017-09-03 14:14 Kloot Note Added: 0018337
2017-09-03 14:18 Kloot Note Added: 0018338
2017-09-03 14:18 Kloot Status new => feedback
2017-09-03 14:24 Kloot Note Added: 0018339
2017-09-03 14:28 Kloot Note Edited: 0018337 View Revisions
2017-09-03 14:29 Kloot Note Edited: 0018337 View Revisions
2017-09-03 14:56 Google_Frog Note Added: 0018341
2017-09-03 14:56 Google_Frog Status feedback => new
2017-09-03 15:23 Kloot Note Added: 0018343
2017-09-03 15:23 Kloot Status new => feedback
2017-09-05 23:57 Kloot Assigned To => Kloot
2017-09-05 23:57 Kloot Status feedback => closed
2017-09-05 23:57 Kloot Resolution open => unable to reproduce
2017-09-05 23:57 Kloot Note Added: 0018351
2017-09-08 22:25 Kloot Changeset attached => spring develop 3e5409e9
2017-09-08 22:25 Kloot Note Added: 0018361
2017-09-08 22:25 Kloot Status closed => resolved
2017-09-08 22:25 Kloot Resolution unable to reproduce => fixed
+Issue History