2019-11-19 23:51 CET

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0005551Spring engineGeneralpublic2017-05-19 23:15
ReporterGoogle_Frog 
Assigned ToKloot 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version103.0 +git 
Target VersionFixed in Version103.0 +git 
Summary0005551: 103.0.1-880 terrain geometry low detail flickering.
DescriptionThe terrain geometry appears to flicker. In the attached video I used terrain shadows to show the flicker. Apparently the low detail terrain is noticeable while changing the camera zoom level. I did not notice it myself but here are some screenshots:
 * Correct terrain: http://i.imgur.com/Ht1thnQ.jpg
 * Low detail terrain while zooming: http://i.imgur.com/s2uoUYv.jpg

The map is Onyx Cauldron 1.6.
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
+Relationships

-Notes

~0017607

Google_Frog (reporter)

Here is a video with the wiremap showing the issue. The issue can be triggered by changing the camera position. The terrain then might flicker for a few seconds. After a while the terrain settles on the correct rendering, provided the camera is kept static.

~0017608

Google_Frog (reporter)

The issue does not occur with ROAM = 0 in springsettings. It occurs with ROAM = 1 (the default), ROAM = 2 and ROAM = 3.

I'm going to set ROAM = 0 as the chobby default since it works and merely turns the bug into a performance regression.

~0017612

Kloot (developer)

Last edited: 2017-05-12 11:40

View 2 revisions

terrain with lots of spikes isn't handled well by ROAM because the variance changes too rapidly for (re)tessellation to keep up, though here it seems to be oscillating.

also, regression? ROAM=0 should be the faster mode at all comparable average detail levels.

~0017614

Google_Frog (reporter)

What is ROAM for if it is not to be better than the other renderer?

When it was implemented, ROAM was much better than the other terrain renderer. I haven't had any problems with ROAM up to 103-764. The other renderer either made terrain noticeably low detail or took lots of performance when zoomed out, there was no middle ground. My recent experience with ROAM=0 implies that nothing has changed. So I think you're selling ROAM short.

~0017615

Kloot (developer)

I am neither overselling the new nor underselling the old; the different renderers have different strengths and weaknesses because they work differently. "no middle ground" sounds like a fixable weakness to me.

"I haven't had any problems with ROAM up to 103-764" also implies this flickering is a new bug, which was not clear from the initial description or from testing since the majority of maps render fine.

~0017639

Google_Frog (reporter)

Works in 103-827
Broken in 103-854

~0017640

Kloot (developer)

Last edited: 2017-05-16 12:38

View 2 revisions

from testing, the flickering on Onyx happens only above a certain ground detail level (>>> 100, the attached config uses 168) which suggests pool exhaustion.

~0017641

Kloot (developer)

pool size bumped to 1M to handle crazier user settings.

~0017662

Google_Frog (reporter)

Occurs in 103.0.1-924

~0017663

Google_Frog (reporter)

The first failure case appears to be fixed. The issue appears now when zoomed out and especially at low angles. I have not tested if it occurs in this situation with 103-880 but I am fairly sure it did not occur in 103-764 or earlier.

~0017666

Anonymous (viewer)

Fix 59948dce4323025fdf0364fd130969588a0d69f8 committed to develop branch: fix 0005551, repo: spring changeset id: 8232
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2017-05-12 07:20 Google_Frog New Issue
2017-05-12 07:20 Google_Frog File Added: terrainFlicker.mp4
2017-05-12 07:20 Google_Frog File Added: springsettings.cfg
2017-05-12 07:32 Google_Frog File Added: flickerWiremap.mp4
2017-05-12 07:32 Google_Frog Note Added: 0017607
2017-05-12 07:40 Google_Frog Note Added: 0017608
2017-05-12 11:34 Kloot Note Added: 0017612
2017-05-12 11:40 Kloot Note Edited: 0017612 View Revisions
2017-05-12 14:03 Google_Frog Note Added: 0017614
2017-05-12 15:00 Kloot Note Added: 0017615
2017-05-16 09:41 Google_Frog Note Added: 0017639
2017-05-16 12:34 Kloot Severity major => minor
2017-05-16 12:37 Kloot Note Added: 0017640
2017-05-16 12:38 Kloot Note Edited: 0017640 View Revisions
2017-05-16 14:17 Kloot Assigned To => Kloot
2017-05-16 14:17 Kloot Status new => resolved
2017-05-16 14:17 Kloot Resolution open => fixed
2017-05-16 14:17 Kloot Fixed in Version => 103.0 +git
2017-05-16 14:17 Kloot Note Added: 0017641
2017-05-19 16:05 Google_Frog Status resolved => feedback
2017-05-19 16:05 Google_Frog Resolution fixed => reopened
2017-05-19 16:05 Google_Frog Note Added: 0017662
2017-05-19 16:06 Google_Frog File Added: 924_jitter.mp4
2017-05-19 16:08 Google_Frog Note Added: 0017663
2017-05-19 16:08 Google_Frog Status feedback => assigned
2017-05-19 23:13 Changeset attached => spring develop 59948dce
2017-05-19 23:13 Anonymous Note Added: 0017666
2017-05-19 23:15 Kloot Status assigned => resolved
2017-05-19 23:15 Kloot Resolution reopened => fixed
+Issue History