2019-08-24 02:37 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0005326Spring engineGeneralpublic2018-09-30 01:59
ReporterFloris 
Assigned ToKloot 
PrioritynormalSeverityminorReproducibilitysometimes
StatusresolvedResolutionfixed 
Product Version103.0 
Target VersionFixed in Version 
Summary0005326: Camera jumps around
DescriptionSee:
https://www.youtube.com/watch?v=AWCYjBBU40o

This behavior is occurring for years now.
Ctrl+f2 camera
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0016585

Floris (reporter)

Last edited: 2016-07-31 02:32

View 2 revisions

I've bind mouse thumb button to camera pan keybind, and then keep moving mouse to left while clicking the pan keybind, but camera keeps jumping back.

I've reported this issue more often but it seems to be ignored or not reproducible?

~0016588

Floris (reporter)

Seems to be only happening when you move you mouse snd while doing that press the pan-camera keybind, not if mouse is standing still.

~0016604

Floris (reporter)

Ok I guess I'll have to replace the buggy camera system althogether for BA and write/implement my own

~0017951

Kloot (developer)

sorry, but I still can't reproduce this in any obvious way (103+) with a standard 3-button mouse and MMB bound to pan-mode.

~0019367

Kloot (developer)

Fix b2e0badd3a5fa0c2e31f19849f207862d2627997 committed to develop branch: fix 0006046 0005326 0005222 0004663
one small step for Spring, repo: spring changeset id: 10756

~0019371

Kloot (developer)

Fix 9e82927f50b059442b2e672b50a7969c0b378f27 committed to maintenance branch: fix 0006046 0005326 0005222 0004663
one small step for Spring, repo: spring changeset id: 10757
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2016-07-31 02:26 Floris New Issue
2016-07-31 02:31 Floris Note Added: 0016585
2016-07-31 02:32 Floris Note Edited: 0016585 View Revisions
2016-07-31 20:34 Floris Note Added: 0016588
2016-08-08 14:46 Floris Note Added: 0016604
2017-07-07 16:03 Kloot Status new => closed
2017-07-07 16:03 Kloot Resolution open => unable to reproduce
2017-07-07 16:03 Kloot Note Added: 0017951
2018-09-30 01:58 Kloot Changeset attached => spring develop b2e0badd
2018-09-30 01:58 Kloot Note Added: 0019367
2018-09-30 01:58 Kloot Assigned To => Kloot
2018-09-30 01:58 Kloot Status closed => resolved
2018-09-30 01:58 Kloot Resolution unable to reproduce => fixed
2018-09-30 01:59 Kloot Changeset attached => spring maintenance 9e82927f
2018-09-30 01:59 Kloot Note Added: 0019371
+Issue History