2019-08-25 03:25 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0005043Spring engineGeneralpublic2016-01-27 00:20
ReporterJools 
Assigned Tohokomoko 
PrioritynormalSeverityminorReproducibilityrandom
StatusresolvedResolutionfixed 
Product Version100.0+git 
Target VersionFixed in Version 
Summary0005043: Crash after [GiveUnits]
Description[f=-000001] Player Jools finished loading and is now ingame
[f=0000386] [GiveUnits] spawned 3 arm_spidey unit(s) for team 0
[f=0000655] [GiveUnits] spawned 1 arm_u4commander unit(s) for team 0
[f=0000656] Error: Spring 100.0.1-923-ga6670b2 develop has crashed.
Steps To ReproduceI really did nothing more than that. It'c in cheating mode with a gadget.

infolog: http://pastebin.com/iNTL1ncc
Additional InformationU:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x0090A782 rts/Sim/Misc/LosMap.cpp:634
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x0090AC58 /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/bits/stl_vector.h:734
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x009016E3 /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/functional:2073
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x00BEEBD8 /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/functional:2469
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x00C2775D /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/bits/atomic_base.h:624
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x00BEEC00 /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/functional:2469
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x009047E8 /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/bits/shared_ptr_base.h:552
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x009056BF /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/functional:2029
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x00905AEA rts/Sim/Misc/LosHandler.cpp:685
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x00BEEBD8 /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/functional:2469
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x00C2775D /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/bits/atomic_base.h:624
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x00BEEC00 /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/functional:2469
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x009047E8 /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/bits/shared_ptr_base.h:552
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x00904AE6 /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/functional:2029
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x00425F85 rts/Game/Game.cpp:1481
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x004FC112 rts/System/Sync/SyncChecker.h:37
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x0043057D rts/Game/Game.cpp:960
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x00742DAE rts/System/SpringApp.cpp:960
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x0074A239 rts/System/SpringApp.cpp:996
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x007225C6 rts/System/Main.cpp:48
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x00D1BEC4 rts/System/Main.cpp:107
U:\bin\Spring\Data\engine\100.0.1-923-ga6670b2 develop\spring.exe 0x00401402 /opt/mxe/tmp-gcc/gcc-4.8.1/mirror-mingw-w64-c28722c/trunk/mingw-w64-crt/crt/crtexe.c:317
C:\Windows\syswow64\kernel32.dll 0x762F338A ??:0
C:\Windows\SysWOW64\ntdll.dll 0x77A59EF2 ??:0
C:\Windows\SysWOW64\ntdll.dll 0x77A59EC5 ??:0
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
duplicate of 0005037closed Crash in rts/Sim/Misc/LosMap.cpp 
+Relationships

-Notes

~0015561

hokomoko (developer)

btw, in gui_xta_layout.lua if XTA_MenuIconsX or XTA_MenuIconsY aren't set you send NANs to the engine (you divide in btns.y)

~0015562

hokomoko (developer)

Fix f9fdfd9d9e39ef09be537bd61f4793fea18d83c6 committed to develop branch: Fix 0005043

lostables can be resized while it's being iterated
over in (Un)SafeLosAdd

Solution -> make it an array of pointers.
(since it's already vectors, nr. of cache misses doubles
at most)., repo: spring changeset id: 6407

~0015565

hokomoko (developer)

Fix f86e45f077452360ed8aaa14154ed01794c3abca committed to develop branch: Fix 0005043 take 2, repo: spring changeset id: 6410

~0015567

hokomoko (developer)

Fix c95be45394cd6f874c54908bd235de7e4e597a03 committed to develop branch: Fix 0005043 take 2, repo: spring changeset id: 6411

~0015568

Jools (reporter)

Just wanted to mention this:
https://github.com/xta-springrts/xta-springrts/blob/master/luaui/widgets/gui_xta_layout.lua#L234

I just quickly edited this ancient widget, but to my understanding that line sets default values.

~0015569

hokomoko (developer)

and this line overwrites them:
https://github.com/xta-springrts/xta-springrts/blob/master/luaui/widgets/gui_xta_layout.lua#L241

0 in lua is true

~0015570

hokomoko (developer)

If you want to talk about lua, you can find me in the lobby
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2016-01-25 03:11 Jools New Issue
2016-01-25 10:58 Kloot Relationship added duplicate of 0005037
2016-01-26 11:01 hokomoko Assigned To => hokomoko
2016-01-26 11:01 hokomoko Status new => assigned
2016-01-26 11:28 hokomoko Note Added: 0015561
2016-01-26 12:50 hokomoko Changeset attached => spring develop f9fdfd9d
2016-01-26 12:50 hokomoko Note Added: 0015562
2016-01-26 12:50 hokomoko Status assigned => resolved
2016-01-26 12:50 hokomoko Resolution open => fixed
2016-01-26 15:00 hokomoko Changeset attached => spring develop f86e45f0
2016-01-26 15:00 hokomoko Note Added: 0015565
2016-01-26 15:02 hokomoko Changeset attached => spring develop c95be453
2016-01-26 15:02 hokomoko Note Added: 0015567
2016-01-26 23:47 Jools Note Added: 0015568
2016-01-26 23:47 Jools Status resolved => feedback
2016-01-26 23:47 Jools Resolution fixed => reopened
2016-01-27 00:02 hokomoko Note Added: 0015569
2016-01-27 00:20 hokomoko Note Added: 0015570
2016-01-27 00:20 hokomoko Status feedback => resolved
2016-01-27 00:20 hokomoko Resolution reopened => fixed
+Issue History