2019-08-20 11:56 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0004926Spring engineGeneralpublic2016-01-08 17:21
ReporterGoogle_Frog 
Assigned Tohokomoko 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusresolvedResolutionreopened 
Product Version100.0 
Target VersionFixed in Version 
Summary0004926: Weapon tag for true radar unit tracking.
DescriptionThis ticket concerns whether tracking weapons hit radar dots.

Currently MissileLaunchers track radar dot position for most of their flight. When they are within about 300 elmos of their target they "see" their target and switch to tracking the real unit position. This causes them to almost always hit radar dots, they are effectively unaffected by radar wobble.

StarburstLauncher track radar dot position with no switch to real unit position at the end of their flight. This causes them to miss due to radar wobble.

This behaviour appears to be hardcoded. I would like a tag which controls whether tracking weapons track real unit position once they are within a certain range. This tag could also control the range at which their tracking switches to the real unit position.
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0015069

jK (developer)

Fix 4bb06e208a5b10dac705c0bce616100d52bb7f86 committed to develop branch: fix 0004926: limit missile's always-exact targeting to interceptors, repo: spring changeset id: 5493

~0015070

Google_Frog (reporter)

What? This is not what I wanted at all. You have just fiddled with the type of tracking weapons which get exact tracking. What I wanted is an independent tag to control exact tracking because it is an independent property of a tracking weapon.

That commit is an unwanted balance change for ZK. I will not use it.

~0015071

jK (developer)

Fix 8750d2de0449c12b9c24bbe5da31cc57088ed1df committed to develop branch: further fix 0004926: remove missile's always-exact targeting as a whole
-> doesn't make sense for unit targets only for projectile targets it would make sense, but those don't got an error pos at all, repo: spring changeset id: 5496

~0015072

Google_Frog (reporter)

^ You removed engine features. As I have said elsewhere, the engine shouldn't decide what "makes sense". I could easily make up some game fluff and say that missiles are launched at the radar dot but, when they get closer, they use their onboard sensors to track the target perfectly.

~0015080

jK (developer)

strange to hear that from you who else wants to remove fundamental engine features just cause you again implemented them in lua:

* that `feature` is not intuitive
* I won't add a 1000th weapondef tag just for this (remind kloot)
* the code is already cluttered as hell, simplification is the way to go
* when you want a heat seeking missile, there is lua

~0015081

Google_Frog (reporter)

Have you considered that there are some things the engine should do and some things it shouldn't? The intuitiveness of the feature is not your concern because that is up to games to decide and convey. A lua heat seeking missile sounds like a performance hog. The code for tracking either real position or radar position looked really simple, just a distance check.

~0015460

hokomoko (developer)

Fix dfefb30283e0e23a50c948306ad75270ff491c78 committed to develop branch: Add SetProjectileIgnoreTrackingError Fix 0004926, repo: spring changeset id: 6174
+Notes

-Related Changesets
spring: develop 4bb06e20
Timestamp: 2015-08-19 02:45:53
Author: jK
Details ] Diff ]
fix 0004926: limit missile's always-exact targeting to interceptors
mod - rts/Sim/Projectiles/WeaponProjectiles/MissileProjectile.cpp Diff ] File ]
spring: develop 8750d2de
Timestamp: 2015-08-19 02:52:30
Author: jK
Details ] Diff ]
further fix 0004926: remove missile's always-exact targeting as a whole
-> doesn't make sense for unit targets only for projectile targets it would make sense, but those don't got an error pos at all
mod - rts/Sim/Projectiles/WeaponProjectiles/MissileProjectile.cpp Diff ] File ]
spring: develop dfefb302
Timestamp: 2016-01-08 17:22:57
Author: hokomoko
Details ] Diff ]
Add SetProjectileIgnoreTrackingError Fix 0004926
mod - doc/changelog.txt Diff ] File ]
mod - rts/Lua/LuaSyncedCtrl.cpp Diff ] File ]
mod - rts/Lua/LuaSyncedCtrl.h Diff ] File ]
mod - rts/Sim/Projectiles/Unsynced/ShieldProjectile.cpp Diff ] File ]
mod - rts/Sim/Projectiles/WeaponProjectiles/MissileProjectile.cpp Diff ] File ]
mod - rts/Sim/Projectiles/WeaponProjectiles/MissileProjectile.h Diff ] File ]
mod - rts/Sim/Projectiles/WeaponProjectiles/StarburstProjectile.cpp Diff ] File ]
mod - rts/Sim/Projectiles/WeaponProjectiles/StarburstProjectile.h Diff ] File ]
mod - rts/Sim/Projectiles/WeaponProjectiles/TorpedoProjectile.cpp Diff ] File ]
mod - rts/Sim/Projectiles/WeaponProjectiles/TorpedoProjectile.h Diff ] File ]

+Related Changesets

-Issue History
Date Modified Username Field Change
2015-08-07 04:46 Google_Frog New Issue
2015-08-19 02:47 jK Changeset attached => spring develop 4bb06e20
2015-08-19 02:47 jK Note Added: 0015069
2015-08-19 02:47 jK Assigned To => jK
2015-08-19 02:47 jK Status new => resolved
2015-08-19 02:47 jK Resolution open => fixed
2015-08-19 02:51 Google_Frog Note Added: 0015070
2015-08-19 02:51 Google_Frog Status resolved => feedback
2015-08-19 02:51 Google_Frog Resolution fixed => reopened
2015-08-19 02:51 jK Changeset attached => spring develop 8750d2de
2015-08-19 02:51 jK Note Added: 0015071
2015-08-19 02:51 jK Status feedback => resolved
2015-08-19 02:52 Google_Frog Note Added: 0015072
2015-08-19 02:52 Google_Frog Status resolved => feedback
2015-08-21 16:43 jK Note Added: 0015080
2015-08-21 18:27 Google_Frog Note Added: 0015081
2015-08-21 18:27 Google_Frog Status feedback => assigned
2016-01-08 17:21 hokomoko Changeset attached => spring develop dfefb302
2016-01-08 17:21 hokomoko Note Added: 0015460
2016-01-08 17:21 hokomoko Assigned To jK => hokomoko
2016-01-08 17:21 hokomoko Status assigned => resolved
+Issue History