2019-08-24 09:52 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0004798Spring engineLinuxpublic2015-06-25 17:42
Reporterbioinfornatics 
Assigned Toabma 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionunable to reproduce 
Product Version 
Target Version99.0Fixed in Version 
Summary0004798: Failling to build spring as he do not find java
DescriptionDear,

I use cmake 3 and when I do: cmake ..
This error is raised:
-----------------------------
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:138 (message):
  Could NOT find Java (missing: ) (found version "1.8.0.45")
Call Stack (most recent call first):
-----------------------------

while java is present and set correctly:

$ echo $JAVA_HOME
/opt/java/jdk1.8.0_45/

$ java -version
java version "1.8.0_45"
Java(TM) SE Runtime Environment (build 1.8.0_45-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)

$ javac -version
javac 1.8.0_45

$ alternatives --config java

There are 4 programs which provide 'java'.

  Selection Command
-----------------------------------------------
* 1 /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-39.b14.fc22.x86_64/jre/bin/java
 + 2 /opt/java/jdk1.8.0_45/jre/bin/java
   3 /opt/java/jdk1.7.0_55/jre/bin/java
   4 /opt/java/jdk1.6.0_45/jre/bin/java

TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files
  • ? file icon log (559 bytes) 2015-06-07 17:45 -
    warning: Java AI Interface will not be built!
    warning: Java OO AI Wrapper will not be built!
    warning: NullJavaAI Skirmish AI will not be built!
    CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:138 (message):
      Could NOT find Java (missing: ) (found version "1.8.0.45")
    Call Stack (most recent call first):
      /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:374 (_FPHSA_FAILURE_MESSAGE)
      /usr/share/cmake/Modules/FindJava.cmake:209 (find_package_handle_standard_args)
      AI/Skirmish/DAI/CMakeLists.txt:2 (find_package)
    
    
    
    ? file icon log (559 bytes) 2015-06-07 17:45 +

-Relationships
+Relationships

-Notes

~0014558

bioinfornatics (reporter)

Sorry I finnally found the problem.

With cmake 3 I need to find java like this:

find_package(Java COMPONENTS Development)

~0014567

abma (administrator)

Fix 579369f01dfee1390ff3acf8d5446c12659c2d49 committed to develop branch: (try to) fix 0004798, repo: spring changeset id: 5061

~0014568

abma (administrator)

can you please test if this change fixed it for you?

https://github.com/spring/spring/commit/579369f01dfee1390ff3acf8d5446c12659c2d49
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2015-06-07 17:35 bioinfornatics New Issue
2015-06-07 17:45 bioinfornatics File Added: log
2015-06-07 18:20 bioinfornatics Note Added: 0014558
2015-06-10 17:22 abma Changeset attached => spring develop 579369f0
2015-06-10 17:22 abma Note Added: 0014567
2015-06-10 17:22 abma Assigned To => abma
2015-06-10 17:22 abma Status new => resolved
2015-06-10 17:22 abma Resolution open => fixed
2015-06-10 17:23 abma Note Added: 0014568
2015-06-10 17:23 abma Status resolved => feedback
2015-06-10 17:23 abma Resolution fixed => reopened
2015-06-10 17:23 abma Target Version => 99.0
2015-06-10 17:24 abma Severity block => major
2015-06-25 17:42 abma Status feedback => resolved
2015-06-25 17:42 abma Resolution reopened => unable to reproduce
+Issue History