2019-12-07 07:34 CET

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0004684Spring engineGeneralpublic2015-09-06 20:23
ReporterShadowfury333 
Assigned TojK 
PriorityhighSeveritycrashReproducibilityalways
StatusresolvedResolutionfixed 
Product Version98.0.1+git 
Target VersionFixed in Version 
Summary0004684: Crash with nVidia and DebugGL at "Loading LuaUI" on -386
Descriptionhttp://pastebin.com/ZirvJm0J
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
+Relationships

-Notes

~0014066

Shadowfury333 (reporter)

Sorry, small mistake in title, it crashes without DebugGL on as well

~0014067

abma (administrator)

C:\Users\Shadowfury333\Documents\My Games\Spring\engine\98.0.1-386-g4abfa48\spring.exe 0x006BFD67 /opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/bits/basic_string.h:716
C:\Users\Shadowfury333\Documents\My Games\Spring\engine\98.0.1-386-g4abfa48\spring.exe 0x0044386B rts/Game/LoadScreen.cpp:257
C:\Users\Shadowfury333\Documents\My Games\Spring\engine\98.0.1-386-g4abfa48\spring.exe 0x0073295E rts/System/SpringApp.cpp:912
C:\Users\Shadowfury333\Documents\My Games\Spring\engine\98.0.1-386-g4abfa48\spring.exe 0x00739969 rts/System/SpringApp.cpp:948
C:\Users\Shadowfury333\Documents\My Games\Spring\engine\98.0.1-386-g4abfa48\spring.exe 0x00715616 rts/System/Main.cpp:48
C:\Users\Shadowfury333\Documents\My Games\Spring\engine\98.0.1-386-g4abfa48\spring.exe 0x00EB4884 rts/System/Main.cpp:107
C:\Users\Shadowfury333\Documents\My Games\Spring\engine\98.0.1-386-g4abfa48\spring.exe 0x00401402 /opt/mxe/tmp-gcc/gcc-4.8.1/mirror-mingw-w64-c28722c/trunk/mingw-w64-crt/crt/crtexe.c:317
C:\Windows\syswow64\kernel32.dll 0x74EB338A ??:0
C:\Windows\SysWOW64\ntdll.dll 0x76F39F72 ??:0
C:\Windows\SysWOW64\ntdll.dll 0x76F39F45 ??:0

~0014068

abma (administrator)

does it crash with LoadingMT = 0, too?

~0014073

Shadowfury333 (reporter)

Actually, it stopped crashing when I wiped my springsettings.cfg and used any of the ones used for Zero-K Lobby presets. I don't know what setting caused the problem, but the problem seems fixed

~0015122

jK (developer)

Fix 85b82e2a9fb9727c6b983d2ca0131f5a8d0471f5 committed to pr-downloader branch: fix 0004683 0004684 : make NamedTextures threadsafe, repo: spring changeset id: 5566
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2015-02-21 05:55 Shadowfury333 New Issue
2015-02-21 05:56 Shadowfury333 Note Added: 0014066
2015-02-21 15:47 abma Note Added: 0014067
2015-02-21 15:48 abma Note Added: 0014068
2015-02-21 15:49 abma Status new => feedback
2015-02-22 01:59 Shadowfury333 Note Added: 0014073
2015-02-22 01:59 Shadowfury333 Status feedback => new
2015-02-22 07:03 jK Status new => resolved
2015-02-22 07:03 jK Resolution open => fixed
2015-02-22 07:03 jK Assigned To => jK
2015-09-06 20:23 jK Changeset attached => spring pr-downloader 85b82e2a
2015-09-06 20:23 jK Note Added: 0015122
+Issue History