2019-12-10 19:49 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000320Spring engineGeneralpublic2006-11-07 20:19
Reporterrattle 
Assigned Totvo 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000320: Nightly 2533 keeps crashing...
Description...as soon as the game begins, i.e. when players get spawned.
Screenshot of the error message below.
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
+Relationships

-Notes

~0000425

rattle (reporter)

Last edited: 2006-11-04 16:58

Hardware specs:
1200 Athlon (no SSE), 512 mb ram, Geforce 2 (53.30 driver), sblive and I'm on Win2k SP4.
Did a clean install and registry reset just to be sure.

~0000426

tvo (reporter)

sound drivers ruled out, running with MaxSounds=0 (set in registry) shows same behaviour

~0000428

tvo (reporter)

If this bug happens for you, please test a build of revision 2536 or higher, and paste the infolog.txt here.

Test executables and installers can be found at http://www.osrts.info/~tvo/spring/

~0000429

colorblind (reporter)

Happens for me too. Specs:
P3 866, Intel 440BX chipset, Nvidia 5200FX @ 91.31, SBlive, Win2k SP4.

~0000430

rattle (reporter)

Last edited: 2006-11-04 17:01

Assertion error at line 198 in PreGame.cpp
Expression: good_fpu_control_registers("CPreGame::Update")

Infolog:
FPUCW: 0x027F instead of 0x003A or 0x003F
debug text: "CPreGame::Update"


Perhaps it's related to Win2k, though that would be unusual...

~0000431

KDR_11k (reporter)

On Tobi's request:
Athlon 64 3000, Via A8V, 1024 MB RAM Du-Ch, GeForce 6800 (driver version unknown), Win2k SP4.

Hm, all problems are under 2k SP4... I'll check what happens under XP.

~0000432

tvo (reporter)

Could one of you test revision 2538 and report back the infolog.txt of that one ?

Note to self: bug possibly related to http://qc.borland.com/wc/qcmain.aspx?d=5928 ?

~0000433

tvo (reporter)

Oh, and can one of you upload your Win2k SP4 user32.dll so I can test something?

~0000434

rattle (reporter)

FPUCW: 0x027F instead of 0x003A or 0x003F
debug text: "SpringApp::Run - before mainloop"

http://rattle.from-hell.net/spring/USER32.ZIP

~0000435

tvo (reporter)

colorblind and KDR_11k, can you confirm that revision 2549 or later fixes it for you? (it is fixed for rattle)

http://www.osrts.info/~tvo/spring/spring-r2549.zip
http://www.osrts.info/~tvo/spring/installer/spring_r2549_nightly.exe

~0000436

tvo (reporter)

Assuming it works for everyone now; Reopen / open new issue if it doesn't.

~0000437

colorblind (reporter)

Yeah it works for me now. Nice and nicely done :).
+Notes

-Issue History
Date Modified Username Field Change
2006-11-03 11:26 rattle New Issue
2006-11-03 11:26 rattle File Added: r2533_crash.jpg
2006-11-03 22:45 rattle Note Added: 0000425
2006-11-03 23:03 tvo Note Added: 0000426
2006-11-04 11:58 tvo Status new => assigned
2006-11-04 11:58 tvo Assigned To => tvo
2006-11-04 12:00 tvo Note Added: 0000428
2006-11-04 12:35 colorblind Note Added: 0000429
2006-11-04 16:58 rattle Note Edited: 0000425
2006-11-04 16:59 rattle Note Added: 0000430
2006-11-04 17:01 rattle Note Edited: 0000430
2006-11-04 19:55 KDR_11k Note Added: 0000431
2006-11-04 22:59 tvo Note Added: 0000432
2006-11-04 23:00 tvo Note Added: 0000433
2006-11-04 23:07 rattle Note Added: 0000434
2006-11-05 23:04 tvo Note Added: 0000435
2006-11-07 15:29 tvo Status assigned => resolved
2006-11-07 15:29 tvo Resolution open => fixed
2006-11-07 15:29 tvo Note Added: 0000436
2006-11-07 20:19 colorblind Note Added: 0000437
+Issue History