spring: develop 711d2873 | [ Diff ] [ Back to Repository ] | |||
Author | Committer | Branch | Timestamp | Parent |
---|---|---|---|---|
tvo | tvo | develop | 2008-10-12 17:25:12 | develop 307040ac |
Changeset | Cleanups: * It is allowed to loop over signed integers, saves a bunch of typing and unreadability, compare: - 'for (unsigned p = 0; p < static_cast<unsigned>(MAX_PLAYERS); ++p)' vs - 'for (int p = 0; i < MAX_PLAYERS; ++p)' In general try to *avoid* casts, not try to needlessly insert extra casts :) * Member variables should start with lower case, good: isPaused, bad: IsPaused * Don't put multiple declarations on single line (readability). git-svn-id: https://spring.clan-sy.com/svn/spring/trunk@6683 37977431-3df6-0310-b722-df95706aa16b |
|||
mod - rts/Game/GameServer.cpp | [ Diff ] [ File ] | |||
mod - rts/Game/GameServer.h | [ Diff ] [ File ] | |||
mod - rts/Map/SMF/BFGroundTextures.cpp | [ Diff ] [ File ] | |||
mod - rts/System/GlobalStuff.cpp | [ Diff ] [ File ] | |||
mod - rts/System/LoadSaveHandler.cpp | [ Diff ] [ File ] |