Graphics issue

Graphics issue

A dynamic game undergoing constant development and refinement, that attempts to balance playability with fresh and innovative features.

Moderator: Content Developer

Post Reply
Viktor87
Posts: 16
Joined: 17 Sep 2009, 09:32

Graphics issue

Post by Viktor87 » 20 Aug 2010, 16:15

Hey guys,
I've been off of CA for a while (~5 months) due to a poor internet connection. Internet might be improving soon so I decided to check back in, see what has happened to the game, update my install etc... So I did that, updated to the latest spring version and downloaded the latest stable. Problem is, something happened to my shadows. CA says my hardware/software settings don't support them when I try to toggle shadows ingame, and turning them on through Spring Settings also has no effect.
I used to have shadows and now I don't. No idea what happened.
I have an old computer, I've complained about it before- ancient Mobility Radeon 9600 graphics card. Still, it used to run shadows in CA. Anything I can do? Driver is up to date as far as I know, they stopped releasing new versions a while ago...
Game looks rather ugly without shadows.

Viktor
0 x

User avatar
Pxtl
Posts: 6112
Joined: 23 Oct 2004, 01:43

Re: Graphics issue

Post by Pxtl » 21 Aug 2010, 03:47

I used to run with a Radeon 9600, and I used to get shadows on that too... but it killed my framerate. Is it just a problem in CA, or does it appear in other mods?

The Spring developers have been doing really nice stuff with ground textures, so I wouldn't be surprised if older cards like that are losing support for this feature.

Remember that, in a pinch, CA has some blob-shadow widgets that you can use in lieu of Spring shadows. They're much uglier, but they don't kill your FPS to use them.
0 x

User avatar
Licho
Zero-K Developer
Posts: 3803
Joined: 19 May 2006, 19:13

Re: Graphics issue

Post by Licho » 21 Aug 2010, 13:51

Thats normal in new spring. You have to try different drivers.
10.7 have shadows, but dont have unit textures.
You can also try enabling atihacks in config file.
0 x

User avatar
Rafal99
Posts: 162
Joined: 14 Jan 2006, 04:09

Re: Graphics issue

Post by Rafal99 » 22 Aug 2010, 17:38

I have display driver version 10.2 on my Radeon 9600 Pro, and it runs without any major problems. All earlier versions caused various graphics bugs to me. Spring is set to minimal settings, no idea about AtiHacks, can't find it in settings, is it still there?

Also hello back Victor!
We had some nice 1v1s back then. :)
0 x

User avatar
Licho
Zero-K Developer
Posts: 3803
Joined: 19 May 2006, 19:13

Re: Graphics issue

Post by Licho » 22 Aug 2010, 18:48

In springdownloader go to settings, click graphics and pick edit engine configuration file.

You can try enabling atihacks there.
0 x

Post Reply

Return to “Zero-K”

cron