Broken single-player setup script (RC3.2)

Broken single-player setup script (RC3.2)

Some guys decided to attack each other with tanks and you can be one of them. /join #springtanks

Moderators: Moderators, Content Developer

Locked
User avatar
SpliFF
Posts: 1224
Joined: 28 Jul 2008, 06:51

Broken single-player setup script (RC3.2)

Post by SpliFF » 19 Mar 2011, 05:21

http://pastebin.com/8xuFzqhg (infolog)

http://pastebin.com/kLhyf2EK (script.txt)

Playing single-player following the instructions in the wiki for playing vs AI. Other mods work.

The script is there, it's even correct but for whatever reason it isn't recognized after that.

I also have _script.txt in that folder. Not sure if that's important.

I have the maps

Code: Select all

$ ls /home/spliff/.spring/maps
AlienDesert.sd7  Castles.sdz   DeltaSiegeDry.sd7    MoonQ20x.sd7         Supreme Battlefield.sd7
BananaHill.sd7   Chess_b2.sd7  Eye_Of_Horus_v2.sd7  MountDustmoreV3.sd7
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: Broken single-player setup script (RC3.2)

Post by knorke » 19 Mar 2011, 08:14

I guess that is the error that happens if you select any of the singleplayer battles in the Lua menu?
It does not seem to work on non-windows. :?
same problem i think: http://springrts.com/phpbb/viewtopic.php?f=43&t=25004

I do not even use a file named "script.txt" or "_script.txt", it must be something the engine messes up?
The startscripts are in Missions\ folder and are named:
startscript_castle.txt
startscript_dust.txt
startscript_horus.txt
startscript_moon.txt
startscript_tv.txt
0 x

User avatar
SpliFF
Posts: 1224
Joined: 28 Jul 2008, 06:51

Re: Broken single-player setup script (RC3.2)

Post by SpliFF » 19 Mar 2011, 08:48

Yes, i'd have to say it is the same issue. It looks like something borked with the way it restarts Spring and passes arguments. By "it" I mean whatever part of Spring and/or mod handles that stuff.
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: Broken single-player setup script (RC3.2)

Post by knorke » 19 Mar 2011, 09:01

It seems spring on non-windows Spring ignores the passed startscript (in form of a long string) and instead always looks for a "script.txt"
Modwise I do not know what to do, I do not have Linux anyway so can not test it.
To play, you could extract one of the startscripts from the .sdz file and try to somehow feed it to Spring. By drag&drop or via command line.
0 x

Locked

Return to “Spring Tanks”