messages from spads hosts not appearing on lobby chat

messages from spads hosts not appearing on lobby chat

Discuss development of lobby clients, server, autohosts and auto-download software.

Moderators: Moderators, Lobby Developers

Post Reply
raaar
Metal Factions Developer
Posts: 805
Joined: 20 Feb 2010, 12:17

messages from spads hosts not appearing on lobby chat

Post by raaar » 24 Feb 2019, 00:04

The messages from my spads hosts, when players join/leave (#mf) and !promote (#mf, #main, and a bunch of others) aren't showing up on the chat.

Is this a known issue?
0 x


raaar
Metal Factions Developer
Posts: 805
Joined: 20 Feb 2010, 12:17

Re: messages from spads hosts not appearing on lobby chat

Post by raaar » 24 Feb 2019, 19:54

hmmm..do I need to update spads due to the latest server changes?

there's these warnings on the logs:

20190224182525 - NOTICE - [SPADS] Initializing SPADS 0.12.4
20190224182525 - WARNING - [SPADS] Skipping auto-update at start, another updater instance is already running
20190224182525 - NOTICE - [SPADS] Loading Spring archives using unitsync library version 104 ...
20190224182528 - NOTICE - [SPADS] Spring server mode: headless
20190224182528 - NOTICE - [SimpleEvent] Event loop initialized using internal model
20190224182528 - NOTICE - [SpringAutoHostInterface] Listening on AutoHost port (127.0.0.1:8455)
20190224182528 - NOTICE - [SPADS] <PlayerAnnounce> Plugin loaded (version 1.0)
20190224182528 - NOTICE - [SimpleEvent] Starting event loop...
20190224182528 - NOTICE - [SpringLobbyInterface] Connecting to lobby.springrts.com:8200
20190224182529 - NOTICE - [SPADS] Lobby server has no default engine set, UnitSync is using Spring 104
20190224182529 - INFO - [SPADS] No local LAN IP address found
20190224182529 - INFO - [SPADS] Logged on lobby server
20190224182529 - NOTICE - [SPADS] TrueSkill service available
20190224182529 - WARNING - [SpringLobbyInterface] Replacing an existing JOINEDBATTLE callback for priority "PlayerAnnounce"
20190224182529 - WARNING - [SpringLobbyInterface] Replacing an existing LEFTBATTLE callback for priority "PlayerAnnounce"
20190224182529 - WARNING - [SpringLobbyInterface] Replacing an existing OPENBATTLE callback for priority "PlayerAnnounce"

20190224182529 - INFO - [SPADS] Channel mf joined
20190224182529 - INFO - [SPADS] Channel nl joined
20190224182529 - INFO - [SPADS] Channel de joined
20190224182529 - INFO - [SPADS] Channel fr joined
20190224182529 - INFO - [SPADS] Channel hu joined
20190224182529 - INFO - [SPADS] Channel ru joined
20190224182529 - INFO - [SPADS] Channel se joined
20190224182529 - INFO - [SPADS] Channel en joined
20190224182529 - INFO - [SPADS] Channel fi joined
20190224182529 - INFO - [SPADS] Channel pt joined
20190224182529 - INFO - [SPADS] Channel it joined
20190224182529 - INFO - [SPADS] Channel dk joined
20190224182529 - INFO - [SPADS] Channel main joined
20190224182529 - INFO - [SPADS] Channel pl joined
0 x

raaar
Metal Factions Developer
Posts: 805
Joined: 20 Feb 2010, 12:17

Re: messages from spads hosts not appearing on lobby chat

Post by raaar » 26 Feb 2019, 02:17

the messages seem to be working again, did anybody do anything?
0 x

User avatar
bibim
Lobby Developer
Posts: 901
Joined: 06 Dec 2007, 11:12

Re: messages from spads hosts not appearing on lobby chat

Post by bibim » 26 Feb 2019, 09:48

Nothing has changed at SPADS side, the warnings you see in your logs are just due to the "PlayerAnnounce" plugin you are using. It seems this plugin is redefining/erasing callbacks it has already declared.

If this is the code you are using for this plugin, then you should just add the check "if(getLobbyState() > 3)" at the end of line 65 to fix these warnings:

Code: Select all

	onLobbyConnected() if(getLobbyState() > 3);
But this has nothing to do with your messages not showing in chat.
1 x

User avatar
ThinkSome
Posts: 277
Joined: 14 Jun 2015, 13:36

Re: messages from spads hosts not appearing on lobby chat

Post by ThinkSome » 11 Mar 2019, 00:16

Fixed in repo, which now lives at https://framagit.org/specing/s44_spads
0 x

User avatar
bibim
Lobby Developer
Posts: 901
Joined: 06 Dec 2007, 11:12

Re: messages from spads hosts not appearing on lobby chat

Post by bibim » 11 Mar 2019, 09:33

Apparently you just replaced a code comment with a new call to "onLobbyConnected()", which should make things worse...
You should revert this commit and just add the "if(getLobbyState() > 3)" check at the end of the line containing the call to "onLobbyConnected()" as I explained.
0 x

User avatar
Silentwings
Moderator
Posts: 3579
Joined: 25 Oct 2008, 00:23

Re: messages from spads hosts not appearing on lobby chat

Post by Silentwings » 11 Mar 2019, 09:37

On the OP, no bug was reported but it might have been related to lobbyserver work (and if so, I guess was resolved weeks ago, unintentionally).
0 x

User avatar
ThinkSome
Posts: 277
Joined: 14 Jun 2015, 13:36

Re: messages from spads hosts not appearing on lobby chat

Post by ThinkSome » 11 Mar 2019, 18:08

Hahaha :D
0 x

Post Reply

Return to “Lobby Clients & Server”