Problem with Spring 100.0 + KP 4.6?

Problem with Spring 100.0 + KP 4.6?

Moderator: Content Developer

Post Reply
TheBlackPumpkin
Posts: 1
Joined: 12 Oct 2015, 13:42

Problem with Spring 100.0 + KP 4.6?

Post by TheBlackPumpkin »

Hello.

There is my problem.
I installed Spring and KP on ArchLinux with the ArchLinux's packet installer (pacman) and launched a game. I can order the first builder to create a unit: the builder starts its animation, but the built unit flickers. It's like the unit is instantly built then destroyed the frame after, and the builder immediately starts building another one. I can pause, select the built unit and give it a move order, but when I remove the pause, the unit flickers again. Result: I can build nothing.

Meanwhile, I get spammed with error messages, both before I launch the game (while in the lobby) and during the game.
Many of them:
Error: CobError: Unknown set constant 103
And periodically one of them (every 1 second or so):
Warning: trojan: weapon1: Neither AimFromWeapon nor QueryWeapon defined or returned invalid pieceids
Is there a link? I doubt because the error messages come before the "flicker" problem. But who know?

My version of Spring is 100.0 and KP version is 4.6, but on this page I see KP 4.6 and Spring 95.0. Does the problem come with KP 4.6 + Spring 100.0?

How can I help you helping me?
Thanks in advance!
gajop
Moderator
Posts: 3040
Joined: 05 Aug 2009, 20:42

Re: Problem with Spring 100.0 + KP 4.6?

Post by gajop »

Not a KP dev, but sharing your infolog: https://springrts.com/wiki/Infolog.txt and maybe even replays: https://springrts.com/wiki/Spring_Replays would be helpful.
However, it's likely that KP just isn't going to work on Spring 100.0 if the dev hasn't updated it yet
User avatar
Jools
XTA Developer
Posts: 2813
Joined: 23 Feb 2009, 16:29

Re: Problem with Spring 100.0 + KP 4.6?

Post by Jools »

Yes, infolog will contain all relevant errors.

I tested KP 4.6 with spring 98.0 and it did run for me without any errors, but for some reason there was a lot of lag. If you want to test earlier versions of spring, you can find them here:

http://springrts.com/dl/buildbot/default/master/

I guess on linux the engine goes into ~/.config/spring/engine folder : viewtopic.php?t=30044
User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7031
Joined: 16 Nov 2004, 13:08

Re: Problem with Spring 100.0 + KP 4.6?

Post by zwzsg »

Yes, Spring 100.0 is not compatible with Kernel Panic 4.6. Its bits have rotten.

There are many more errors that the ones you found, so I suggest you use an older version of Spring. Something like 88.

[list]
[*] Units under construction flicker and never build : constructionDecayTime is set to 0 in ModRules, and in Spring 100 that make the nanoframe disappear even before the builder gets a chance.
[*] Neither AimFromWeapon nor QueryWeapon defined: It's because factories and builders use weapon to emit build effect. Those weapons are never actually fired, so the function related to firing aren't implemented. Spring 100 doesn't like that.
[*] Error: CobError: Unknown set constant 103 : set ALPHA_THRESHOLD stopped working long ago, but only recently does it spit errors.
[*] [GetUnitCommands] called too often without a 2nd argument to define maxNumCmds : I guess I have find and modify all my GetUnitCommands
[*] GetUnitSeparation used to accept 1 and 0 instead of true and false, not anymore, this make ONS crash.
[*] Some spray shots stop short: they now need burnblow=0
[*] Minelauncher doesn't work.
[*] Color Wars eat all the lua mem: according to yesterday chat, it's more about my table and how I pass them to unsynced than OpenGL, so maybe I can fix it.
[*] Maybe something about starting factories sending units to the wrong rally point and spawning backwards.
[*] HexFarm 7 gadget crash => Fixed in HexFarm 8
[*] Can't build on HexFarm without having a unit in sight range first: it's because engine implemented unsynced heightmap, which I can't disable.
[*] Plus all those I haven't yet found![/list]
ballsystemlord
Posts: 2
Joined: 13 Oct 2011, 21:29

Re: Problem with Spring 100.0 + KP 4.6?

Post by ballsystemlord »

gajop wrote:Not a KP dev, but sharing your infolog: https://springrts.com/wiki/Infolog.txt and maybe even replays: https://springrts.com/wiki/Spring_Replays would be helpful.
However, it's likely that KP just isn't going to work on Spring 100.0 if the dev hasn't updated it yet
I'm experiencing the same problem, do you still want the full infolog?
I can't install spring 95.0 or older as the cmake it uses is way too old (request for 2.4 compat when I'm using version 3.7!).
gajop
Moderator
Posts: 3040
Joined: 05 Aug 2009, 20:42

Re: Problem with Spring 100.0 + KP 4.6?

Post by gajop »

I don't, not sure about zwzsg. I don't think he's active in development anymore.
Generally there is no point working with an old Spring. Games should be updated to newest or abandoned if there's no interest.
User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7031
Joined: 16 Nov 2004, 13:08

Re: Problem with Spring 100.0 + KP 4.6?

Post by zwzsg »

Yeah, I kinda stopped updating Kernel Panic because it was taking many nights to merely slow down the decay: Some issues I could fix, but there are engine changes against which I don't even have workarounds!

I'd say to use an old Spring build, but apparently it's not possible under Linux?
Post Reply

Return to “Kernel Panic”