[~Solved] ATI Catalyst driver <--> no texture <--> fps ?

[~Solved] ATI Catalyst driver <--> no texture <--> fps ?

Discuss everything related to running Spring on your chosen distribution of Linux.

Moderator: Moderators

Post Reply
User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

[~Solved] ATI Catalyst driver <--> no texture <--> fps ?

Post by albator » 09 Jun 2009, 18:38

I use:

Ubuntu 9.04
AMD 3000+
1Go RAM
ATI 9800 PRO 128Mo
drivers: fglrx radeon


I do not have any textures when i play (everything is white) but except this problem everything is fine

I want to know :
1) Do you think that installing the Catalyst drivers will solve this problem
2) If it solves this problem do you think it will influence the framerate cause Ubuntu use far more ressources than my Windows XPSP1 and I am afraid I will not be able to play if I loose more fps.
Last edited by albator on 12 Jun 2009, 11:52, edited 1 time in total.
0 x

Auswaschbar
Spring Developer
Posts: 1254
Joined: 24 Jun 2007, 08:34

Re: [Problem] ATI Catalyst driver <--> no texture <--> fps ?

Post by Auswaschbar » 09 Jun 2009, 18:41

Yes, it will help, and no, fps should increase in fact.
0 x

User avatar
clericvash
Posts: 1394
Joined: 05 Oct 2004, 01:05

Re: [Problem] ATI Catalyst driver <--> no texture <--> fps ?

Post by clericvash » 09 Jun 2009, 23:23

Installing the proper catalyst drivers will always work better for the moment until the open source ones are up to scratch.

I had a ati card and it seems to work pretty well.
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: [Problem] ATI Catalyst driver <--> no texture <--> fps ?

Post by albator » 10 Jun 2009, 13:25

Ok, i will do it if i can.

It has been 2 days i am trying to but with no sucess. Indeed, I use

ubuntu 9.04
ATI 9800 PRO 128Mo
Athlon 3000+

And I can only install catalyst 9.3 using the patch for old ATI card. http://doc.ubuntu-fr.org/catalyst

Unfortunatly I dont have the appropriate kernel for the patch (I should go from 2.6.28 to 2.6.29). Consequently I have configure and install a new one, unless there is a simpler way to update my kernel
0 x

imbaczek
Posts: 3629
Joined: 22 Aug 2006, 16:19

Re: [Problem] ATI Catalyst driver <--> no texture <--> fps ?

Post by imbaczek » 10 Jun 2009, 17:37

try older versions of catalyst, like 8.12.
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: [Problem] ATI Catalyst driver <--> no texture <--> fps ?

Post by albator » 10 Jun 2009, 18:01

yes , I tryed,. In fact I am currently looking for catalyst 9.2 but I cannot find them cause evey links heading for older version than 9.3 bring me on this webpage... http://support.amd.com/us/gpudownload/l ... linux.aspx, which is the 9.5

I am so depress I am gonna get back to Xp or I will downgrad to ubuntu 8.10

EDIT:

After checking, it seems that Xorg 1.6 (and 1.7) are the reason of the failed installation, so I have the choice to downgrade Xorg to 1.5(2) or install clean 8.10.
I dunno what is the easier

~Solved:

I installed Intrepid 8.10, catalyst 9.3, everything works perfectly, with a little more fps than XP SP1
0 x

Post Reply

Return to “Linux”