[Fixed] MagnesiumRelay does not start (exit status 127)

[Fixed] MagnesiumRelay does not start (exit status 127)

Please use this forum to set up matches and discuss played games.

Moderator: Moderators

Post Reply
Lawd
Posts: 5
Joined: 07 Jun 2013, 20:07

[Fixed] MagnesiumRelay does not start (exit status 127)

Post by Lawd » 07 Jun 2013, 20:22

So myself and a couple of online friends play spring from time to time, and some time ago (I estimate months) the relay host that we used just would not host games anymore. It would instantly stop and throw this message into the battleroom chat:

[12:44:37] * MagnesiumRelay_1 *** Starting game...
[12:44:37] * MagnesiumRelay_1 *** Error: Spring Exited with status 127
[12:44:37] * MagnesiumRelay_1 *** Game ended

And it would do this for all of us, regardless of who was hosting.
Now, figuring this was a problem beyond our grasp, we would occasionally check back into SL to see if someone fixed this problem, but it never was. I've scoured the boards more than once to see if anyone far more regular to this game posted about the problem, but nobody seems to have done so in regards to this particular relay. So now, I figure that I may as well be the one to ask, since I just can't seem to find what I'm looking for on my own.

So I guess what I'm asking is, is this a clientside problem I can fix, and if so how? If not, is there a different host I can use with the manual entry thing? Magnesium is the only option I (we) seem to have, the others being automatic (which picks magnesium anyway) and Manually Enter (which I can't seem to find a name to put here that will work). If neither of these things are possible, what can I do instead?
Last edited by SirMaverick on 16 Jun 2013, 21:17, edited 1 time in total.
Reason: title: fixed
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: Relay eats itself before a game can start

Post by knorke » 07 Jun 2013, 22:02

So I guess what I'm asking is, is this a clientside problem I can fix, and if so how?
No, it is problem with the relay host:
http://springrts.com/phpbb/viewtopic.php?f=16&t=29659

Btw in http://springrts.com/phpbb/viewtopic.ph ... 67#p542529 dansan writes about his relayhost: (not sure if magnesiumrelay is his but does not matter)
The relay is mostly down, because it doesn't have a init-script and isn't really needed, as there are enough relays up atm.
Maybe other server owners thought similiar and took their relays down because thought it is not needed?
But thing is, there no relays up atm. Since some time they all disappeared or are broken. So if someone can run relays, it is welcome i think :)
If neither of these things are possible, what can I do instead?
In meantime can use an authost. Type !lock to make the game private. You can also use the !spawn command pmed to bot to make it open a room with whatever mod you want (must be on rapid) but I dont know how that works in detail.
0 x

Lawd
Posts: 5
Joined: 07 Jun 2013, 20:07

Re: MagnesiumRelay eats itself before a game starts (status

Post by Lawd » 07 Jun 2013, 22:41

Thank you for your help.

Although since I have little to no experience with autohosts, I'm not entirely sure what you said in that last paragraph. I can understand the part about locking it (which I suppose I COULD do, since there appears to be one autohost with a clantag or something that is using tech annihilation), but I'm not sure about the rest. Who is the "bot" you speak of that I need to pm that spawn command? What do you mean by "must be on rapid"?

And also, does locking the game restrict everyone from entering, or can I set a password on it/manually invite people somehow?
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: MagnesiumRelay eats itself before a game starts (status

Post by knorke » 07 Jun 2013, 23:13

The bot would be "Springie" or any other autohost bot that supports it. (I dont know which ones do, try out)

The message would be like:
!spawn mod=zk:stable
Then the host responds with a message to you "room is ready, join me!"
The short name that goes after the mod= you can find on
http://springrts.com/wiki/Rapid_Tags
So zk would be Zero-K.
Now what is the name for Tech Annihilation I do not know, it is not on that list. (="must be on rapid")
And also, does locking the game restrict everyone from entering, or can I set a password on it/manually invite people somehow?
!lock locks it for everyone, no password or inviting possible.
With the !spawn commdand you add a password:
!spawn mod=zk:stable,password=blablasecret
Pm !help to a springie bot for more info.
Sorry, a it confusing and vague. Wish there was a real tutorial on this.
0 x

Lawd
Posts: 5
Joined: 07 Jun 2013, 20:07

Re: MagnesiumRelay eats itself before a game starts (status

Post by Lawd » 07 Jun 2013, 23:43

Thank you very much; you have been extraordinarily helpful. I hope to get back into the game soon :D

Wait, I've got one last question. What parameter do I give the spawn command to make it a tech annihilation game? I don't see it on that list.(edit: evidently you already made note of that before, and I missed that little detail somehow. Derp. <_<)

Edit: argh. SL doesn't work with springiee, evidently. Also, is there a way to remove the instance of the autohost I created? Or do I not understand how these work....? (Editwithintheedit: It seems they delete themselves after a while or something.)
0 x

Lawd
Posts: 5
Joined: 07 Jun 2013, 20:07

Re: MagnesiumRelay eats itself before a game starts (status

Post by Lawd » 08 Jun 2013, 03:10

Excuse my double post, but I felt my last one was too cluttered with edits and a bit incoherent.

So what I think is happening is when I try to !spawn to one of the autohosts, it hosts a game using an outdated version of spring, and I thus can't use it properly. Is there some way to avoid this?

Also, I's still wondering about the Tech Annihilation problem mentioned earlier. It's not absolutely essential that I play on that mod, but it would be nice if I could. Anyone who can come forth and show me how to use that mod will be greatly appreciated.
0 x

User avatar
CarRepairer
Cursed Zero-K Developer
Posts: 3359
Joined: 07 Nov 2007, 21:48

Re: MagnesiumRelay eats itself before a game starts (status

Post by CarRepairer » 08 Jun 2013, 04:32

Try logging in with http://weblobby.springrts.com and create a multiplayer battleroom. You can select Tech Annihilation from the dropdown list in the autohost tab.
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: MagnesiumRelay eats itself before a game starts (status

Post by knorke » 08 Jun 2013, 14:28

it hosts a game using an outdated version of spring, and I thus can't use it properly.
yes, type !setengine 94.1
The host should restart with correct version.
SL doesn't work with springiee, evidently.
hm they work with springlobby for me..
0 x

abma
Spring Developer
Posts: 3548
Joined: 01 Jun 2009, 00:08

Re: MagnesiumRelay eats itself before a game starts (status

Post by abma » 09 Jun 2013, 01:28

Code: Select all

127 is reserved for "command not found"
autohost is wrongly configured it seems...
0 x

Lawd
Posts: 5
Joined: 07 Jun 2013, 20:07

Re: MagnesiumRelay eats itself before a game starts (status

Post by Lawd » 12 Jun 2013, 05:35

Thank you all for your help. I haven't been able to comment due to lack of time.

I've tried setengine shenanigans and the weblobby thing, and I think I have the hang of this now. Thanks to that weblobby app, I have discovered that the rapid tags for tech annihilation and robot defense are
techa:latest
tard:latest
Respectively.

I now just need to figure out the autohost commands, but I can do that through experimentation, I believe. I thank you all again for your help.
0 x

SirMaverick
Posts: 834
Joined: 19 May 2009, 21:10

Re: MagnesiumRelay eats itself before a game starts (status

Post by SirMaverick » 16 Jun 2013, 21:16

abma wrote:

Code: Select all

127 is reserved for "command not found"
autohost is wrongly configured it seems...
Libraries were updates so the server didn't start anymore. Fixed now.
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: [Fixed] MagnesiumRelay does not start (exit status 127)

Post by knorke » 13 Jul 2013, 15:15

thanks SirMaverick.

It worked for some time, now it is broken again: all the relayhosts seem to be gone/down.
0 x

User avatar
FLOZi
MC: Legacy & Spring 1944 Developer
Posts: 6106
Joined: 29 Apr 2005, 01:14

Re: [Fixed] MagnesiumRelay does not start (exit status 127)

Post by FLOZi » 28 Jul 2013, 14:39

knorke wrote:thanks SirMaverick.

It worked for some time, now it is broken again: all the relayhosts seem to be gone/down.
This is a major community issue imo. Anything we can do about it?
0 x

abma
Spring Developer
Posts: 3548
Joined: 01 Jun 2009, 00:08

Re: [Fixed] MagnesiumRelay does not start (exit status 127)

Post by abma » 28 Jul 2013, 14:44

run the relayhosts at springrts.com maybe? there should be mostly an admin available...

is there some doc about how to set it up? or does it run already there?
0 x

Post Reply

Return to “Ingame Community”