The call to initStatic() returned unsuccessfuly.

The call to initStatic() returned unsuccessfuly.

Here is where ideas can be collected for the skirmish AI in development

Moderators: hoijui, Moderators

msm8bball
Posts: 52
Joined: 09 Oct 2009, 08:08

The call to initStatic() returned unsuccessfuly.

Post by msm8bball » 07 Feb 2011, 07:42

I'm getting this error. I'm not exactly sure what's causing it. It only seems to happen when I run the AI I made, or the NullOOJavaAI that comes with it. Running some of the other finish AI's that are included works just fine.

Here's the infolog.txt:

Code: Select all

LogOutput initialized.
Spring 0.82.7.0 (0.82.7)
Build date/time: Jan  2 2011 14:08:40
Available log subsystems: CollisionVolume, unit, ArchiveScanner, VFS-detail, VFS, Sound
Enabled log subsystems: Sound
Enable or disable log subsystems using the LogSubsystems configuration key
  or the SPRING_LOG_SUBSYSTEMS environment variable (both comma separated).
  Use "none" to disable the default log subsystems.
using configuration source "C:\Users\msm8bball\AppData\Local\springsettings.cfg"
[CMyMath::Init] CPU SSE mask: 888, flags:
	SSE 1.0:  1,  SSE 2.0:  1
	SSE 3.0:  1, SSSE 3.0:  0
	SSE 4.1:  0,  SSE 4.2:  0
	SSE 4.0A: 1,  SSE 5.0A: 0
	using streflop SSE FP-math mode, CPU supports SSE instructions
OS: Microsoft Windows
Microsoft Windows 7 Business Edition, 64-bit (build 7600)
AMD Phenom(tm) II X4 965 Processor; 8191MB RAM, 16380MB pagefile
OS: emulated 32bit mode
Using read-only data directory: C:\Program Files (x86)\Spring\
Using read-write data directory: C:\Users\msm8bball\Documents\My Games\Spring\
Scanning: C:\Users\msm8bball\Documents\My Games\Spring\maps
Scanning: C:\Users\msm8bball\Documents\My Games\Spring\mods
Scanning: C:\Program Files (x86)\Spring\maps
Scanning: C:\Program Files (x86)\Spring\base
Scanning: C:\Program Files (x86)\Spring\games
Scanning: C:\Program Files (x86)\Spring\mods
Supported Video modes: 1366x768, 1360x768, 1280x800, 1280x768, 1280x720, 1024x768, 800x600, 720x576, 720x480, 640x480
Video mode set to 1280x800/32bit
[f=0000000] SDL:  1.2.10
[f=0000000] GL:   4.1.10362 Compatibility Profile Context
[f=0000000] GL:   ATI Technologies Inc.
[f=0000000] GL:   ATI Radeon HD 5700 Series 
[f=0000000] GLSL: 4.10
[f=0000000] GLEW: 1.5.4
[f=0000000] ATI hacks enabled
[f=0000000] Joysticks found: 0
[f=0000000] Joystick 0 not found
[f=0000000] Loading startscript from: C:\Users\msm8bball\Documents\My Games\Spring\\script.txt
[f=0000000] Connecting to local server
[f=0000000] Binding UDP socket to IP (v6) :: Port 8452
[f=0000000] [UDPListener] succesfully bound socket on port 8452
[f=0000000] Starting GameServer: 5 ms
[f=0000000] Starting demo recording
[f=0000000] Using map DeltaSiegeDry
[f=0000000] Recording demo demos/20110206_235609_DeltaSiegeDry_0.82.7.sdf
[f=0000000] Using mod Balanced Annihilation V7.19
[f=0000000] [Sound] OpenAL info:
[f=0000000] [Sound]   Vendor:     OpenAL Community
[f=0000000] [Sound]   Version:    1.1 ALSOFT 1.11.753
[f=0000000] [Sound]   Renderer:   OpenAL Soft
[f=0000000] [Sound]   AL Extensions: AL_EXTX_buffer_sub_data AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_OFFSET AL_EXTX_sample_buffer_object AL_EXT_source_distance_model AL_LOKI_quadriphonic
[f=0000000] [Sound]   ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_disconnect ALC_EXT_EFX ALC_EXTX_thread_local_context
[f=0000000] [Sound]                   ALC_EXT_EFX found (required for air absorption): yes
[f=0000000] [Sound]   Device:     DirectSound Software
[f=0000000] [Sound]   Available Devices:  
[f=0000000] [Sound]                       DirectSound Software
[f=0000000] [Sound] air absorption enabled: 0.1
[f=0000000] Using mod archive BA719.sd7
[f=0000000] Loading client data: 51 ms
[f=0000000] User number 0 (team 0, allyteam 0)
[f=0000000] [Sound]  parsed 25 sounds from gamedata/sounds.lua
[f=0000000] Loading sounds: 1 ms
[f=0000000] Camera and mouse: 58 ms
[f=0000000] Parsing unit icons
[f=0000000] Loading GameData Definitions
[f=0000000] Loading all definitions:  0.317000
[f=0000000] Loading GameData Definitions: 347 ms
[f=0000000] Parsing Map Information
[f=0000000] Loading SMF
[f=0000000] Loading Map
[f=0000000] Calculating smooth height mesh
[f=0000000] Calculating smooth mesh: 126 ms
[f=0000000] Number of damage types: 40
[f=0000000] Creating unit textures
[f=0000000] Loading weapon definitions
[f=0000000] Loading unit definitions
[f=0000000] Loading feature definitions
[f=0000000] Initializing map features
[f=0000000] Unknown map feature type 
[f=0000000] Reading Estimate PathCosts [8]
[f=0000000] Reading Estimate PathCosts [32]
[f=0000000] [CPathManager] pathing data checksum: 07e0d450
[f=0000000] Loading .smt tile-file "maps/DryDeltaSiege.smt"
[f=0000000] Loading 40585 tiles from file 1/1
[f=0000000] Reading tiles
[f=0000000] Reading tile map
[f=0000000] generating MipMaps: 5 ms
[f=0000000] Generating 3D trees
[f=0000000] Creating Projectile Textures
[f=0000000] Creating sky
[f=0000000] Loading console: 1 ms
[f=0000000] Loading LuaRules
[f=0000000] Loaded gadget:  No Self-D           <unit_prevent_share_selfd.lua>
[f=0000000] Loaded gadget:  Air Release         <unit_air_release_manager.lua>
[f=0000000] Loaded gadget:  AirPlantParents     <unit_air_plants.lua>
[f=0000000] Loaded gadget:  Commando Watch      <unit_commando_watch.lua>
[f=0000000] Loaded gadget:  DirectControl       <unit_direct_control.lua>
[f=0000000] Loaded gadget:  DragonsDisguise     <unit_set_neutral.lua>
[f=0000000] Loaded gadget:  DroppedStartPos     <unit_fix_dropped_startpos.lua>
[f=0000000] Loaded gadget:  FinishedBuilding    <unit_finished_building.lua>
[f=0000000] Loaded gadget:  Hitsphere Scaledown  <unit_hitsphere_scaledown.lua>
[f=0000000] Loaded gadget:  MissileControl      <unit_missile_delay.lua>
[f=0000000] Loaded gadget:  Napalm              <lups_napalm.lua>
[f=0000000] Loaded gadget:  No Land Damage      <unit_no_land_damage.lua>
[f=0000000] Loaded gadget:  No Self Pwn         <unit_noselfpwn.lua>
[f=0000000] Loaded gadget:  NoCost              <cmd_nocost.lua>
[f=0000000] Loaded gadget:  PassiveBuilders     <unit_passive_builders.lua>
[f=0000000] Loaded gadget:  Prevent Lab Hax     <unit_prevent_lab_hax.lua>
[f=0000000] Loaded gadget:  Prevent Load Hax    <unit_prevent_load_hax.lua>
[f=0000000] Loaded gadget:  Prevent Range Hax   <unit_prevent_range_hax.lua>
[f=0000000] Loaded gadget:  Prevent Strange Orders  <unit_prevent_strange_orders.lua>
[f=0000000] Loaded gadget:  Reclaim Fix         <unit_reclaim_fix.lua>
[f=0000000] Loaded gadget:  ShieldDrain         <unit_shield_watch.lua>
[f=0000000] Loaded gadget:  Shockwaves          <lups_shockwaves.lua>
[f=0000000] Loaded gadget:  Spawn               <init_game_spawn.lua>
[f=0000000] Loaded gadget:  Start Point Remover Gadget  <init_start_point_remover_gadget.lua>
[f=0000000] Loaded gadget:  fx_reclaim_shards   <fx_reclaim_shards.lua>
[f=0000000] Loaded gadget:  lups_wrapper.lua    <lups_wrapper.lua>
[f=0000000] Loaded gadget:  mo_enemywrecks      <mo_enemywrecks.lua>
[f=0000000] Loaded gadget:  mo_noshare          <mo_noshare.lua>
[f=0000000] Loaded gadget:  prevent_flying_com_wrecks  <unit_prevent_flying_com_wrecks.lua>
[f=0000000] Loaded gadget:  Area Attack         <areaattack.lua>
[f=0000000] Loaded gadget:  C Is For Control    <comiscontrol.lua>
[f=0000000] Loaded gadget:  Team Com Ends       <teamcomends.lua>
[f=0000000] Loaded gadget:  LupsSyncedManager   <lups_manager.lua>
[f=0000000] Loaded gadget:  Mex Upgrader Gadget  <unit_mex_upgrader.lua>
[f=0000000] Loaded gadget:  Air Release         <unit_air_release_manager.lua>
[f=0000000] Loaded gadget:  AirPlantParents     <unit_air_plants.lua>
[f=0000000] Loaded gadget:  DragonsDisguise     <unit_set_neutral.lua>
[f=0000000] Loaded gadget:  DroppedStartPos     <unit_fix_dropped_startpos.lua>
[f=0000000] Loaded gadget:  FinishedBuilding    <unit_finished_building.lua>
[f=0000000] Loaded gadget:  Hitsphere Scaledown  <unit_hitsphere_scaledown.lua>
[f=0000000] Loaded gadget:  MissileControl      <unit_missile_delay.lua>
[f=0000000] Loaded gadget:  Napalm              <lups_napalm.lua>
[f=0000000] Loaded gadget:  NoCost              <cmd_nocost.lua>
[f=0000000] Loaded gadget:  PassiveBuilders     <unit_passive_builders.lua>
[f=0000000] Loaded gadget:  Reclaim Fix         <unit_reclaim_fix.lua>
[f=0000000] Loaded gadget:  ShieldDrain         <unit_shield_watch.lua>
[f=0000000] Loaded gadget:  Shockwaves          <lups_shockwaves.lua>
[f=0000000] Loaded gadget:  Start Point Remover Gadget  <init_start_point_remover_gadget.lua>
[f=0000000] Loaded gadget:  fx_reclaim_shards   <fx_reclaim_shards.lua>
[f=0000000] Loaded gadget:  mo_enemywrecks      <mo_enemywrecks.lua>
[f=0000000] Loaded gadget:  mo_greenfields      <mo_greenfields.lua>
[f=0000000] Loaded gadget:  mo_noowner          <mo_noowner.lua>
[f=0000000] Loaded gadget:  mo_noshare          <mo_noshare.lua>
[f=0000000] Loaded gadget:  mo_nowrecks         <mo_nowrecks.lua>
[f=0000000] Loaded gadget:  prevent_flying_com_wrecks  <unit_prevent_flying_com_wrecks.lua>
[f=0000000] Loaded gadget:  Area Attack         <areaattack.lua>
[f=0000000] Loaded gadget:  C Is For Control    <comiscontrol.lua>
[f=0000000] Loaded gadget:  LupsSyncedManager   <lups_manager.lua>
[f=0000000] Loaded gadget:  Mex Upgrader Gadget  <unit_mex_upgrader.lua>
[f=0000000] Loaded gadget:  Lups                <lups_wrapper.lua>
[f=0000000] Loading LuaGaia
[f=0000000] Loading LuaUI
[f=0000000] Using LUAUI_DIRNAME = LuaUI/
[f=0000000] Reloaded ctrlpanel with: LuaUI/ctrlpanel.txt
[f=0000000] LuaUI: bound F11 to the widget selector
[f=0000000] LuaUI: bound CTRL+F11 to tweak mode
[f=0000000] Loading widget from mod:   Red_UI_Framework    <red_ui_framework.lua> ...
[f=0000000] Loading widget from mod:   BlurApi             <api_gfx_blur.lua> ...
[f=0000000] Loading widget from mod:   MexUpg Helper       <helper.lua> ...
[f=0000000] Loading widget from mod:   Red Tooltip         <gui_red_tooltip.lua> ...
[f=0000000] Loading widget from mod:   HealthBars          <unit_healthbars.lua> ...
[f=0000000] Loading widget from mod:   BuildETA            <gui_build_eta.lua> ...
[f=0000000] Loading widget from mod:   Auto First Build Facing  <autofirstbuildfacing.lua> ...
[f=0000000] Loading widget from mod:   Autoquit            <autoquit.lua> ...
[f=0000000] Loading widget from mod:   Build Split         <cmd_buildsplit.lua> ...
[f=0000000] Loading widget from mod:   CustomIcons         <unit_customicons.lua> ...
[f=0000000] Loading widget from mod:   Loop Select         <unit_loop_select.lua> ...
[f=0000000] Loading widget from mod:   MoreSounds          <unit_more_sounds.lua> ...
[f=0000000] Loading widget from mod:   MohoExploiter       <unit_moho_exploiter.lua> ...
[f=0000000] MohoExploiter widget disabled for spectators
[f=0000000] Loading widget from mod:   Pause Screen        <gui_pausescreen.lua> ...
[f=0000000] Loading widget from mod:   Defense Range       <gui_defenserange.lua> ...
[f=0000000] Loading widget from mod:   Point Tracker       <gui_point_tracker.lua> ...
[f=0000000] Loading widget from mod:   NoDuplicateOrders   <cmd_no_duplicate_orders.lua> ...
[f=0000000] Loading widget from mod:   ReclaimInfo         <gui_reclaiminfo.lua> ...
[f=0000000] Loading widget from mod:   Red Build/Order Menu  <gui_red_buildordermenu.lua> ...
[f=0000000] Loading widget from mod:   Red Console         <gui_red_console.lua> ...
[f=0000000] Loading widget from mod:   Red Resource Bars   <gui_red_resourcebars.lua> ...
[f=0000000] Loading widget from mod:   GameTypeInfo        <gui_game_type_info.lua> ...
[f=0000000] Loading widget from mod:   Red_Drawing         <red_ui_framework_drawing.lua> ...
[f=0000000] Loading widget from mod:   Share Tracker       <unit_share_tracker.lua> ...
[f=0000000] Loading widget from mod:   Transporting        <gui_transporting.lua> ...
[f=0000000] Loading widget from mod:   XrayHighlight       <gui_xray_highlight.lua> ...
[f=0000000] Loading widget from mod:   ComCounter          <unit_com_counter.lua> ...
[f=0000000] Loading widget from mod:   Ghost Site          <unit_ghostsite.lua> ...
[f=0000000] Loading widget from mod:   Take Reminder       <gui_take_remind.lua> ...
[f=0000000] Loading widget from mod:   Attack AoE          <gui_attack_aoe.lua> ...
[f=0000000] Loading widget from mod:   Prospector          <gui_prospector.lua> ...
[f=0000000] Loading widget from mod:   Red Minimap         <gui_red_minimap.lua> ...
[f=0000000] Loading widget from mod:   BA Waypoint Dragger  <unit_waypoint_dragger_2.lua> ...
[f=0000000] Loading widget from mod:   LupsManager         <gfx_lups_manager.lua> ...
[f=0000000] Loading widget from mod:   BA_AllyCursors      <gui_ba_ally_cursors.lua> ...
[f=0000000] Loading widget from user:  Mouse Buildspacing  <gui_buildspacing.lua> ...
[f=0000000] Loading widget from mod:   Lups                <lups_wrapper.lua> ...
[f=0000000] Loading widget from mod:   CustomFormations2   <unit_customformations2.lua> ...
[f=0000000] LuaUI v0.3
[f=0000000] Finalizing...
[f=0000000] <Ghost Site> Spectator mode. Widget removed.
[f=0000000] Connection attempt from invalid
[f=0000000]  -> Version: 0.82.7.0 (0.82.7)
[f=0000000]  -> Connection established (given id 0)
[f=0000000] Spectator invalid finished loading and is now ingame
[f=0000000] GameID: 84894f4d2008a34c7a1e4c4679b8f899
[f=0000000] ERROR: Initializing AI Interface library from file "C:\Program Files (x86)\Spring\AI\Interfaces\Java\0.1\AIInterface.dll". The call to initStatic() returned unsuccessfuly.
[f=0000003] Skirmish AI "Bot1", which controlled team 0 is now dead
[f=0000003] Skirmish AI "Bot2", which controlled team 1 is now dead
[f=0000030] <DefenseRange> Spectator mode. Widget removed.
[f=0000091] Game has ended
[f=0000091] <autoquit> Automatically exiting in 12 seconds. Move mouse to cancel.
[f=0000100] <autoquit> Autoquit canceled.
[f=0000289] Red_UI_Framework>> last processed widget was "Red Tooltip"
[f=0000289] Red_Drawing>> last processed widget was "Red Tooltip"
[f=0000289] Path cache hits 0 0%
[f=0000289] Path cache hits 0 0%
[f=0000289] Statistics for local connection:
Received: 1416 bytes
Sent: 3094 bytes
any tips? I tried re-installing Spring engine but that didn't fix it.
0 x

abma
Spring Developer
Posts: 3540
Joined: 01 Jun 2009, 00:08

Re: The call to initStatic() returned unsuccessfuly.

Post by abma » 07 Feb 2011, 11:52

maybe spring couldn't find your installed java?

what does <spring writeable dir>/AI/Interfaces/Java/0.1/log/interface-log.txt say?
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: The call to initStatic() returned unsuccessfuly.

Post by hoijui » 07 Feb 2011, 14:37

when posting a log file, post it as attached file (or through pastebin), not like you did.

read the announcement about pureint in this forum (top-most topic). i recommend basing new work on that. pureint should have better error reporting already.
0 x

msm8bball
Posts: 52
Joined: 09 Oct 2009, 08:08

Re: The call to initStatic() returned unsuccessfuly.

Post by msm8bball » 22 Feb 2011, 19:52

abma wrote:maybe spring couldn't find your installed java?

what does <spring writeable dir>/AI/Interfaces/Java/0.1/log/interface-log.txt say?
It looks like you may be right. But it was working before....
How would I go about pointing it to the JRE?
Attachments
interface-log.txt
(563 Bytes) Downloaded 54 times
0 x

abma
Spring Developer
Posts: 3540
Joined: 01 Jun 2009, 00:08

Re: The call to initStatic() returned unsuccessfuly.

Post by abma » 23 Feb 2011, 08:38

it looks like you've a 64 bit windows. do you have a 32bit java installed? as spring is 32 bit, it requires a 32 bit jre.

as the log says, you can then specify the environment var JAVA_HOME, where java is installed...

but as hoijui already said, if you want to develop an ai, please use the current spring developement version.
0 x

msm8bball
Posts: 52
Joined: 09 Oct 2009, 08:08

Re: The call to initStatic() returned unsuccessfuly.

Post by msm8bball » 24 Feb 2011, 01:55

abma wrote:it looks like you've a 64 bit windows. do you have a 32bit java installed? as spring is 32 bit, it requires a 32 bit jre.

as the log says, you can then specify the environment var JAVA_HOME, where java is installed...

but as hoijui already said, if you want to develop an ai, please use the current spring developement version.
Thanks, I'll check the JRE version.

What did you mean "as the log says"? I scanned through the log and didn't see anything about Java mentioned. Was there something in there that I missed, but you knew what to look for?
0 x

abma
Spring Developer
Posts: 3540
Joined: 01 Jun 2009, 00:08

Re: The call to initStatic() returned unsuccessfuly.

Post by abma » 24 Feb 2011, 03:05

"Failed locating a JRE installation, you may specify the JAVA_HOME env var."


in console do something like:

Code: Select all

cd \path\to\spring
set JAVA_HOME=C:\Path\To\Java
spring.exe
0 x

msm8bball
Posts: 52
Joined: 09 Oct 2009, 08:08

Re: The call to initStatic() returned unsuccessfuly.

Post by msm8bball » 24 Feb 2011, 03:18

abma wrote:"Failed locating a JRE installation, you may specify the JAVA_HOME env var."


in console do something like:

Code: Select all

cd \path\to\spring
set JAVA_HOME=C:\Path\To\Java
spring.exe
I don't see a line in the log file that says "Failed locating a JRE installation, you may specify the JAVA_HOME env var." I'm kind of confused now.

All the other functional AI's (everything but NullOOJavaAI and mine) seem to work just fine. If my JRE wasn't configured right, wouldn't those AI's fail to work?
0 x

abma
Spring Developer
Posts: 3540
Joined: 01 Jun 2009, 00:08

Re: The call to initStatic() returned unsuccessfuly.

Post by abma » 24 Feb 2011, 14:24

the other ai's are written in c++, so these need no jre, afaik in special jvm.dll.

look into your posted interface-log.txt, there is the line i talked about.
0 x

User avatar
AF
AI Developer
Posts: 20667
Joined: 14 Sep 2004, 11:32

Re: The call to initStatic() returned unsuccessfuly.

Post by AF » 25 Feb 2011, 13:34

Shard AAI KAIK and RAI have no java or JRE of any kind.

If there was you'd see an AF thread complaining loudly about it demanding the removal of an unwanted dependency
0 x

kfriars
Posts: 36
Joined: 28 Sep 2011, 01:00

Re: The call to initStatic() returned unsuccessfuly.

Post by kfriars » 09 Mar 2012, 12:10

Hey,
So I am having the exact same problem as was being described here and have followed it up to this point. I am on windows 64 bit and after installing the 32bit jre and pointed the JAVA_HOME environment variable to it i am getting the following error in my interface-log

"Failed locating the client version of the JVM, please contact spring devs"

Any help is appreciated.
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: The call to initStatic() returned unsuccessfuly.

Post by hoijui » 09 Mar 2012, 12:49

please give the whole infolog and java interface log, the value of your JAVA_HOME env var, and a directory listing of the dir that var points to.
use pastebin.com or attach all these files to the forum post.
0 x

kfriars
Posts: 36
Joined: 28 Sep 2011, 01:00

Re: The call to initStatic() returned unsuccessfuly.

Post by kfriars » 09 Mar 2012, 13:05

JAVA_HOME = C:\Program Files (x86)\Java\jre6

interface-log
http://pastebin.com/mbaADuFM

infolog.txt
http://pastebin.com/hmRbwn2W

dir output of C:\Program Files (x86)\Java\jre6
http://pastebin.com/pgxM3FnF
0 x

msm8bball
Posts: 52
Joined: 09 Oct 2009, 08:08

Re: The call to initStatic() returned unsuccessfuly.

Post by msm8bball » 09 Mar 2012, 16:25

kfriars wrote:JAVA_HOME = C:\Program Files (x86)\Java\jre6

interface-log
http://pastebin.com/mbaADuFM

infolog.txt
http://pastebin.com/hmRbwn2W

dir output of C:\Program Files (x86)\Java\jre6
http://pastebin.com/pgxM3FnF
My JRE home is set to C:\Program Files (x86)\Java\jdk1.6.0_26\bin
0 x

kfriars
Posts: 36
Joined: 28 Sep 2011, 01:00

Re: The call to initStatic() returned unsuccessfuly.

Post by kfriars » 09 Mar 2012, 17:05

Just downloaded newest jdk and set JAVA_HOME to C:\Program Files (x86)\Java\jdk1.7.0_03\bin and received the same result.
0 x

kfriars
Posts: 36
Joined: 28 Sep 2011, 01:00

Re: The call to initStatic() returned unsuccessfuly.

Post by kfriars » 09 Mar 2012, 17:13

Forgot to mention i also tried with jdk1.6.0_31
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: The call to initStatic() returned unsuccessfuly.

Post by hoijui » 09 Mar 2012, 22:26

looking at the code, i currently have two ideas of what might be going wrong:
A) there is a jre-location.txt file somewhere (i think it would have to be in the Java AI Interface dir, could be in the global data dir too though.. best check your whole harddrive ;-)
if you find it, best is to delete it.

the order in which the spring Java AI Interface searches the JVM:
1. jre-location.txt
2. JAVA_HOME env var
3. OS specific (eg registry on windows)

B) there is a problem in the AI Interface code .. somewhere :D

i made a small patch to output the path of the JRE that is actually being used.
please try it with this spring:
http://springrts.com/dl/buildbot/defaul ... -ga636f02/
(installer is the first file)
the JRE path will appear in the interface-log.
0 x

msm8bball
Posts: 52
Joined: 09 Oct 2009, 08:08

Re: The call to initStatic() returned unsuccessfuly.

Post by msm8bball » 15 May 2016, 00:29

I'm having this same issue again. Tried leaving JAVA_HOME unset, tried setting it to C:\Program Files (x86)\Java\jdk1.7.0_55\bin and C:\Program Files (x86)\Java\jdk1.7.0_55.

No luck. Any ideas?
Attachments
infolog.txt
(35.56 KiB) Not downloaded yet
0 x

abma
Spring Developer
Posts: 3540
Joined: 01 Jun 2009, 00:08

Re: The call to initStatic() returned unsuccessfuly.

Post by abma » 15 May 2016, 00:38

please test with the spring >= 101.0.1-354-g2614c5c. it will log ai interfaces errors to infolog.txt (again) and hopefully show what the problem is.

https://springrts.com/dl/buildbot/default/develop/
0 x

abma
Spring Developer
Posts: 3540
Joined: 01 Jun 2009, 00:08

Re: The call to initStatic() returned unsuccessfuly.

Post by abma » 17 May 2016, 14:11

should be fixed with https://github.com/spring/spring/commit ... 0a9ddaff5a

please try again with >= spring 101.0.1-373-g9d13eb6
0 x

Post Reply

Return to “AI”