Spring crashes while loading any mod

Spring crashes while loading any mod

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.

Moderator: Moderators

richardba
Posts: 5
Joined: 08 Jul 2010, 23:14

Spring crashes while loading any mod

Post by richardba » 14 Aug 2010, 05:50

Hello there, Spring is crashing after I updated Spring Engine to latest version when it loads any mod

Here goes a infolog file with the last crash while trying to load BA7.14
Attachments
infolog.txt
(7.41 KiB) Downloaded 152 times
0 x

slogic
AI Developer
Posts: 626
Joined: 17 Mar 2008, 19:03

Re: Spring crashes while loading any mod

Post by slogic » 14 Aug 2010, 06:42

Downgrade to Catalyst 10.4.
0 x

User avatar
Licho
Zero-K Developer
Posts: 3803
Joined: 19 May 2006, 19:13

Re: Spring crashes while loading any mod

Post by Licho » 14 Aug 2010, 10:12

Catalyst 10.4 has no shadows for me (and no bump water and no lups jitter effect)
0 x

slogic
AI Developer
Posts: 626
Joined: 17 Mar 2008, 19:03

Re: Spring crashes while loading any mod

Post by slogic » 14 Aug 2010, 10:44

Then low a bit to 10.3. I have both shadows and bump water.
0 x

User avatar
Licho
Zero-K Developer
Posts: 3803
Joined: 19 May 2006, 19:13

Re: Spring crashes while loading any mod

Post by Licho » 14 Aug 2010, 12:04

Including shorewaves and without horizontal artifacts?
0 x

slogic
AI Developer
Posts: 626
Joined: 17 Mar 2008, 19:03

Re: Spring crashes while loading any mod

Post by slogic » 14 Aug 2010, 12:58

Generally yes. See images.
Attachments
screen00071.png
The _most_ minimal zoom, i see... artefacts? right?
(1.03 MiB) Downloaded 8 times
screen00070.png
Close enough view, no visible artefacts
(977.66 KiB) Downloaded 8 times
0 x

User avatar
Licho
Zero-K Developer
Posts: 3803
Joined: 19 May 2006, 19:13

Re: Spring crashes while loading any mod

Post by Licho » 14 Aug 2010, 15:47

Wow cool, must try it. Lups is completely dead for me at 10.4 now (it used to work pre 82
0 x

richardba
Posts: 5
Joined: 08 Jul 2010, 23:14

Re: Spring crashes while loading any mod

Post by richardba » 14 Aug 2010, 21:57

downgrading to 10.04 gives me compatibility with Spring, however it has other specific problems with other games and also will reduce my game performance
0 x

richardba
Posts: 5
Joined: 08 Jul 2010, 23:14

Re: Spring crashes while loading any mod

Post by richardba » 15 Aug 2010, 19:07

I still can't play Spring, even downgrading to 10.4 it still gives a lot of errors, this release does not natively support 1920x1080 resolution, also the only way to play Spring is choosing lowest configuration in spring settings, because when I choose high detail or even normal the game crashes I'm really disappointed coz Spring 0.80 does not crash with Catalyst 10.4.
Attachments
infolog.txt
(10.88 KiB) Downloaded 109 times
0 x

richardba
Posts: 5
Joined: 08 Jul 2010, 23:14

Re: Spring crashes while loading any mod

Post by richardba » 17 Aug 2010, 03:31

I've made a rollback, I tried 10.3, 10.2, 10.1 drivers, all of them report the same error, with different exception handlers, I cannot run spring with any eye candy, it crashes before the start of the game, I don't know what to do, this hurts me a lot because I love spring and it is the only good open source RTS out there and IMO one of the best RTS games since original TA

I've been able to play the game only and once with Spring 0.83 release

can someone give me a light? Mine is dimming
0 x

User avatar
CarRepairer
Cursed Zero-K Developer
Posts: 3359
Joined: 07 Nov 2007, 21:48

Re: Spring crashes while loading any mod

Post by CarRepairer » 17 Aug 2010, 07:21

richardba wrote:I've made a rollback, I tried 10.3, 10.2, 10.1 drivers, all of them report the same error, with different exception handlers, I cannot run spring with any eye candy, it crashes before the start of the game, I don't know what to do, this hurts me a lot because I love spring and it is the only good open source RTS out there and IMO one of the best RTS games since original TA

I've been able to play the game only and once with Spring 0.83 release

can someone give me a light? Mine is dimming
www.nvidia.com

I'm so sorry, but his story was heartbreaking.
0 x

User avatar
manolo_
Posts: 1370
Joined: 01 Jul 2008, 00:08

Re: Spring crashes while loading any mod

Post by manolo_ » 17 Aug 2010, 08:12

i have the same problem with 10.4, it worked fine with previous spring version
0 x

Chamrin
Posts: 33
Joined: 05 Mar 2010, 12:31

Re: Spring crashes while loading any mod

Post by Chamrin » 17 Aug 2010, 14:02

You said it worked once, then it didn't work again. This bug is probably the problem: http://springrts.com/phpbb/viewtopic.ph ... 89#p443989

If you're playing BA, backup then delete the Spring\LuaUI\Config\BA.lua file. If another mod, do the same with the appropriate config file. It should work.
0 x

Klopper
Posts: 146
Joined: 10 Jan 2007, 14:31

Re: Spring crashes while loading any mod

Post by Klopper » 17 Aug 2010, 22:57

In Spring settings, do NOT have dynamic clouds and high-res clouds activated AT THE SAME TIME! It will give you the dreaded atioglxx.dll driver crash (at least for me, i have a Radeon 4870 and am using the Catalyst 10.7 Beta OpenGL ES 2.0 drivers which Yuri linked to, they resolved my old driver crash issues). If you have only one of the two settings activated it works fine.
0 x

Klopper
Posts: 146
Joined: 10 Jan 2007, 14:31

Re: Spring crashes while loading any mod

Post by Klopper » 18 Aug 2010, 00:05

Another strange thing just figured out: If using bump-mapped water, using shorewaves ONLY works on maps with water, but will cause the driver crash for maps WITHOUT water.
0 x

Gouken
Posts: 35
Joined: 18 Aug 2010, 22:55

Re: Spring crashes while loading any mod

Post by Gouken » 19 Aug 2010, 20:17

slogic wrote:Downgrade to Catalyst 10.4.
Spring needz to make itself compatible with ATI otherwise its a piece of crap

all computers are ATI these days

I demand a refund!
0 x

Gouken
Posts: 35
Joined: 18 Aug 2010, 22:55

Re: Spring crashes while loading any mod

Post by Gouken » 19 Aug 2010, 21:43

I just got 10.4 and it still crashes every time, wat do?
0 x

User avatar
maackey
Posts: 490
Joined: 02 Jul 2008, 07:11

Re: Spring crashes while loading any mod

Post by maackey » 19 Aug 2010, 22:33

Gouken wrote:
slogic wrote:Downgrade to Catalyst 10.4.
Spring needz to make itself compatible with ATI otherwise its a piece of crap
There are more respectful ways to encourage support for things. Some people (the wonderful developers who spend a lot of their free time making spring) might take offense to your statement.
all computers are ATI these days
objectively false -- no trolling please :regret:
I demand a refund!
Fill out the warranty card 3.05a in the wiki and we'll send your money back asap.
0 x

User avatar
CarRepairer
Cursed Zero-K Developer
Posts: 3359
Joined: 07 Nov 2007, 21:48

Re: Spring crashes while loading any mod

Post by CarRepairer » 19 Aug 2010, 23:03

Gouken wrote:ATI needz to make itself compatible with Spring otherwise its a piece of crap

Why even buy an ATI these days

I demand a refund!
Fixed.
0 x

slogic
AI Developer
Posts: 626
Joined: 17 Mar 2008, 19:03

Re: Spring crashes while loading any mod

Post by slogic » 20 Aug 2010, 14:52

Here is screenshot with my graphics options which are compatible with Spring 0.82.3. I have HD5770 and i'm using Catalyst 10.3. Hope this will help ATI users.
Image

I would like to note that enabling "Use Pixelbuffer objects" gives me a crash. I'm sure that enabling some other options (compare with your own) may easily crash Spring.
Attachments
Clipboard01.jpg
(78.78 KiB) Downloaded 8 times
0 x

Post Reply

Return to “Help & Bugs”