Search

Search found 28 matches

by jpcordovae
20 Aug 2012, 19:06
Forum: Engine
Topic: Engine Testing - 10. Aug 2012 (89.0.1-87-gce4d36e)
Replies: 43
Views: 3766

Re: Engine Testing - 10. Aug 2012 (89.0.1-87-gce4d36e)

HI to all, I have an error compiling this spring branch as you can see here:

http://pastebin.com/f3eFu7JZ

boost version: 1.49
gcc version 4.7.1 (GCC)

JP
by jpcordovae
08 Aug 2012, 16:54
Forum: Linux
Topic: Slackware 13.37 and 14.0 packages update
Replies: 0
Views: 743

Slackware 13.37 and 14.0 packages update

There is a new release of Slackware packages, I try to maintain the same packages from the default release, but I use multilib and the change to gcc 4.7.1 force me to make an update of boost libraries, I hope this run in 13.37 x86_64 without problems. A script download and install the packages requi...
by jpcordovae
07 Aug 2012, 16:36
Forum: Engine
Topic: spring compilation error boost 1.50
Replies: 6
Views: 1226

Re: spring compilation error boost 1.50

I left you a link to gcc 4.7 porting code documentation, to keep in mind.

http://gcc.gnu.org/gcc-4.7/porting_to.html

JP
by jpcordovae
07 Aug 2012, 16:34
Forum: Linux
Topic: Oldest compiler?
Replies: 4
Views: 1419

Re: Oldest compiler?

There is a document for gcc 4.7 porting code, very useful.

http://gcc.gnu.org/gcc-4.7/porting_to.html

JP
by jpcordovae
05 Aug 2012, 18:03
Forum: Linux
Topic: Oldest compiler?
Replies: 4
Views: 1419

Re: Oldest compiler?

I maintain springrts package for slackware, and I use gcc 4.7.1 (Slackware 14 default gcc package), and that is a problem because libboost_thread.so is disable until 1.45 boost version. From boost 1.48 and forward, multithread works fine again. And I have serious problems compiling springlobby, I'll...
by jpcordovae
02 Aug 2012, 14:25
Forum: Engine
Topic: spring compilation error boost 1.50
Replies: 6
Views: 1226

Re: spring compilation error boost 1.50

@Tobi, except for TIME_UTC issue, it works perfect !!

I left the patch to fix the boost 1.50 TIME_UTC issue in the next link, it should work no matter what version of boost you use.

http://pastebin.com/ZtFCuD4Y

Thanks you guys.

JP
by jpcordovae
02 Aug 2012, 01:00
Forum: Engine
Topic: spring compilation error boost 1.50
Replies: 6
Views: 1226

Re: spring compilation error boost 1.50

Thanks you very much, I'll take a look to the patch.

JP
by jpcordovae
01 Aug 2012, 22:30
Forum: Engine
Topic: spring compilation error boost 1.50
Replies: 6
Views: 1226

spring compilation error boost 1.50

HI to all, well, I was updating boost libs to 1.50 and I wasn't able to compile spring by two reason until now, first, boost::TIME_UTC was renamed to boost::TIME_UTC_ , not big deal, easy to patch, but then an error over an overloaded function :( , like seems to me that is a boost problem. I hope yo...
by jpcordovae
23 Jul 2012, 16:24
Forum: Linux
Topic: What Linux Distros are you using?
Replies: 28
Views: 2544

Re: What Linux Distros are you using?

Slackware here, the oldest distribution (still kicking)..., all system configs in files, you must know what are you doing to use it, it is perfect to learn Linux and subsystems. This distribution have a native 64b package repository, and ARM flavor too. If you like tweak you system, slackware is the...
by jpcordovae
18 Jul 2012, 15:24
Forum: Linux
Topic: Slackware Wiki Update
Replies: 5
Views: 1261

Re: Slackware Wiki Update

Hi, well, the MT run smoother in Linux, and graphics are better from my perception (I have no real metrics), but in Win7 it runs very well since 0.82 version. And about installation, go to the wiki http://springrts.com/wiki/Slackware12_install and install the packages that you can find in the wiki (...
by jpcordovae
16 May 2012, 22:24
Forum: Linux
Topic: Slackware Wiki Update
Replies: 5
Views: 1261

Re: Slackware Wiki Update

No, it is not the script what I was looking for. The script spring.SlackBuild (or any xxx.SlackBuild) is a script used to select architecture, patch code , compiler options (--libdir options for example in 64b distribution), install directories, and anything relative to slackware distribution before...
by jpcordovae
18 Apr 2012, 13:06
Forum: Linux
Topic: Slackware Wiki Update
Replies: 5
Views: 1261

Slackware Wiki Update

Hi everybody, I just made some updates to the Slackware wiki, and sad to say that due the close of megauload we lost the script that I had made to make automatic install of the packages and stuff, so if someone already have it, please sent it to me asap to put it in another host that I have (private...
by jpcordovae
28 Nov 2011, 12:34
Forum: Engine
Topic: Stereoscopy for Spring (3D)
Replies: 8
Views: 1160

Re: Stereoscopy for Spring (3D)

CarRepairer wrote:My widget is not a perfect solution. This should be implemented on the engine level. I've wanted to do so for a long time but I would need help.
I wish like to help if you want too, contact me at jpcordovae@gmail.com

JP
by jpcordovae
23 Sep 2011, 19:54
Forum: Engine
Topic: Stereoscopy for Spring (3D)
Replies: 8
Views: 1160

Re: Stereoscopy for Spring (3D)

lol, ok, I'll search better next time, ty.

[DoR]MelKor
by jpcordovae
23 Sep 2011, 19:23
Forum: Engine
Topic: Stereoscopy for Spring (3D)
Replies: 8
Views: 1160

Stereoscopy for Spring (3D)

I want to try to make stereoscopy (3D) for SpringRTS, I work with 3D for Unity3D based software, and probably can I export the changes inside SpringRTS engine (I'm worried about MT), but before I wish like to know if was another attempt to do it, I have searched inside forums and found nothing. If s...
by jpcordovae
14 May 2011, 18:15
Forum: Linux
Topic: Slackware repository updated
Replies: 1
Views: 568

Slackware repository updated

I have made install scripts for Slackware distribution (http://springrts.com/wiki/Slackware12_install), that because can be very painful install packager, or even make packages using slackbuild scripts for new people. This installer add directories, springlobby, few maps and Battle Anihilation + KZe...
by jpcordovae
26 Feb 2011, 12:48
Forum: Lua Scripts
Topic: script dont work
Replies: 8
Views: 810

Re: script dont work

I make it works, the problem was between kb and screen: me, like almost the time, if you see in posted code, I never put the word then after the if . Anyway, spring don't say anything about error or something like that. I've disassembled the mod and I find all I need to make any script. It isn't cle...
by jpcordovae
26 Feb 2011, 03:06
Forum: Lua Scripts
Topic: script dont work
Replies: 8
Views: 810

Re: script dont work

That widget you linked to does exactly what you are trying to do, so your effort is quite redundant :S. It is already enabled by default so there should be no work required. The script I show it's mine, the original is a bit shorter, but make almost the same., I think is the best way to learn, take...
by jpcordovae
26 Feb 2011, 01:23
Forum: Lua Scripts
Topic: script dont work
Replies: 8
Views: 810

Re: script dont work

I found hardcoded names in few scripts, you can check at http://code.google.com/p/zero-k/source/browse/trunk/mods/zk/LuaUI/Widgets/unit_marker.lua?spec=svn957&r=957 Anyway, I cant load any new widget. --MARKER LIST ------------------------------------ NEED TO UPDATE CA1F TO ZK WHEN MOD UPDATES. unit...
by jpcordovae
26 Feb 2011, 01:20
Forum: Kernel Panic
Topic: Setup-script does not exist
Replies: 11
Views: 5515

Re: Setup-script does not exist

Sorry guys, I have too many firefox tabs open and I get confused, my original post in this thread was a mistake, sorry !!! I was able to launch the script, in launching it manually with spring in the terminal. how you did it ? /luaui script.lua ?? because I try, but don't work for me. MK I think he ...

Go to advanced search