View topic - 85.0 on debian squeeze (no sound)


All times are UTC + 1 hour


Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: 14 Jan 2012, 16:13 

Joined: 14 Jan 2012, 16:00
Ever since 0.82.7.1 I have been trying to get spring to work with sound, with no luck at all. Back around the time of 0.82.7.1 I was compiling from source, but yesterday on my fresh install of squeeze amd64 I installed 85.0 using the wheezy repos. Game runs almost perfect, still no sound.

I have been in and out of the irc many times and many people have told me to disable pulse, but how exactly do I do that? Spring itself is not calling/using pulse, but does detect it in my infolog.txt

If anyone could help me out as to what I should do next that would awesome! I don’t really get on spring anymore because of this reason, and rarely log on to my windows partition, but anyways all help would be appreciated!

infolog.txt: http://pastebin.com/LVR0HnP4
Top
 Offline Profile  
 
PostPosted: 14 Jan 2012, 16:35 
Spring Developer
User avatar

Joined: 22 Sep 2007, 08:51
how to remove pulseaudio from your system depends on your distro (and versions). it is independent of spring. i dont know how to do it for your system. maybe try google. pulseaudio is generally buggy, lots of people have to remove it (not only spring players), so there should also be guides that fit for you.
Top
 Offline Profile  
 
PostPosted: 14 Jan 2012, 19:14 

Joined: 14 Jan 2012, 16:00
I have successfully purged pulse from my system, when I currently check the infolog.txt pulse is nowhere to be found. However there is still absolutely no sound in spring. What is the next step I should take?

infolog.txt: http://pastebin.com/LTRaHjE1
Top
 Offline Profile  
 
PostPosted: 14 Jan 2012, 23:16 
Spring Developer
User avatar

Joined: 22 Sep 2007, 08:51
Quote:
[f=0000000] [Sound] Available Devices:
[f=0000000] [Sound] ALSA Software
[f=0000000] [Sound] PortAudio Software
[f=0000000] [Sound] Device: ALSA Software

try to use the other device, by putting this in your spring settings (~/.springrc):
Quote:
snd_device=PortAudio Software
... at least i hope it will work this way.
Top
 Offline Profile  
 
PostPosted: 15 Jan 2012, 00:35 

Joined: 14 Jan 2012, 16:00
Just tried that, no luck at all :(
Top
 Offline Profile  
 
PostPosted: 17 Jan 2012, 03:45 

Joined: 14 Jan 2012, 16:00
Solved by using this: http://springrts.com/wiki/FAQ:trouble#Sound

Code:
sudo apt-get install alsoft-conf
alsoft-conf

In the "backend" tab, keep only "ALSA" on the left column, then save. Done!
Side Note: ALSA is redirected to the PulseAudio layer when installed.

Thanks hoijui for the help in the irc :)
Top
 Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Site layout created by Roflcopter et al.