View topic - Test build for 0.82



All times are UTC + 1 hour


Post new topic Reply to topic  [ 14 posts ] 
Author Message
 Post subject: Test build for 0.82
PostPosted: 18 Jul 2010, 15:12 
Spring Developer

Joined: 01 Jun 2005, 10:36
Location: The Netherlands
With this post I'd like to urge everyone to test the following build from the latest Spring sourcecode, and tell us whether it works correctly or not. When it does not work correctly, please back up your statement by filing a bug in our bug tracker.

Here is a link to the installer:

http://springrts.com/dl/buildbot/defaul ... 7e87ab.exe

Other related files can found here:

http://springrts.com/dl/buildbot/defaul ... -ge7e87ab/

The source code can be checked out from github commit e7e87ab.

On Linux this code can be build by following approximately these steps:


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 18 Jul 2010, 17:26 
Spring Developer

Joined: 24 Jun 2007, 07:34
Location: 50┬░ 56' N, 11┬░ 35' O
Time to build it is increased big time when all of GML / HL / default are build. Are there any flags to disable / enable them seperately?

Apart from that, build worked nicely, will do some test later on.


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 18 Jul 2010, 17:31 
Spring Developer
User avatar

Joined: 28 Jun 2007, 06:30
Auswaschbar wrote:
Time to build it is increased big time when all of GML / HL / default are build. Are there any flags to disable / enable them seperately?

Apart from that, build worked nicely, will do some test later on.

Code:
make spring


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 18 Jul 2010, 17:40 
Spring Developer

Joined: 24 Jun 2007, 07:34
Location: 50┬░ 56' N, 11┬░ 35' O
Fabulous, but it will build the remaining stuff when "make install"ing, unless I miss something obvious.


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 18 Jul 2010, 17:47 
Spring Developer

Joined: 01 Jun 2005, 10:36
Location: The Netherlands
For that, we should have `make install-spring' now.


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 18 Jul 2010, 19:03 
Spring Developer
User avatar

Joined: 22 Sep 2007, 08:51
please join #playtest


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 19 Jul 2010, 13:35 
Balanced Annihilation Maintainer
User avatar

Joined: 10 Dec 2006, 18:46
When I looked at this in June I came up with
http://consternationstation.com/files/BA713beta.sd7 for BA if anyone else fancies running some tests.

I will however also look into this newer version this evening too.


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 19 Jul 2010, 23:38 
Lobby Developer
User avatar

Joined: 06 Dec 2007, 11:12
SpadsGit is currently running Spring version e7e87ab with BA713beta on springlobby.info lobby server.
This version of SPADS should support spoof protection through script passwords and in-game (re)join, but I can't test it easily right now.


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 20 Jul 2010, 19:09 
Kernel Panic Co-Developer
User avatar

Joined: 16 Nov 2004, 13:08
It doesn't work:

The error box I get.

The infolog.

I set the graphic to the min, same error.


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 20 Jul 2010, 19:28 
Lobby Developer

Joined: 16 Mar 2007, 18:27
zwzsg wrote:
It doesn't work:

The error box I get.

The infolog.

I set the graphic to the min, same error.

doesn't spring need at least GL 1.4 ?


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 20 Jul 2010, 19:42 
Spring Developer
User avatar

Joined: 22 Sep 2007, 08:51
indeed, your GFX setup looks quite borked...
you should not be able to run the release version on that machine either.


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 20 Jul 2010, 19:47 
Kernel Panic Co-Developer
User avatar

Joined: 16 Nov 2004, 13:08
Uh, I guess my graphic card just died then. :cry:


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 20 Jul 2010, 19:52 
Spring Developer
User avatar

Joined: 22 Sep 2007, 08:51
it looks more like your driver got fucked up, maybe use one of those driver cleaner programs and reinstall.


Top
 Offline Profile  
 
 Post subject: Re: Test build for 0.82
PostPosted: 20 Jul 2010, 21:01 
Kernel Panic Co-Developer
User avatar

Joined: 16 Nov 2004, 13:08
I'm confused, I only have that issue in windowed mode (both with 0.82 and 0.81), but in full screen mode, it works (both in 0.82 and 0.81). Anyway, so the problem is not related to that 0.82, feel free to delete my posts or split thread.


____________________

CreateUnitRulesParams is gone. But as jK said, if in trepan gadgets, they can just be deleted as they are followed by a SetUnitRulesParam.

Every I use Spring.Restart, the old Spring ends with an error. The new Spring is properly launched though: http://uppix.net/1/e/1/60feeebb8d81fd25 ... 8c341b.png


Top
 Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Site layout created by Roflcopter et al.