View topic - Spring 0.81.1.3 released



All times are UTC + 1 hour


Post new topic Reply to topic  [ 38 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Spring 0.81.1.3 released
PostPosted: 31 Jan 2010, 19:51 
Spring Developer

Joined: 01 Jun 2005, 10:36
Location: The Netherlands
So after the past two release candidates we're now proud te present the next real release:
Spring 0.81.1.3

Changes since the last release candidate:

Engine:
  • Fixed automatically assigning start position if none is chosen
  • Fixed bug in DXT5 loading (caused artifacts with teamcolors)
  • Fixed F1 heightmap view
  • Fixed playing of demos created in a game in which Spring crashed
  • Made spectator drawings white instead of random team color
  • Disable recording demos from demos (default, DemoFromDemo in springrc to enable)
  • Added a mechanism to register/unregister for messages that are normally not broadcasted to game server

AIs:
  • E323AI 3.14.5:
    • support for: partial watermaps (plays land only), group merging, auto kbot/vehicle lab selection, template configs
    • XTA & BA config improvements
    • Better lab assisting
  • KAIK: do not build MExes on spots used by allies

For changes since 0.80.5.2, easiest is to look here.


Thanks everyone for their contributions!


Download links:


To game developers: do not forget to adapt your game to the next version of Spring.
See the threads for details.


Have fun!


Top
 Offline Profile  
 
PostPosted: 31 Jan 2010, 21:03 
User avatar

Joined: 14 Aug 2009, 16:36
Location: UK
just though thanks are in order.

so thanks :) well done to all the hard workers


Top
 Offline Profile  
 
PostPosted: 31 Jan 2010, 21:11 
Moderator

Joined: 22 Aug 2006, 15:19
well done!


Top
 Offline Profile  
 
PostPosted: 31 Jan 2010, 22:33 
Community Representative
User avatar

Joined: 08 Sep 2008, 21:59
Location: small cars
thanks to all who contributed :D works great


Top
 Offline Profile  
 
PostPosted: 31 Jan 2010, 22:46 
Tournaments Moderator
User avatar

Joined: 08 Dec 2007, 17:39
Location: UK - England
Working smoothly for me. Nice job guys.


Top
 Offline Profile  
 
PostPosted: 31 Jan 2010, 23:05 
Moderator
User avatar

Joined: 26 Oct 2007, 15:21
Thanks for all your work!

A few things:
Seems like smoothmesh is strangely affecting the behaivior or bladewings, they hover up and down before attacking when close to hills.
Some people say minimap is darker, Im not sure of this myself.


Top
 Offline Profile  
 
PostPosted: 31 Jan 2010, 23:34 

Joined: 19 Apr 2005, 18:23
Been playing on my laptop for years and today this:

Missing minimal required OpenGL. Version is 1.4

Never had this problem before, updated drivers and it didnt fix it. Card is ATI MOBILITY/RADEON 9000


Top
 Offline Profile  
 
PostPosted: 31 Jan 2010, 23:36 
Moderator

Joined: 22 Aug 2006, 15:19
Beherith wrote:
Seems like smoothmesh is strangely affecting the behaivior or bladewings, they hover up and down before attacking when close to hills.
gunships can behave weirdly, they need further tuning wrt smoothmesh. mod can opt out on per-unit basis.


Top
 Offline Profile  
 
PostPosted: 01 Feb 2010, 00:17 
User avatar

Joined: 18 Nov 2009, 14:27
I saw an unsynced guy on dsd and we kicked him, unsynced people should be automaticaly kicked maybe?


Top
 Offline Profile  
 
PostPosted: 01 Feb 2010, 00:45 
Moderator

Joined: 19 May 2009, 20:10
triton wrote:
I saw an unsynced guy on dsd and we kicked him, unsynced people should be automaticaly kicked maybe?

You can't debug that if you get autokicked.


Top
 Offline Profile  
 
PostPosted: 01 Feb 2010, 07:05 
Skinner / Texturer
User avatar

Joined: 18 Oct 2005, 19:56
Location: Germany
would be great if somebody could update these installers too: http://springrts.com/wiki/GamesDownloads

Is there any way to see which version the installer has before download? there is no version included in filename and nothing on the page shows it.


Top
 Offline Profile  
 
PostPosted: 01 Feb 2010, 10:28 
Kernel Panic Co-Developer
User avatar

Joined: 16 Nov 2004, 13:08
I'll eventually update KP installer, but new Spring also breaks stuff in the mod, so I have to fix the mod, and if I do a new version of the mod it needs to to also include a couple updates I'm not done coding. Plus I have to do extensive testing to avoid rushing something broken.

The KP installer mention the engine version in its filename. The KP installer detect Spring version and do not reinstall the engine if you have a newer one, so you can just install it ontop of a new install done with the "official" installer. And last time I tried, if you a install a slightly outdated Spring version, the first time you connect to lobby it offers you to upgrade your Spring.

Are you really using those installers, or complaining for the sake of it? If there's really a need, I could rush a Spring 0.81.1.3 + Kernel Panic 3.8, but tbh I doubt there is such urgency.


Top
 Offline Profile  
 
PostPosted: 01 Feb 2010, 10:33 
Spring Developer
User avatar

Joined: 22 Sep 2007, 08:51
dogma, i am working on it.
it is a problem of initialization order.. rather ugly to fix (moving one thing to an earlier stage of the startup phase, breaks something else, ...).


Top
 Offline Profile  
 
PostPosted: 01 Feb 2010, 11:30 
Moderator

Joined: 12 Oct 2007, 08:24
I think teamcolor.lua is broken. Units often appeared with the wrong teamcolor in a 1v1. The other player did not use teamcolor.lua and had no problems.


Top
 Offline Profile  
 
PostPosted: 01 Feb 2010, 17:43 
Spring Developer
User avatar

Joined: 22 Sep 2007, 08:51
dogma:
AI stuff is fixed in master and will be in the next release; there will probably be a bug-fix release in the next few weeks.
until then, if you want to play against AIs, use this:

windows:
http://buildbot.eat-peet.net/spring/ins ... cb5ef1.exe
i recommend installing it in a separate folder.

linux (have to compile yourself):
bcb5ef185c405103a3053b0d629f57013cd613b2


Top
 Offline Profile  
 
PostPosted: 01 Feb 2010, 20:19 
Skinner / Texturer
User avatar

Joined: 18 Oct 2005, 19:56
Location: Germany
zwzsg wrote:
Are you really using those installers, or complaining for the sake of it? If there's really a need, I could rush a Spring 0.81.1.3 + Kernel Panic 3.8, but tbh I doubt there is such urgency.


These are the best installers at all, they are easy to use for unexperienced and new players because of the included module updater. Thats the reason why i only put these on spring-portal.

so yea i would be really happy if someone would update them :)


Top
 Offline Profile  
 
PostPosted: 01 Feb 2010, 23:48 
Conflict Terra Developer
User avatar

Joined: 17 Jan 2009, 22:37
Location: The drama continues
not working for me, had to upgrade from ubuntu 9.04 to 910 to get it due to it not being in the repos.
link to thread.


Top
 Offline Profile  
 
PostPosted: 02 Feb 2010, 03:42 
User avatar

Joined: 16 Nov 2005, 00:01
Location: Sunshine Coast, Australia
I have created a Mac OS X (Snow Leopard) build of this version (sorry no bundled lobby client yet - hopefully soon). See this thread.


Top
 Offline Profile  
 
PostPosted: 02 Feb 2010, 15:02 

Joined: 13 Jan 2009, 11:20
So you think you can stop me from using TASClient, huh?

Never gonna happen, TASClient 4 life 8)


Top
 Offline Profile  
 
PostPosted: 02 Feb 2010, 16:20 
User avatar

Joined: 02 May 2005, 02:56
Location: Canada
HectorMeyer wrote:
So you think you can stop me from using TASClient, huh?

Never gonna happen, TASClient 4 life 8)


TASClient is out at the maintainer's request... my interpretation of his reasoning is basically that the official Spring installer was installing the version from the time of the lastest spring release instead of the latest version... basically if a new TASClient version came out after the latest Spring people would have to update their TASClient the first time they ran it after a fresh install... It's still available on the official Download page.


Top
 Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 38 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: Exabot [Bot] and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Site layout created by Roflcopter et al.