View topic - SM3


All times are UTC + 1 hour


Post new topic Reply to topic  [ 212 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7, 8 ... 11  Next
Author Message
 Post subject: Re: SM3
PostPosted: 24 Aug 2009, 21:32 
Content Developer
User avatar

Joined: 13 Jan 2005, 00:46
so other than shadows what issues are there?
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 25 Aug 2009, 21:03 
Omnidouche
User avatar

Joined: 16 Oct 2004, 18:40
Location: Canada
People using crappy hosts like zshare?

More seriously... I'll give it a try and see how it compares on my oobrputer. If the download ever starts.

~~~~

I haven't tried with shadows on yet, but with them off nothing's going wrong.

Well, that's odd. I get 490 fps with nothing selected, just a commander spawned. If I select my commander, I get 260 fps.

On an SM2 map (sherwood) I get 210 fps with nothing selected and 160 with my commander selected.

I'm not sure what the reason for the sudden decline is - possibly my GUI is to blame, I have a lot of lua installed atm.

Anyways, shouldn't the performance drop be similar on SM2 or SM3? In the same scenario on a similar-sized map, I lose ~24% of my FPS in SM2 and ~47% in SM3.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 25 Aug 2009, 21:13 

Joined: 02 Jun 2009, 12:25
Hi,

I know of one more shadows issue I was even trying to chase down for some time. From certain camera angles the terrain shadows are ridiculously off (for instance spanning half of a map). Try to scroll out and mess with the angle a bit.

For a couple of weeks now I have been (and will be) without access to a decent computer so can't post screenshots. Will do it later though.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 04 Dec 2009, 09:06 
Content Developer
User avatar

Joined: 13 Jan 2005, 00:46
BUMP still has white shadows. system hangs etc....
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 04 Dec 2009, 18:51 
Spring Developer

Joined: 08 Oct 2006, 15:58
Neither problem is reproducable (by me). That unfortunately means neither is fixable (by me).

Being more specific about the conditions of these hangs ("when looking at the upper-left corner of map XYZ", "when viewing the terrain under extreme angles", etc) might also help, this sounds like a driver issue unless mine are somehow hiding both symptoms.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 04 Dec 2009, 19:36 
Content Developer
User avatar

Joined: 13 Jan 2005, 00:46
I can update my nvidia drivers yet again and see but I am running a 280gts I should be able to easily handle this map.

What I can tell you is on load there is an initial hang. it waits a bit then hangs again...

is there any kind of way to debug this sort of thing.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 04 Dec 2009, 21:28 
User avatar

Joined: 21 Feb 2005, 03:38
Location: Herding cats uphill whilst wearing roller skates.
Are you using DDS for the files? If not, you really should, it was designed for that format.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 04 Dec 2009, 22:06 
Content Developer
User avatar

Joined: 13 Jan 2005, 00:46
you and dds.... really coming across as pushy...

I am not sure DDS texture is the issue. i will convert the textures to DDS if you tell me what version I need to use so I don't have to do this more than once. Not using a map of my own, this is forbs narrow valley btw.

Also side note: Almost done with my harbor features. they will be pd and since I am doing them in gundam scale I will upload the .wings so you can scale them as needed.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 04 Dec 2009, 22:19 
User avatar

Joined: 21 Feb 2005, 03:38
Location: Herding cats uphill whilst wearing roller skates.
I'll go find that test map I made, see what it looks like. I am pretty sure I used DDS at the time, but I forget, it was over 2 years ago. You can test with that, if it's still working.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 04 Dec 2009, 22:22 
Content Developer
User avatar

Joined: 13 Jan 2005, 00:46
I will give it a shot if you upload it.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 04 Dec 2009, 22:43 
User avatar

Joined: 21 Feb 2005, 03:38
Location: Herding cats uphill whilst wearing roller skates.
Here you go. I saw a lot of bugs related to tessellation of the map (ground scars, etc. aren't right, shadowmaps) and light behaves a little funny, but it was otherwise OK.


Attachments:
SM3test.sdz [3.02 MiB]
Downloaded 27 times
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 05 Dec 2009, 01:50 
MC: Legacy & Spring 1944 Developer
User avatar

Joined: 29 Apr 2005, 00:14
Location: #moddev - join it!
A lot of forb's .sm3 have missing ;'s, can cause errors on loading.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 05 Dec 2009, 02:09 
Evolution RTS Developer
User avatar

Joined: 17 Nov 2005, 02:43
That's cause they changed the format a little and it broke all those old ones, and since no one can use them anyhow, what's the point in fixing them?
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 05 Dec 2009, 03:16 
Content Developer
User avatar

Joined: 13 Jan 2005, 00:46
because some of us want to help the devs work out the kinks and get a working sm3.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 05 Dec 2009, 05:00 
MC: Legacy & Spring 1944 Developer
User avatar

Joined: 29 Apr 2005, 00:14
Location: #moddev - join it!
Forboding Angel wrote:
That's cause they changed the format a little and it broke all those old ones, and since no one can use them anyhow, what's the point in fixing them?


Format didn't change - parser got stricter.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 05 Dec 2009, 08:13 
Evolution RTS Developer
User avatar

Joined: 17 Nov 2005, 02:43
Ahh, gotcha.

Smoth, if it doesn't properly support ati cards, then what's the point? I want sm3 as much if not more than the next guy, but I also want it to be able to be used by everyone as well.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 05 Dec 2009, 08:20 
Content Developer
User avatar

Joined: 13 Jan 2005, 00:46
well getting it working first is part of that.

I don't see any validity to the excuses.. if I have to buy an ati card to test spring with I will. I want this format.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 05 Dec 2009, 08:23 
Evolution RTS Developer
User avatar

Joined: 17 Nov 2005, 02:43
While I admire your resolve, I suppose I gave up on it years ago :-/
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 05 Dec 2009, 08:35 
Content Developer
User avatar

Joined: 13 Jan 2005, 00:46
life is short, no time for giving up.
Top
 Offline Profile  
 
 Post subject: Re: SM3
PostPosted: 05 Dec 2009, 10:28 
Evolution RTS Developer
User avatar

Joined: 17 Nov 2005, 02:43
Well, at this rate I'll die of old age before sm3 actually comes to fruition. Besides, in all technicality, I've done my bit. Made a few sm3 maps. They work fine for me, but apparently not for everyone else.
Top
 Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 212 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7, 8 ... 11  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: Misolavera and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Site layout created by Roflcopter et al.