Page 1 of 1

issues with springlobby on ubuntu linux

Posted: 27 Jan 2023, 04:11
by raaar
What's the recommended way to get an updated springlobby on a linux distribution?

I've tried to follow the instructions on the springlobby website

I've tested installing on a computer with ubuntu 20.0.4. Using "sudo apt-get install springlobby", it got me SL 0.269 and there's no apparent way to upgrade.

The "flatpak install flathub com.springrts.SpringLobby" didn't seem to work, aborts with "error: no remote refs found similar to 'flathub'" and "no remote refs found similar to 'com.springrts.SpringLobby'"

I've updated the OS to ubuntu 22.0.4 and retried installing using apt-get, and then it got me a more up-to-date version, 0.273, which still isn't the latest.

With 0.273, if i try to join the MF room and auto-download the BAR engine, it crashes and refuses to start from then on.

Code: Select all

*** stack smashing detected ***: terminated
Aborted (core dumped)
Then i tried the other installation, the "sudo snap install springlobby-nsg". This one got me the 0.270 version, but after using "snap refresh --edge springlobby-nsg" it did update to the "nsg" version of SL 0.274, which looks slightly different (also uses a different content directory, which can be a source of confusion, although it warns about it on the console output). Then it's able to download the engine, but not the game, apparently pr-downloader segfaults. I manually download the MF v2.00 game, then try to start a battle through springlobby and.....crash:

Code: Select all

[t=00:00:00.025750] 	SSE 4.1 : 1,  SSE 4.2 : 1
[t=00:00:00.025767] 	SSE 4.0A: 1,  SSE 5.0A: 1
[t=00:00:00.029372] [WatchDog::Install] installed (hang-timeout: 60s)
[t=00:00:00.029422] [WatchDog::RegisterThread] registering controls for thread [main]
X Error:  BadAlloc
  Request Major code 146 ()
  Request Minor code 7
  Error Serial #103
  Current Serial #104
terminate called without an active exception
Error: Spring crashed
Manually downloading the BAR105 engine 1478 or 1500 and MF v2.00 I can start spring binary directly without using a lobby and load the game, provided i place the game and map files on the right place.

Meanwhile, back on springlobby-nsg 0.274, I go to tools > download archives and get "engine:spring 105.0". It throws me some error popups claiming that it "couldn't load" because "/lib/x86_64-linux-gnu/ version 'GLIBC_2.29' not found".

I remove the bar105 engines and keep only the official 104.0 and 105.0 and restart the lobby. Same "glibc 2.29 not found" error. It's unable to load the 105.0 engine. I try to start a battle with the 104.0 engine and get the same "BadAlloc" error i got when trying to start games with the BAR105 engines.

I had players using ubuntu tell me that while they could play MF using springlobby and the 105.0 engine, they couldn't get springlobby to load the new BAR105 engine (the "*** stack smashing detected ***" error i got on 0.273).

Another user with "gentoo" linux tried building his own springlobby 0.274 and can play 105.0 but fails to run "BAR105 engines" and gets this error

Code: Select all

Couldn't load the library /home/bozo/.spring/engine/linux64/105.1.1-1478-gbc6400c BAR105/ /home/bozo/.spring/engine/linux64/105.1.1-1478-gbc6400c BAR105/ undefined symbol: lzma_code
my experience setting it up with springlobby on ubuntu was even worse : couldn't even get it to play games on 104.0 or 105.0.

Btw, then I tried skylobby. First i downloaded the .jar and installed a java 17 jre and tried to run it, that failed:

Code: Select all

Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't load library: /usr/lib/jvm/java-17-openjdk-amd64/lib/
...but then i got the .deb file and right clicked then opened with software installer and installed it. Then ran it and it worked : with skylobby i could join the MF room and it downloaded the engine/game/map and I was able to play.

Re: issues with springlobby on ubuntu linux

Posted: 28 Jan 2023, 15:52
by abma
use flatpak: ... pringLobby
The "flatpak install flathub com.springrts.SpringLobby" didn't seem to work, aborts with "error: no remote refs found similar to 'flathub'" and "no remote refs found similar to 'com.springrts.SpringLobby'"
very likely you missed the "setup guide" and didn't add the flathub repository:

Code: Select all

flatpak remote-add --if-not-exists flathub
i've removed the other instructions from the wiki as they are untested / not working / just install an outdated version.

Re: issues with springlobby on ubuntu linux

Posted: 01 Feb 2023, 07:02
by raaar
Ah, it does install 0.274 after running that command and then using the "flatpak run com.springrts.SpringLobby" to start it, and then it was able to download and run the various engines etc.