Adding visual studio compiler to buildbot. - Page 3

Adding visual studio compiler to buildbot.

Discuss the source code and development of Spring Engine in general from a technical point of view. Patches go here too.

Moderator: Moderators

Super Mario
Posts: 823
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

I don't mind that, however be sure to ask for volunteers in announcement some time in the future, as I'm merely using my personal computer for initial state, and I don't have extra hardware lying around at the moment for me to convert it into a windows server buildslave.
Super Mario
Posts: 823
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

It's up again, though, you need to edit the cmake file as it getting errors concerning the glew files.
abma
Spring Developer
Posts: 3716
Joined: 01 Jun 2009, 00:08

Re: Adding visual studio compiler to buildbot.

Post by abma »

can you delete CMakeCache.txt please?
Super Mario
Posts: 823
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

abma wrote:can you delete CMakeCache.txt please?
Can't, currently don't have access to it, you need to tell build bot to delete it. Not until I have software that I can access it remotely. Ok I manged to delete the cache file.
Super Mario
Posts: 823
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

Deleting the cache file didn't do anything.
abma
Spring Developer
Posts: 3716
Joined: 01 Jun 2009, 00:08

Re: Adding visual studio compiler to buildbot.

Post by abma »

hokomoko
Spring Developer
Posts: 592
Joined: 02 Jun 2014, 00:46

Re: Adding visual studio compiler to buildbot.

Post by hokomoko »

some library names had to be fixed manually and USE_CREG had to be set to off

also updating your local vclibs14 folder may help.
abma
Spring Developer
Posts: 3716
Joined: 01 Jun 2009, 00:08

Re: Adding visual studio compiler to buildbot.

Post by abma »

hokomoko wrote:also updating your local vclibs14 folder may help.
the buildbot scripts automaticly update it before each build. thats why it very likely doesn't even even start compile any more:

i.e. see http://buildbot.springrts.com/builders/ ... logs/stdio

hokomoko wrote:some library names had to be fixed manually
what do you mean with that?
hokomoko
Spring Developer
Posts: 592
Joined: 02 Jun 2014, 00:46

Re: Adding visual studio compiler to buildbot.

Post by hokomoko »

abma wrote:what do you mean with that?
For instance I've only had luck with linking with the static version of glew so you need to link with glew32s.lib or glew32sd.lib depending on the build type (release/debug) that probbaly explains why GLEW_LIBRARIES isn't found.

(it currently only looks for glew32.lib probably)
Super Mario
Posts: 823
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

It works fine, before you made changes to it. I have no idea what you did, but force to fix it manually when it comes to the build bot process isn't a way to go.
hokomoko
Spring Developer
Posts: 592
Joined: 02 Jun 2014, 00:46

Re: Adding visual studio compiler to buildbot.

Post by hokomoko »

it will get fixed but it's not my priority at the moment.
Super Mario
Posts: 823
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

hokomoko wrote:it will get fixed but it's not my priority at the moment.
Then revert the changes you made to it until you fix it then, or better yet, fork the libraries. Don't broke other people things and say it's not important at the moment.
Post Reply

Return to “Engine”