[SOLVED] /team command "illegally"

[SOLVED] /team command "illegally"

Discuss the source code and development of Spring Engine in general from a technical point of view. Patches go here too.

Moderator: Moderators

Post Reply
Posts: 24
Joined: 27 Nov 2011, 10:38

[SOLVED] /team command "illegally"

Post by PixelOfDeath »

I'm lua scripting around and for some tests I need to control 2 enemy teams. But now the /team command doesn't work for me.
I just get a "Player (0) tried to change team illegally" after I already enabled cheats...

I just noticed that teams are indexed by 0. And only if you use the id after the last valid ID you get this message. If you use any higher ID you actually get the normal help message.
User avatar
Lobby Developer
Posts: 1164
Joined: 25 Sep 2006, 13:56

Re: [SOLVED] /team command "illegally"

Post by BrainDamage »

that's because it still is a valid team id, it's gaia, just not "selectable"
User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14657
Joined: 17 Nov 2005, 02:43

Re: [SOLVED] /team command "illegally"

Post by Forboding Angel »

Perhaps internal verbage could be changed to reflect that?

Pixel, if you would, make a mantis report about it (that way it doesn't get lost in the shuffle, unlike the eventual fate of this thread): http://springrts.com/mantis
Post Reply

Return to “Engine”