Page 10 of 14

Re: SpringLobby 0.224 released!

Posted: 05 Jun 2015, 18:16
by prandipadaro
help/system info
SpringLobby 0.224 (unix x64)
SpringLobby config file: /home/p/.springlobby/springlobby.conf ( writable)
LobbyWriteDir (/home/p/.springlobby/)
WX: yes POSIX: yes TRY: yes
CachePath (/home/p/.springlobby/cache/)
WX: yes POSIX: yes TRY: yes
ExecutableFolder (/usr/local/bin/)
WX: no POSIX: no TRY: no
DownloadDir (/home/p/.spring/)
WX: yes POSIX: yes TRY: yes
Current SpringData: ()
WX: no POSIX: no TRY: no
Current unitsync:
Current spring executable:
Current uikeys.txt: uikeys.txt
Portable mode: no
Compiled with wxWidgets 3.0.0.0
Started with:
springlobby
edit/spring settings is not avaible, I can not select it, it is grey

Re: SpringLobby 0.224 released!

Posted: 05 Jun 2015, 18:32
by abma
abma wrote:check help->system info / edit ->preferences -> spring.

Re: SpringLobby 0.224 released!

Posted: 05 Jun 2015, 18:50
by prandipadaro
sorry
here i have the 98.0 engine
if selected

engine is in /usr/games/spring

lib unitsync
/usr/lib/spring/libunitsync.so

Re: SpringLobby 0.224 released!

Posted: 05 Jun 2015, 18:56
by prandipadaro
oh!
if i change the edit/preference/spring and i modify the path of engine... it work!
thanks

Re: SpringLobby 0.224 released!

Posted: 07 Jun 2015, 20:46
by tzaeru
I compiled the github development version, but was met with some sync errors. Is this to be expected and should only the release source tarballs be used?

Great work on the recent bugfixes btw. :) It's appreciated.

Re: SpringLobby 0.224 released!

Posted: 07 Jun 2015, 21:02
by jamerlan
tzaeru wrote:I compiled the github development version, but was met with some sync errors. Is this to be expected and should only the release source tarballs be used?
Are you talking about this bug? https://github.com/springlobby/springlobby/issues/473

Re: SpringLobby 0.224 released!

Posted: 07 Jun 2015, 21:03
by tzaeru
jamerlan wrote:
tzaeru wrote:I compiled the github development version, but was met with some sync errors. Is this to be expected and should only the release source tarballs be used?
Are you talking about this bug? https://github.com/springlobby/springlobby/issues/473
Might be related. It does keep prompting me to download again. After a succesful download, I can even spec games with no sync errors and everything seems to work, but I show up asynced in the battleroom.

In 0.224 release, I've no async issues.

Re: SpringLobby 0.225 released!

Posted: 18 Jun 2015, 00:36
by abma
released 0.225. this release should finally the sync issues: it was broken on 32 bit platforms (mostly windows). As i'm using linux / 64 bit i didn't notice this problem and as it only desynced for some maps / games it took this long.

thanks for your feedback + help!

Re: SpringLobby 0.225 released!

Posted: 25 Jun 2015, 03:17
by raaar
I'm using 0.225 and i keep having these issues.

The map has been downloaded but it keeps prompting to dl again and again....and I show as "not in sync" in the battleroom.

Is this a lobby bug or Is there something else that can cause this?

It only seems to happen for some maps. For example now it's happening with the doxta_v3.sdz map.

edit : when i try to start in singleplayer it gives me an error saying that icyrunv2.sd7 is not found....And i don't actually have that file, i have icy_run_v2.sd7

edit2 : copy pasting and renaming to the desired file made it work for this particular case

Re: SpringLobby 0.225 released!

Posted: 25 Jun 2015, 08:40
by Usaga
Please, create an issue on bugtrack https://github.com/springlobby/springlobby/issues and make detailed report what did you do and what goes wrong.

Re: SpringLobby 0.225 released!

Posted: 25 Jul 2015, 19:57
by raaar
So, when's the next version coming out?

That issue where the player remains unsynched after downloading and has to restart the lobby is annoying.

Re: SpringLobby 0.225 released!

Posted: 25 Jul 2015, 20:05
by abma
raaar wrote:So, when's the next version coming out?
when these bugs are fixed: https://github.com/springlobby/springlobby/issues/528

Re: SpringLobby 0.225 released!

Posted: 10 Aug 2015, 05:39
by darklord42
Um we closed this bug, but no code changes were ever made in master.

https://github.com/springlobby/springlobby/issues/491

I thought we settled on std::abs(static_cast<double>(count)). it's still

std::abs(count))

Re: SpringLobby 0.226 released!

Posted: 24 Aug 2015, 19:41
by abma
released 0.226:

- this should fix all issues with lists on windows but sadly introduces a new bug on linux: https://github.com/springlobby/springlobby/issues/509
any help is welcome to fix this one, but its difficult, as its a wxwidgets bug :-|

for more details, see the changelog:

https://github.com/springlobby/springlo ... /ChangeLog

Re: SpringLobby 0.226 released!

Posted: 25 Aug 2015, 02:10
by raaar
nice!

lists not refreshing was an annoying bug, glad it's been put outside.

Re: SpringLobby 0.226 released!

Posted: 25 Aug 2015, 02:38
by Silentwings
thanks!

Re: SpringLobby 0.236 released!

Posted: 28 Sep 2015, 21:49
by abma
released 0.236 which basicly is a bugfix release only (fixes a memleak/crash/hang)

Re: SpringLobby 0.236 released!

Posted: 30 Sep 2015, 03:24
by darklord42
Here is a mac version
SpringLobby-0.236-OSX-10.10.dmg

Re: SpringLobby 0.236 released!

Posted: 30 Sep 2015, 10:14
by PicassoCT
I miss those howling mobs with pitchforks and torches. This is not the release culture we once had.

Re: SpringLobby 0.242 released!

Posted: 12 Oct 2015, 01:14
by darklord42
Sorry guys I went and upgraded to 10.11. It makes it difficult to build 10.10 builds anymore. One day I'll have to look into it, but for now here is a 10.11 build of springloby 0.242
http://www.mediafire.com/download/8sdnv ... -10.11.dmg