SpringLobby 0.268 released! - Page 6

SpringLobby 0.268 released!

Moderators: Moderators, Lobby Developers

Post Reply
User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Re: SpringLobby 0.199 released!

Post by Jools » 16 Sep 2014, 21:11

I agree with those statements but isn't it the lobby server that assumes, and not the lobby?

By the way, the lobby asumes also that my download dir is dev null. Assuming is not so smart :)
0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.199 released!

Post by abma » 16 Sep 2014, 22:52

Kapytii wrote:Timeout assumed, disconnecting. Received no data from server for 60 seconds. Last ping send 20421 seconds ago.
this message is from the lobby client. was your computer clock adjusted about ~6 hours?!
0 x

Kapytii
Posts: 64
Joined: 14 Mar 2013, 08:40

Re: SpringLobby 0.199 released!

Post by Kapytii » 17 Sep 2014, 13:07

Sorry abma, I dont understand what you mean about adjusted clock :/ But nothing related to computer clock had been done, or anything else special 6 hours ago from that timeout happening. Its totally random and mystical, these timeouts, I would assume.
0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.199 released!

Post by abma » 17 Sep 2014, 14:17

Kapytii wrote:Sorry abma, I dont understand what you mean about adjusted clock
is automatic clock synchronization enabled? by default its enabled in most os.
0 x

Kapytii
Posts: 64
Joined: 14 Mar 2013, 08:40

Re: SpringLobby 0.200 released!

Post by Kapytii » 18 Sep 2014, 07:33

Yes, automatic clock synchronization with time.windows.com.
0 x

User avatar
Silentwings
Moderator
Posts: 3597
Joined: 25 Oct 2008, 00:23

Re: SpringLobby 0.200 released!

Post by Silentwings » 18 Sep 2014, 23:51

[22:12:09] ** Server ** Timeout assumed, disconnecting. Received no data from server for 60 seconds. Last ping send 7311 seconds ago.
I got one of these too. I am sure that my internet was 100% fine when it happened because I was spectating an online game at the time. The chatlog also shows frequent communication from the server right up until the "Timeout" suddenly happened.
0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.200 released!

Post by abma » 19 Sep 2014, 00:08

ouch, thanks for reporting, too. this time is in milliseconds... i've slightly increased the local timeout & fixed the output: https://github.com/springlobby/springlo ... 52748104c2

didn't see the bug in the code the first time i looked at it, sorry!
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Bug report (sry.. lazy me!)

Post by hoijui » 19 Sep 2014, 14:28

i just tried latest SL master (git commit 5cf678f65f4), and it hangs (0.200 works fine)

it hangs when i am in the battlelist and click on a battle of which i have the map. it does not hang if i don't have the map. i imagine it has to do with the lock introduced in the merged-in branch.
0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.200 released!

Post by abma » 19 Sep 2014, 17:02

0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.200 released!

Post by albator » 28 Sep 2014, 11:59

Can you list all the libraies that need to be install

After makeing cmake src

Code: Select all

CMake Error at CMakeLists.txt:3 (INCLUDE):
  include could not find load file:

    compat_flags

Also,

Code: Select all

-- found wx-config: wxWidgets_CONFIG_EXECUTABLE-NOTFOUND
CMake Error at CMakeLists.txt:65 (message):
  couldn't find wx-widgets >= 2.8, found

Also, I notice the INSTALL note are note up-to-date, so the link in the 1st page maybe the wrong one.

Code: Select all

- Installation Instructions

  cmake .
  make
  make install

You can change build settings like install prefix using 'ccmake .'

Apparently, you should do "cmake src"

Thanks
0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.200 released!

Post by abma » 28 Sep 2014, 14:46

albator wrote:Apparently, you should do "cmake src"
no, thats definitly wrong. you have to run "cmake ." in the root directory of the springlobby source dir.

dependencies should be: openal, wxwidgets, boost & curl.
-- found wx-config: wxWidgets_CONFIG_EXECUTABLE-NOTFOUND
in this case it can't find the utility "wx-config". is wx-widgets installed? is there wx-config-3.0?
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.200 released!

Post by albator » 28 Sep 2014, 15:22

abma wrote: dependencies should be: openal, wxwidgets, boost & curl.

Quote:
-- found wx-config: wxWidgets_CONFIG_EXECUTABLE-NOTFOUND

in this case it can't find the utility "wx-config". is wx-widgets installed? is there wx-config-3.0?

I have libwxgtk2.8 installed.

Could you precise the real name of the package to be installed ? I have tenths of package that match this :

Code: Select all

wx2.8-doc          wx2.8-headers      wx3.0-examples     wx3.0-i18n         wx-common          wxgeometrie        wxmaxima           wxsqlite3-doc      
wx2.8-examples     wx2.8-i18n         wx3.0-headers      wxbanker           wxformbuilder      wxhexeditor        wxsqlite3-2.8-dbg  
libwxgtk2.8-0            libwxgtk2.8-dev          libwxgtk3.0-0-dbg        libwxgtk-media2.8-0      libwxgtk-media2.8-dev    libwxgtk-media3.0-0-dbg  
libwxgtk2.8-dbg          libwxgtk3.0-0            libwxgtk3.0-dev          libwxgtk-media2.8-dbg    libwxgtk-media3.0-0      libwxgtk-media3.0-dev  
Same goes for boost.


The problem is that spring lobby available on the repo and current spring completly fuck up the springsettings.cfg file which is reset or have rand om write on it for no reason. So I have to compile from source.
No wonder why player DB is so low. It is a pain to install even for old spring user. Just giving feed back no hard feeling :D
Thanks for the answers.


Aslo, that will be a god idea to precise what lib needs to be install in the INSTALL file.
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.200 released!

Post by albator » 28 Sep 2014, 15:27

I installed the "curl" package and I still goes this:

CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
Could NOT find CURL (missing: CURL_LIBRARY CURL_INCLUDE_DIR)
What is the name of the package to install ?

Cannot you add it in the INSTALL file ?
0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.200 released!

Post by abma » 28 Sep 2014, 18:14

you need the -dev packages. no i can't name the packages as i don't know which os you have.

maybe see the .travis.yml file for packages names on ubuntu 12.04:
https://github.com/springlobby/springlo ... travis.yml

Code: Select all

sudo apt-get install libwxgtk2.8-dev libboost-thread1.48-dev libboost-system1.48-dev libboost-filesystem1.48-dev
apt-get install libboost-test1.48-dev libalure-dev
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.200 released!

Post by albator » 28 Sep 2014, 20:58

Code: Select all

$ sudo apt-get install   libalure-dev 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libalure-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.


$ cmake .
CMake Error at CMakeLists.txt:3 (INCLUDE):
  include could not find load file:

    compat_flags


-- Boost version: 1.54.0
-- Found the following Boost libraries:
--   thread
--   system
CMake Warning (dev) at CMakeLists.txt:40 (ADD_DEFINITIONS):
  Policy CMP0005 is not set: Preprocessor definition values are now escaped
  automatically.  Run "cmake --help-policy CMP0005" for policy details.  Use
  the cmake_policy command to set the policy and suppress this warning.
This warning is for project developers.  Use -Wno-dev to suppress it.

-- found wx-config: /usr/bin/wx-config
-- found wxwidgets: 2.8.12.1
-- Using WX_CXX_FLAGS: -I/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__
-- Using WX_C_FLAGS: -I/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread
-- Using WX_LD_FLAGS: -L/usr/lib/x86_64-linux-gnu -pthread -Wl,-Bsymbolic-functions -Wl,-z,relro  -L/usr/lib/x86_64-linux-gnu   -lwx_baseu_net-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_richtext-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_aui-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu-2.8
-- /usr/bin/pkg-config returned -lcurl for linking to libcurl
-- /usr/bin/pkg-config returned  for compiling with libcurl
-- Version tarball
-- Could NOT find MINIZIP (missing:  MINIZIP_LIBRARY MINIZIP_INCLUDE_DIR) 
-- Boost version: 1.54.0
-- Found the following Boost libraries:
--   unit_test_framework
-- Boost version: 1.54.0
-- Found the following Boost libraries:
--   system
--   thread
--   filesystem
-- Sound enabled!
CMake Error at sound/CMakeLists.txt:9 (find_package):
  By not providing "FindAlure.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Alure", but
  CMake did not find one.

  Could not find a package configuration file provided by "Alure" with any of
  the following names:

    AlureConfig.cmake
    alure-config.cmake

  Add the installation prefix of "Alure" to CMAKE_PREFIX_PATH or set
  "Alure_DIR" to a directory containing one of the above files.  If "Alure"
  provides a separate development package or SDK, be sure it has been
  installed.


CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 2.8)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!
See also "~/Softwares/springlobby-0.200/CMakeFiles/CMakeOutput.log".

mint 17 x64
0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.200 released!

Post by abma » 28 Sep 2014, 21:54

abma wrote:you have to run "cmake ." in the root directory of the springlobby source dir.
you are running it in the subdirectory src, thats wrong!
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.200 released!

Post by albator » 28 Sep 2014, 22:13

abma wrote:
abma wrote:you have to run "cmake ." in the root directory of the springlobby source dir.
you are running it in the subdirectory src, thats wrong!
No, I dont, I do this:

Code: Select all

~/Softwares/springlobby-0.200$ cmake .
CMake Error at CMakeLists.txt:3 (INCLUDE):
  include could not find load file:

    compat_flags


-- Boost version: 1.54.0
-- Found the following Boost libraries:
--   thread
--   system
CMake Warning (dev) at CMakeLists.txt:40 (ADD_DEFINITIONS):
  Policy CMP0005 is not set: Preprocessor definition values are now escaped
  automatically.  Run "cmake --help-policy CMP0005" for policy details.  Use
  the cmake_policy command to set the policy and suppress this warning.
This warning is for project developers.  Use -Wno-dev to suppress it.

-- found wx-config: /usr/bin/wx-config
-- found wxwidgets: 2.8.12.1
-- Using WX_CXX_FLAGS: -I/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__
-- Using WX_C_FLAGS: -I/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread
-- Using WX_LD_FLAGS: -L/usr/lib/x86_64-linux-gnu -pthread -Wl,-Bsymbolic-functions -Wl,-z,relro  -L/usr/lib/x86_64-linux-gnu   -lwx_baseu_net-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_richtext-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_aui-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu-2.8
-- /usr/bin/pkg-config returned -lcurl for linking to libcurl
-- /usr/bin/pkg-config returned  for compiling with libcurl
-- Version tarball
-- Could NOT find MINIZIP (missing:  MINIZIP_LIBRARY MINIZIP_INCLUDE_DIR) 
-- Boost version: 1.54.0
-- Found the following Boost libraries:
--   unit_test_framework
-- Boost version: 1.54.0
-- Found the following Boost libraries:
--   system
--   thread
--   filesystem
-- Sound enabled!
CMake Error at sound/CMakeLists.txt:9 (find_package):
  By not providing "FindAlure.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Alure", but
  CMake did not find one.

  Could not find a package configuration file provided by "Alure" with any of
  the following names:

    AlureConfig.cmake
    alure-config.cmake

  Add the installation prefix of "Alure" to CMAKE_PREFIX_PATH or set
  "Alure_DIR" to a directory containing one of the above files.  If "Alure"
  provides a separate development package or SDK, be sure it has been
  installed.


CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 2.8)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!
See also "~/Softwares/springlobby-0.200/CMakeFiles/CMakeOutput.log".

Doing what you say I did would have result in this:

Code: Select all

~/Softwares/springlobby-0.200/src$ cmake .
CMake Error at CMakeLists.txt:3 (INCLUDE):
  include could not find load file:

    compat_flags


-- Boost version: 1.54.0
-- Found the following Boost libraries:
--   thread
--   system
CMake Warning (dev) at CMakeLists.txt:40 (ADD_DEFINITIONS):
  Policy CMP0005 is not set: Preprocessor definition values are now escaped
  automatically.  Run "cmake --help-policy CMP0005" for policy details.  Use
  the cmake_policy command to set the policy and suppress this warning.
This warning is for project developers.  Use -Wno-dev to suppress it.

-- found wx-config: /usr/bin/wx-config
-- found wxwidgets: 2.8.12.1
-- Using WX_CXX_FLAGS: -I/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__
-- Using WX_C_FLAGS: -I/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread
-- Using WX_LD_FLAGS: -L/usr/lib/x86_64-linux-gnu -pthread -Wl,-Bsymbolic-functions -Wl,-z,relro  -L/usr/lib/x86_64-linux-gnu   -lwx_baseu_net-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_richtext-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_aui-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu-2.8
-- /usr/bin/pkg-config returned -lcurl for linking to libcurl
-- /usr/bin/pkg-config returned  for compiling with libcurl
-- Version tarball
-- Could NOT find MINIZIP (missing:  MINIZIP_LIBRARY MINIZIP_INCLUDE_DIR) 
-- Boost version: 1.54.0
-- Found the following Boost libraries:
--   unit_test_framework
-- Boost version: 1.54.0
-- Found the following Boost libraries:
--   system
--   thread
--   filesystem
-- Sound enabled!
CMake Error at sound/CMakeLists.txt:9 (find_package):
  By not providing "FindAlure.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Alure", but
  CMake did not find one.

  Could not find a package configuration file provided by "Alure" with any of
  the following names:

    AlureConfig.cmake
    alure-config.cmake

  Add the installation prefix of "Alure" to CMAKE_PREFIX_PATH or set
  "Alure_DIR" to a directory containing one of the above files.  If "Alure"
  provides a separate development package or SDK, be sure it has been
  installed.


CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 2.8)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!
See also "~/Softwares/springlobby-0.200/src/CMakeFiles/CMakeOutput.log".
0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.200 released!

Post by abma » 28 Sep 2014, 22:17

cmake for some reason doesn't find this file: https://github.com/springlobby/springlo ... lags.cmake does this file exist?
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.200 released!

Post by albator » 28 Sep 2014, 22:24

$ locate compat_flags.cmake


~/Softwares/springlobby-0.200/cmake/compat_flags.cmake
~/Softwares/springlobby-0.200/src/lsl/cmake/compat_flags.cmake


0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.200 released!

Post by abma » 28 Sep 2014, 22:33

CMake Error at CMakeLists.txt:3 (INCLUDE):

https://github.com/springlobby/springlo ... sts.txt#L3

uhm... did you edit CMakeLists.txt?
0 x

Post Reply

Return to “SpringLobby Client”

cron