SpringLobby 0.267 released! - Page 3

SpringLobby 0.267 released!

Moderators: Moderators, Lobby Developers

dansan
Server Owner & Developer
Posts: 1192
Joined: 29 May 2010, 23:40

Re: SpringLobby 0.180 released!

Post by dansan » 12 Jan 2014, 22:57

knorke wrote:Does springlobby have a logfile (like infolog.txt etc) to upload for crashes?

Code: Select all

daniel@moja ~ $ springlobby --help
Usage: springlobby [-h] [-nc] [-fl <str>] [-cl] [-gl] [-f <str>] [-l <num>] [-n <str>]
  -h, --help               	show this help message
  -nc, --no-crash-handler  	don't use the crash handler (useful for debugging)
  -fl, --file-logging=<str>	dumps application log to a file ( enter path )
  -cl, --console-logging   	shows application log to the console(if available)
  -gl, --gui-logging       	enables application log window
  -f, --config-file=<str>  	override default choice for config-file
  -l, --log-verbosity=<num>	overrides default logging verbosity, can be:
                                0: no log
                                1: critical errors
                                2: errors
                                3: warnings (default)
                                4: messages
                                5: function trace
  -n, --name=<str>         	overrides default application name
0 x

abma
Spring Developer
Posts: 3556
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.180 released!

Post by abma » 13 Jan 2014, 18:31

smoth wrote:are we getting a fix update soon?
as always, when its "ready". :)
0 x

100Gbps
Posts: 73
Joined: 30 Jan 2009, 13:19

Re: SpringLobby 0.180 released!

Post by 100Gbps » 16 Jan 2014, 03:30

Game filtering on 0.180 suddenly stopped working for me. 'Only games I have' checkbox isn't working, 'Host', 'Description', 'Map', 'Game' textboxes too ...

Also did a clean install w/o success.
0 x

User avatar
AntiAllez
Posts: 105
Joined: 06 Mar 2012, 18:22

Re: SpringLobby 0.180 released!

Post by AntiAllez » 16 Jan 2014, 06:30

did you removed the Lobby "error reporting" function? cannot disable it at preference with new lobby or where to find it now?
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: SpringLobby 0.180 released!

Post by knorke » 20 Jan 2014, 03:52

How excactly (parameters) must I start SL to get useful logfile in case of crash?
I tried:
springlobby.exe -fl="c:\springlobby.txt" -l=5 -nc

But the logfile only contains log about failed replay parsing like:
03:50:39: Error: Parsing torptest20121121_093100_SaltrockColonyV2_91.sdf failed
03:50:39: Error: Couldn't open replay C:\Spiele\springcontent\demos\torptest20121121_093100_SaltrockColonyV2_91.sdf
( https://github.com/springlobby/springlobby/issues/129 )
and nothing else.
0 x

abma
Spring Developer
Posts: 3556
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.180 released!

Post by abma » 13 Mar 2014, 22:31

i'm trying to push out a new release. would be great if some people could test the current version on windows:

http://springlobby.info/temp/builds/abma/sl_master.zip


report bugs please at the issue tracker:
https://github.com/springlobby/springlobby/issues

changes: i don't really remember, many of them are mostly code refactoring / cleanup, so no visual / functional change. please give it a try!

when "testing" on linux, you've to compile it: https://github.com/springlobby/springlo ... g_from_Git
0 x

abma
Spring Developer
Posts: 3556
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.181 released!

Post by abma » 21 Mar 2014, 16:27

released 0.181
0 x

User avatar
zoggop
Posts: 289
Joined: 07 Sep 2010, 18:47

Re: SpringLobby 0.182 released!

Post by zoggop » 21 Mar 2014, 17:43

hooray, 0.182 has gotten rid of the "XX flag not found" error messages for me
0 x

100Gbps
Posts: 73
Joined: 30 Jan 2009, 13:19

Re: SpringLobby 0.182 released!

Post by 100Gbps » 21 Mar 2014, 19:12

Game filtering is still not working.
This time the newest 'feature': Automatic opening of user-chosen tab is not working.

Do not tell me to delete the settings file:
1. Already did it. Even installed it on different partition
2. We are in 2014
0 x

abma
Spring Developer
Posts: 3556
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.182 released!

Post by abma » 21 Mar 2014, 19:20

100Gbps wrote:Game filtering is still not working.
This time the newest 'feature': Automatic opening of user-chosen tab is not working.
can you provide details? both work for me.

edit: i know usabilitiy is bad... but it works.
0 x

User avatar
Silentwings
Moderator
Posts: 3593
Joined: 25 Oct 2008, 00:23

Re: SpringLobby 0.182 released!

Post by Silentwings » 21 Mar 2014, 19:28

Awesome :D changing font worked and it remembered my column widths <3

Game filtering works fine for me. So do the tabs.
0 x

100Gbps
Posts: 73
Joined: 30 Jan 2009, 13:19

Re: SpringLobby 0.182 released!

Post by 100Gbps » 21 Mar 2014, 21:22

abma wrote:can you provide details? both work for me.

edit: i know usabilitiy is bad... but it works.
1. I(the Robot)'m starting SpringLobby 0.182 for n-th time.
2. Chat tab is open, no matter that 'SinglePlayer' is chosen in 'Edit->Preferences->General' tab.
3. The robot is clicking on 'Battlelist' tab.
4. The robot clicks again, this time on the 'Filter' button and changes the contents of 'Game' textbox with 'Balanced'. All other options are by default.
5. The same robot checks 'Activated' checkbox.
6. Games disappear.
7. The robot is undoing steps 5 to 4.
8. Games are here again.
0 x

abma
Spring Developer
Posts: 3556
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.182 released!

Post by abma » 22 Mar 2014, 02:05

100Gbps wrote: 6. Games disappear.
load/save of filter got broken, because of this defaults weren't loaded as well.

fixed in this commit: https://github.com/springlobby/springlo ... ecba9d3741

just select ->status -> locked, passworded, started, full, open and you should see some games.
0 x

100Gbps
Posts: 73
Joined: 30 Jan 2009, 13:19

Re: SpringLobby 0.182 released!

Post by 100Gbps » 22 Mar 2014, 19:56

Still broken ...

Can't remember since which version this happened, Spring 0.95+ and Lobby 0.1-seventy-something ...
0 x

abma
Spring Developer
Posts: 3556
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.183 released!

Post by abma » 23 Mar 2014, 19:34

0.183 released which contains the fixing commit.
0 x

User avatar
Floris
Balanced Annihilation Developer
Posts: 599
Joined: 04 Jan 2011, 20:00

Re: SpringLobby 0.183 released!

Post by Floris » 23 Mar 2014, 19:59

Springlobby used to show the countryname when hovering over a flag icon, this was a nice to have to get familliar with unknown country flags.


Lots of thanks for bringing back springlobby to the state we had before!
0 x

floppy1356
Posts: 2
Joined: 08 Nov 2013, 23:00

Re: SpringLobby 0.184 released!

Post by floppy1356 » 23 Mar 2014, 21:48

My issue with the last (0.184 and previous 0.182) is the following, every time I restart Springlobby it forgets the whole path of file spring.exe in the SL preferences and replace it with simply "spring.exe". (I'm using vista)
0 x

User avatar
LordMatt
Posts: 3393
Joined: 15 May 2005, 04:26

Re: SpringLobby 0.184 released!

Post by LordMatt » 23 Mar 2014, 22:36

The latest pull is not compiling for me on Ubuntu 12.04:

Code: Select all

CMake Error at src/CMakeLists.txt:304 (ADD_EXECUTABLE):
  Cannot find source file:

    /home/matt/Desktop/springlobby/src/helper/imageviewer.cpp

  Tried extensions .c .C .c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp
  .hxx .in .txx


0 x

abma
Spring Developer
Posts: 3556
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.184 released!

Post by abma » 23 Mar 2014, 22:44

delete CMakeCache.txt or edit it, search for imageviewer.cpp and delete this line
0 x

User avatar
LordMatt
Posts: 3393
Joined: 15 May 2005, 04:26

Re: SpringLobby 0.184 released!

Post by LordMatt » 23 Mar 2014, 22:57

That worked thanks.
0 x

Post Reply

Return to “SpringLobby Client”

cron