(springlobby) unable to join game due to 88/89 spring

(springlobby) unable to join game due to 88/89 spring

Moderators: Moderators, Lobby Developers

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

(springlobby) unable to join game due to 88/89 spring

Post by knorke » 19 Jul 2012, 10:32

I can not join any battleroom, even the ones that run on spring 88.0
Image
<[2up]knorke> the "incompatible (spring 88) " room, is it really 88?
<[2up]knorke> because springlobby wont let me join
<RogerSheriff> [2up]knorke I can join with this warning... and it seems to be 88.. because I have version 88 and no desyncs
...
<RogerSheriff> knorke I am still with 0.146 lobby
<RogerSheriff> jzhmer and me are with Linux and we can join.. maybe its a windows bug?
I installed SL 0.146 (since RogerSheriff said he can join with that) but same thing.

can not report it on redmine site because still can not log in
http://springrts.com/phpbb/viewtopic.ph ... 3&p=510268

/edit
enabled quickmatching on zero-k site and it moved me into a host where i could then play.

/edit
rightclicking on same players name and using "join same battle" i can join room. but over battlelist i can not join the very same room

/edit
in springlobby.conf
DisableVersionCheck=1
and
disablewarning=1
did not help.
0 x

User avatar
Silentwings
Moderator
Posts: 3593
Joined: 25 Oct 2008, 00:23

Re: (springlobby) unable to join game due to 88/89 spring

Post by Silentwings » 20 Jul 2012, 09:42

I had this problem too - I didn't properly figure it out but I think it was something to do with the installer not overwriting my old unitsync.dll. In the end I just delete all sl/engine files and did a clean portable install; that worked.
0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: (springlobby) unable to join game due to 88/89 spring

Post by abma » 20 Jul 2012, 17:34

the zero-k people decided to use spring 88, but spring 89 is set as version at the lobby server. springlobby doesn't fully support multi versions -> these problems you have. easiest solution on windows: use zero-k lobby

if you want to use springlobby, install spring 88 and disable version checking...
0 x

User avatar
koshi
Lobby Developer
Posts: 1058
Joined: 14 Aug 2007, 16:15

Re: (springlobby) unable to join game due to 88/89 spring

Post by koshi » 20 Jul 2012, 17:46

using versions smaller than the one set globally should always result in errors anyhow, anything else might just as well stop testing/bug reporting/etc altogether
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: (springlobby) unable to join game due to 88/89 spring

Post by knorke » 20 Jul 2012, 20:15

I have never installed spring 89.0
Only testversions but that was unzipping to seperate folders and portable, so it is not "installer overwriting unitsync.dll"
(deleted them too)

To be clear, by this:
rightclicking on same players name and using "join same battle" i can join room. but over battlelist i can not join the very same room
I mean:
When I want to join via the battlelist, I get the error messages as on the screenshot.
But when I rightclick on a playername (who is in the battle) and click "join same battle", I can join the battle. I can even play without problem once joined. Similiar, if I zero-K's matchmaking can shuffle me in a room without problems too.
The error is only when joining via battlelist.

So if not anything else, that behaviour is inconsistent at least.
0 x

User avatar
koshi
Lobby Developer
Posts: 1058
Joined: 14 Aug 2007, 16:15

Re: (springlobby) unable to join game due to 88/89 spring

Post by koshi » 20 Jul 2012, 20:54

knorke wrote:I have never installed spring 89.0
Which is set as mandatory server wide, hence your issue.
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: (springlobby) unable to join game due to 88/89 spring

Post by knorke » 20 Jul 2012, 23:30

yes, but the hosts are on spring 88.
and i play on them.
but only with the weird workaround of clicking different.
0 x

User avatar
koshi
Lobby Developer
Posts: 1058
Joined: 14 Aug 2007, 16:15

Re: (springlobby) unable to join game due to 88/89 spring

Post by koshi » 20 Jul 2012, 23:31

The bug is in context/forced join not checking server rev compat, not the other way round knorke.
0 x

User avatar
KingRaptor
Zero-K Developer
Posts: 838
Joined: 14 Mar 2007, 03:44

Re: (springlobby) unable to join game due to 88/89 spring

Post by KingRaptor » 21 Jul 2012, 07:43

knorke wrote: in springlobby.conf
DisableVersionCheck=1
and
disablewarning=1
did not help.
0 x

User avatar
Licho
Zero-K Developer
Posts: 3803
Joined: 19 May 2006, 19:13

Re: (springlobby) unable to join game due to 88/89 spring

Post by Licho » 23 Jul 2012, 12:58

koshi thats not a bug, thats the only way for him to join :)

SL wont let him even if it should, he has 88.0
0 x

User avatar
koshi
Lobby Developer
Posts: 1058
Joined: 14 Aug 2007, 16:15

Re: (springlobby) unable to join game due to 88/89 spring

Post by koshi » 23 Jul 2012, 13:25

koshi wrote:using versions smaller than the one set globally should always result in errors anyhow, anything else might just as well stop testing/bug reporting/etc altogether
0 x

gajop
Moderator
Posts: 3023
Joined: 05 Aug 2009, 20:42

Re: (springlobby) unable to join game due to 88/89 spring

Post by gajop » 23 Jul 2012, 13:40

koshi wrote:
koshi wrote:using versions smaller than the one set globally should always result in errors anyhow, anything else might just as well stop testing/bug reporting/etc altogether
if you have the same spring version as the game you wish to join has, there is no reason not to allow people to play, regardless of the server reported current spring version
the multi-engine phenomenon is a whole different problem
0 x

User avatar
koshi
Lobby Developer
Posts: 1058
Joined: 14 Aug 2007, 16:15

Re: (springlobby) unable to join game due to 88/89 spring

Post by koshi » 23 Jul 2012, 13:51

Sure, if you'd get people to test new versions without force. That's really MTR though.
Fact is there's a bug with the version checking in SL where not all code paths use the same logic. That'll be fixed.
Fact is also that the lobby protocol has not support for multi-version hosting whatsoever. It was to be drafted, discussed and then agreed upon and implemented, but that never came to pass.
0 x

gajop
Moderator
Posts: 3023
Joined: 05 Aug 2009, 20:42

Re: (springlobby) unable to join game due to 88/89 spring

Post by gajop » 23 Jul 2012, 14:22

Yes, but if you don't allow them to play on older versions the end result is that they just can't play.
The reasons some games (like ZK in this example) decide to stick to old versions is because bugs have been discovered and determined that they'd have a large negative impact on gamers -> testing has served its purpose.
0 x

User avatar
Licho
Zero-K Developer
Posts: 3803
Joined: 19 May 2006, 19:13

Re: (springlobby) unable to join game due to 88/89 spring

Post by Licho » 23 Jul 2012, 14:55

Fact is it has support for multi-engine its been in use for ~= a year.

It was discussed here in forum and with aegis.
Maybe its not documented but you cannot claim it has no support.

It has it, it works.
0 x

User avatar
koshi
Lobby Developer
Posts: 1058
Joined: 14 Aug 2007, 16:15

Re: (springlobby) unable to join game due to 88/89 spring

Post by koshi » 23 Jul 2012, 15:13

koshi wrote: Fact is also that the lobby protocol has not support for multi-version hosting whatsoever. It was to be drafted, discussed and then agreed upon and implemented, but that never came to pass.
That's no claim of mine.
0 x

User avatar
Licho
Zero-K Developer
Posts: 3803
Joined: 19 May 2006, 19:13

Re: (springlobby) unable to join game due to 88/89 spring

Post by Licho » 23 Jul 2012, 18:52

Lobby protocol in its only actively used version = lobby protocol as implemented by uberserver, has support for multi engine with extra compatibility flag.
0 x

User avatar
koshi
Lobby Developer
Posts: 1058
Joined: 14 Aug 2007, 16:15

Re: (springlobby) unable to join game due to 88/89 spring

Post by koshi » 23 Jul 2012, 21:31

By all means, lets rehash that entire crapfest, as long as it leads to a properly documented, consented upon and implementable mechanism. Just like it did for FORCEJOIN and consorts :)
0 x

Google_Frog
Moderator
Posts: 2441
Joined: 12 Oct 2007, 09:24

Re: (springlobby) unable to join game due to 88/89 spring

Post by Google_Frog » 24 Jul 2012, 08:09

So if you're "fixing" the workaround that allows users to play games should we warn them to not update SL?

Engine testing would be even better with multi engine support. The only thing stopping me from using post_release for all ZK games is the lack of multi engine support by other lobbies.
0 x

User avatar
koshi
Lobby Developer
Posts: 1058
Joined: 14 Aug 2007, 16:15

Re: (springlobby) unable to join game due to 88/89 spring

Post by koshi » 24 Jul 2012, 09:59

Google_Frog wrote:Engine testing would be even better with multi engine support. The only thing stopping me from using post_release for all ZK games is the lack of multi engine support by other lobbies.
https://github.com/spring/LobbyProtocol/fork_select enter a draft so we can discuss then.
0 x

Post Reply

Return to “SpringLobby Client”

cron