blender user needs halp ;_;

blender user needs halp ;_;

Share and discuss visual creations and creation practices like texturing, modelling and musing on the meaning of life.

Moderators: MR.D, Moderators

User avatar
Wombat
Posts: 3379
Joined: 15 Dec 2008, 15:53

blender user needs halp ;_;

Post by Wombat » 19 May 2010, 07:25

i got serious problem with my blender i cannot solve. when im trying to send my models to someone else, half of my model faces are missing. Kaiser says that normals are f****d and looks like he is right, but i got no clue what is wrong :( (what is funny, even in texture mode in blender these faces are missing, but when i open models with 3dwings everything is ok :D)
Image - this is view which shows normals, i hope you can see that many faces (like under cannon) dont have... well these blue something.

and i already used recalculate outside and remove doubles (Kaiser suggested its problem with my modeling metod, but i just start circle, extrude edges, merge vertices... and well thats all i use most of the time)

Image
0 x

MElvinVM
Posts: 114
Joined: 15 May 2010, 11:43

Re: blender user needs halp ;_;

Post by MElvinVM » 19 May 2010, 07:48

send me a PM with a .obj file and ill try to do something.

On the other hand, be calm and learn some more about 3D modelling, you've just started it.
0 x

User avatar
Hobo Joe
Posts: 1001
Joined: 02 Jan 2008, 21:55

Re: blender user needs halp ;_;

Post by Hobo Joe » 19 May 2010, 07:49

Flip them manually. Select the faces with wrong facing normals, and press W > Flip Normals.
0 x

User avatar
Wombat
Posts: 3379
Joined: 15 Dec 2008, 15:53

Re: blender user needs halp ;_;

Post by Wombat » 19 May 2010, 07:53

Hobo Joe wrote:Flip them manually. Select the faces with wrong facing normals, and press W > Flip Normals.
now i feel quite embarassed i didnt notice this option >> THX !

but now, what causes this ? i cant play with normals every time i make model :X
0 x

User avatar
Beherith
Moderator
Posts: 4934
Joined: 26 Oct 2007, 16:21

Re: blender user needs halp ;_;

Post by Beherith » 19 May 2010, 08:17

Wombat wrote: but now, what causes this ? i cant play with normals every time i make model :X
Probably this:
but i just start circle, extrude edges,merge vertices... and well thats all i use most of the time
0 x

User avatar
Wombat
Posts: 3379
Joined: 15 Dec 2008, 15:53

Re: blender user needs halp ;_;

Post by Wombat » 19 May 2010, 08:26

thats from tutorials >> and i dont merge every vertice, even these faces i dont touch but just extrude are missing. so no
0 x

User avatar
Hobo Joe
Posts: 1001
Joined: 02 Jan 2008, 21:55

Re: blender user needs halp ;_;

Post by Hobo Joe » 19 May 2010, 08:35

Normally it doesn't happen, I very rarely have to flip normals manually, automatically facing them outward works 99% of the time. Guess you just got unlucky on your first try.

I'm not sure what exactly makes it break sometime. Could be the shape of the model, or it could be the way it was built.
0 x

User avatar
Wombat
Posts: 3379
Joined: 15 Dec 2008, 15:53

Re: blender user needs halp ;_;

Post by Wombat » 19 May 2010, 08:41

it happens in every model, equivalent of every face on the other side is broken :/ even if i dont mirror. maybe ill reinstal blender. thx for flip, cant belive i didnt notice it before :D
0 x

MElvinVM
Posts: 114
Joined: 15 May 2010, 11:43

Re: blender user needs halp ;_;

Post by MElvinVM » 19 May 2010, 11:56

have you ever tried polygonal modelling?
0 x

User avatar
CarRepairer
Cursed Zero-K Developer
Posts: 3359
Joined: 07 Nov 2007, 21:48

Re: blender user needs halp ;_;

Post by CarRepairer » 19 May 2010, 19:21

This happened to me the other day. I can tell you exactly how it happened.

Select right arm.
Mirror it to make a left arm.
Left arm shows in upspring, but is inside out in spring.

Once I flipped normals in blender, it shows inside-out in blender but properly in spring. Which is very annoying.
0 x

User avatar
KaiserJ
Community Representative
Posts: 3113
Joined: 08 Sep 2008, 22:59

Re: blender user needs halp ;_;

Post by KaiserJ » 19 May 2010, 19:30

thanks to whoever helped wombat the other day

i was very relieved to see his model load up properly
0 x

User avatar
Hobo Joe
Posts: 1001
Joined: 02 Jan 2008, 21:55

Re: blender user needs halp ;_;

Post by Hobo Joe » 19 May 2010, 19:55

Wombat wrote:it happens in every model, equivalent of every face on the other side is broken :/ even if i dont mirror. maybe ill reinstal blender. thx for flip, cant belive i didnt notice it before :D

Then you are doing something wrong.
0 x

User avatar
MidKnight
Posts: 2650
Joined: 10 Sep 2008, 03:11

Re: blender user needs halp ;_;

Post by MidKnight » 20 May 2010, 00:39

Maybe this will help:
Ctrl + N will make blender recalculate all the selected faces' normals so that they face outside. It's more reliable than flipping them. :-)
0 x

User avatar
Hobo Joe
Posts: 1001
Joined: 02 Jan 2008, 21:55

Re: blender user needs halp ;_;

Post by Hobo Joe » 20 May 2010, 06:00

MidKnight wrote:Maybe this will help:
Ctrl + N will make blender recalculate all the selected faces' normals so that they face outside. It's more reliable than flipping them. :-)

nice reading comprehension bro
0 x

User avatar
MidKnight
Posts: 2650
Joined: 10 Sep 2008, 03:11

Re: blender user needs halp ;_;

Post by MidKnight » 20 May 2010, 06:11

Hobo Joe wrote:
MidKnight wrote:Maybe this will help:
Ctrl + N will make blender recalculate all the selected faces' normals so that they face outside. It's more reliable than flipping them. :-)

nice reading comprehension bro
Could you please clarify?
0 x

User avatar
Wombat
Posts: 3379
Joined: 15 Dec 2008, 15:53

Re: blender user needs halp ;_;

Post by Wombat » 20 May 2010, 07:31

MidKnight wrote:Maybe this will help:
Ctrl + N will make blender recalculate all the selected faces' normals so that they face outside. It's more reliable than flipping them. :-)
another annoying stuff in blender, when i tried to A+ ctrl n, it didnt work, but when i do A+ deselect 1 face + ctrl n, it usually works (but again, not always).

thx for all help anyway, :P
0 x

User avatar
Hobo Joe
Posts: 1001
Joined: 02 Jan 2008, 21:55

Re: blender user needs halp ;_;

Post by Hobo Joe » 20 May 2010, 08:56

MidKnight wrote: Could you please clarify?
first post
Wombat wrote:and i already used recalculate outside and remove doubles
0 x

User avatar
Wombat
Posts: 3379
Joined: 15 Dec 2008, 15:53

Re: blender user needs halp ;_;

Post by Wombat » 20 May 2010, 10:18

Hobo Joe wrote:
MidKnight wrote: Could you please clarify?
first post
Wombat wrote:and i already used recalculate outside and remove doubles
well yes, but it didnt work coz i selected all faces, when i deselect few, ctrl + n works ;) <3 blender
0 x

User avatar
Tribulex
A.N.T.S. Developer
Posts: 1894
Joined: 26 Sep 2009, 21:26

Re: blender user needs halp ;_;

Post by Tribulex » 30 May 2010, 00:49

Wombat wrote:blender is really hard to use and its a fucked up program.
<3 blender
0 x

User avatar
insaneinside
Posts: 29
Joined: 06 Jul 2008, 05:13

Re: blender user needs halp ;_;

Post by insaneinside » 30 May 2010, 00:54

Tribulex wrote:let's misquote someone!
Your off-topic insult to a program that you do not prefer offends me, sir. While many people find Blender's learning curve and key-based interface off-putting, it is incredibly powerful.
0 x

Post Reply

Return to “Art & Modelling”