Question about the onBadSpringVersion setting

Question about the onBadSpringVersion setting

SpringRTS Perl Autohost for Dedicated Server

Moderators: Moderators, Lobby Developers, SPADS AutoHost

Post Reply
User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Question about the onBadSpringVersion setting

Post by Jools » 21 Aug 2015, 15:23

I have a question about this setting:
onBadSpringVersion (global setting)
Explicit name Action for bad Spring version
Description Action to be performed when the Spring version used by the AutoHost doesn't match the default one broadcasted by the lobby server.
Format / Allowed values <null>: use experimental multi-engine lobby protocol extension (not implemented by all lobby clients)
closeBattle: battle lobby is automatically closed
quit: SPADS exits automatically
Default value closeBattle
Is the value for doing nothing to just leave the config variable empty? It says: not implemented by all lobby clients, what is not implemented? If I understood this correctly, this value simply means to do nothing. Shouldn't it be very easy to do nothing? :)
0 x

User avatar
bibim
Lobby Developer
Posts: 901
Joined: 06 Dec 2007, 11:12

Re: SPADS AutoHost

Post by bibim » 21 Aug 2015, 17:18

Jools wrote:Is the value for doing nothing to just leave the config variable empty?
Yes
Jools wrote:It says: not implemented by all lobby clients, what is not implemented? If I understood this correctly, this value simply means to do nothing. Shouldn't it be very easy to do nothing? :)
"not implemented by all lobby clients" refers to what is just before the parentheses, which is "multi-engine lobby protocol extension". But I guess nowadays all lobby clients support the multi-engine lobby protocol extension, so maybe I should update the doc and remove this information.
0 x

Post Reply

Return to “SPADS AutoHost”