multi-engine support with autoUpdateBinaries=yes (Windows)

multi-engine support with autoUpdateBinaries=yes (Windows)

SpringRTS Perl Autohost for Dedicated Server

Moderators: Moderators, Lobby Developers, SPADS AutoHost

Post Reply
User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14606
Joined: 17 Nov 2005, 02:43

multi-engine support with autoUpdateBinaries=yes (Windows)

Post by Forboding Angel » 20 Nov 2013, 21:26

So, this just happened:

Image

Halp?

Running activeperl 5.16.whatever (32bit cause iirc 64bit lolfails)

My confs are referencing spring 94.1.
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14606
Joined: 17 Nov 2005, 02:43

Re: SPADS AutoHost beta release

Post by Forboding Angel » 20 Nov 2013, 23:03

Long story short for anyone with the same issue. I was running spring 94.1 and had spads autoupdating the binaries.
0 x

User avatar
bibim
Lobby Developer
Posts: 901
Joined: 06 Dec 2007, 11:12

Re: SPADS AutoHost beta release

Post by bibim » 26 Nov 2013, 00:25

Forboding Angel wrote:Long story short for anyone with the same issue. I was running spring 94.1 and had spads autoupdating the binaries.
I fixed this stupid SPADS behavior on Windows in SPADS 0.11.13, so you can still host old engine versions and keep Spring server binaries auto-update enabled in SPADS (it will automatically upgrade/downgrade your Spring server binaries more cleverly when needed, following your unitsync version).
0 x

Post Reply

Return to “SPADS AutoHost”