SPADS AutoHost - Page 3

SPADS AutoHost

SpringRTS Perl Autohost for Dedicated Server

Moderators: Moderators, Lobby Developers, SPADS AutoHost

User avatar
nixtux
TechA Developer
Posts: 100
Joined: 01 Mar 2009, 15:36

Re: SPADS AutoHost

Post by nixtux » 05 Sep 2017, 15:39

OMG OMG thank you, you deserve some cookies for this :-)
0 x

User avatar
FabriceFABS
Posts: 345
Joined: 28 Jul 2010, 16:20

Re: SPADS AutoHost

Post by FabriceFABS » 06 Sep 2017, 20:41

Excellent... Very nice job.
Merci beaucoup et encore merci pour le support.

Fabrice
0 x

User avatar
bibim
Lobby Developer
Posts: 901
Joined: 06 Dec 2007, 11:12

Re: SPADS AutoHost

Post by bibim » 06 Sep 2017, 22:11

You're welcome, don't hesitate to ask if you need help with the upgrade process and new version configuration.
0 x

User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Re: SPADS AutoHost

Post by Jools » 07 Sep 2017, 11:27

Same here. Vielen Dank für das ausständige Arbeit!
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14572
Joined: 17 Nov 2005, 02:43

Re: SPADS AutoHost

Post by Forboding Angel » 03 Oct 2017, 11:07

Your upgrade instructions are hard to follow, especially for anyone running multiple spads instances.

I made them marginally easier to parse: https://pastebin.com/FQsu1sbx
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14572
Joined: 17 Nov 2005, 02:43

Re: SPADS AutoHost

Post by Forboding Angel » 06 Jul 2018, 03:36

PSA: Atm it is impossible to get the 32bit version of activeperl (Which is what I've always used) from the ActiveState site. I don't know if it will stay like that, but in case anyone is worried, strawberry seems to work 100% perfectly.
0 x

User avatar
bibim
Lobby Developer
Posts: 901
Joined: 06 Dec 2007, 11:12

Re: SPADS AutoHost

Post by bibim » 08 Jul 2018, 09:40

Forboding Angel wrote:PSA: Atm it is impossible to get the 32bit version of activeperl (Which is what I've always used) from the ActiveState site. I don't know if it will stay like that, but in case anyone is worried, strawberry seems to work 100% perfectly.
Indeed, ActivePerl download page seems to be missing 32bit versions currently. They are still available from official ActiveState download site though (ActivePerl 5.24 Win32 x86, ActivePerl 5.26 Win32 x86). Thanks for the information.

Anyway, as you said SPADS should work as well with Strawberry Perl as with ActivePerl.
1 x

User avatar
bibim
Lobby Developer
Posts: 901
Joined: 06 Dec 2007, 11:12

Re: SPADS AutoHost

Post by bibim » 07 Feb 2019, 20:48

Here are two diagrams to help autohost administrators understand how SPADS settings and presets are organized in the 3 main configuration files: spads.conf, hostingPresets.conf and battlePresets.conf. It is important to understand these 3 files contain different settings, you can't move settings from spads.conf to battlePresets.conf for example.

SPADS settings and presets structure
SPADS presets dependencies

The presets structures are just examples of course, lots of things are possible...
1 x

User avatar
bibim
Lobby Developer
Posts: 901
Joined: 06 Dec 2007, 11:12

Re: SPADS AutoHost

Post by bibim » 14 Apr 2019, 17:50

Experimental support for TLS has been added in SPADS 0.12.6 (only in "unstable" release for now).
You can try it by adding "lobbyTls=on" as command line parameter when launching SPADS.
2 x

User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Re: SPADS AutoHost

Post by Jools » 14 Apr 2019, 19:02

Do we need out our certificates? I know that Let's Encrypt provides that...
0 x

User avatar
bibim
Lobby Developer
Posts: 901
Joined: 06 Dec 2007, 11:12

Re: SPADS AutoHost

Post by bibim » 28 Apr 2019, 10:59

Not sure if this answers your question, but afaik currently only (self-signed) server side certificates are used in lobby protocol encryption, so you don't need your own certificates to run a SPADS instance.
SPADS does the same as SpringLobby: it validates the server certificate based on a trusted certificate fingerprint.
0 x

matyhaty
Posts: 9
Joined: 22 May 2014, 15:12

Re: SPADS AutoHost

Post by matyhaty » 14 Aug 2019, 19:47

im getting the following error in the install on new unbuntu:

NOTICE - [SpadsUpdater] Installing Spring 104.0.1-1888-g380151f into "/root/var/spring/104.0.1-1888-g380151f-linux64"...
ERROR - [SpadsUpdater] Failed to extract "/root/var/spring/104.0.1-1888-g380151f-linux64/spring_{develop}104.0.1-1888-g380151f_minimal-portable-linux64-static.7z", error while running 7zip (child process interrupted by signal 6, with coredump)
ERROR - [SpadsUpdater] Unable to extract Spring archive "/root/var/spring/104.0.1-1888-g380151f-linux64/spring_{develop}104.0.1-1888-g380151f_minimal-portable-linux64-static.7z"


Done the normal 7zip check / update....

IDeas?

@bibim
0 x

Post Reply

Return to “SPADS AutoHost”