Problem when installing IO::Socket::SSL for SPADS

Problem when installing IO::Socket::SSL for SPADS

SpringRTS Perl Autohost for Dedicated Server

Moderators: Moderators, Lobby Developers, SPADS AutoHost

Post Reply
MaDDoX
Posts: 68
Joined: 08 Jan 2006, 17:45

Problem when installing IO::Socket::SSL for SPADS

Post by MaDDoX »

bibim wrote: 13 Feb 2020, 12:00 For example for Debian based distributions (Ubuntu...):

Code: Select all

apt-get install libio-socket-ssl-perl
More generally, it is also possible to install this module without using the system package manager, by using the Perl "cpan" tool:

Code: Select all

cpan IO::Socket::SSL
No idea why, but in Ubuntu (recently upgraded to 21.04) neither apt-get nor cpan was able to build the required IO::Socket::SSL.
After trying it with cpan (After Silentwings told me that TSL wasn't working on my end, I wasn't getting any SPADS errors when trying to connect), I saw errors with Net::SSLeay, which is required by IO::Socket::SSL.
cpan wouldn't compile it after giving me some warnings, so I tried to compile it manually, according to:

https://www.thegeekstuff.com/2008/09/ho ... n-command/

Then finally

Code: Select all

sudo cpan IO::Socket::SSL
worked! Victory! :-)
User avatar
bibim
Lobby Developer
Posts: 938
Joined: 06 Dec 2007, 11:12

Re: Problem when installing IO::Socket::SSL for SPADS

Post by bibim »

MaDDoX wrote: 23 Aug 2021, 07:24 No idea why, but in Ubuntu (recently upgraded to 21.04) neither apt-get nor cpan was able to build the required IO::Socket::SSL.
That's strange, apt-get shouldn't even need to build anything, it should just download and install Perl modules and associated pre-compiled binaries for your distribution...
What error did you get with apt-get ?
MaDDoX wrote: 23 Aug 2021, 07:24 After trying it with cpan (After Silentwings told me that TSL wasn't working on my end, I wasn't getting any SPADS errors when trying to connect), I saw errors with Net::SSLeay, which is required by IO::Socket::SSL.
cpan wouldn't compile it after giving me some warnings, so I tried to compile it manually, according to:

https://www.thegeekstuff.com/2008/09/ho ... n-command/

Then finally

Code: Select all

sudo cpan IO::Socket::SSL
worked! Victory! :-)
Ah, maybe there is a problem with the current default Net::SSLeay version of your distribution, which is only fixed on the latest release that you used when compiling manually?
Thanks for the information.
Post Reply

Return to “SPADS AutoHost”

cron