SPADS shutdown

SPADS shutdown

SpringRTS Perl Autohost for Dedicated Server

Moderators: Moderators, Lobby Developers, SPADS AutoHost

Post Reply
User avatar
jetbird
Posts: 14
Joined: 21 Oct 2014, 13:19

SPADS shutdown

Post by jetbird » 02 May 2018, 22:03

Hi.

Recently I had established a SPADS autohost (2 spads hosts on the one server).

The launch command is:

Code: Select all

perl spads/spads.pl hosts/1v1/etc/spads.conf &
perl spads/spads.pl hosts/2v2/etc/spads.conf &
They work OK several days and then showtdown. I don't see any reason in logs. Just this:

Code: Select all

// spring-dedicated.log (for 1v1)
[GameServer] Connection attempt from Father
[GameServer]  -> Version: 104.0
[GameServer]  -> Address: [::ffff:93.172.107.162]:61319
[GameServer]  -> Connection established (given id 3)
[GameServer] Spectator Father finished loading and is now ingame
[GameServer] Spectator GnomeX left the game:  normal quit
[GameServer] Spectator Father left the game:  normal quit
[GameServer] Server killed!
[~CDemoRecorder] writing demo "/home/jetbird/hosts/1v1/instance/demos-server/20180426_044259_AltairHeckCrossing V3_104.sdfz"
[DedicatedServer] exiting
[DedicatedServer] exited
or

Code: Select all

// spring-dedicated.log for 2v2
[GameServer] Connection attempt from [PO]Usaga
[GameServer]  -> Version: 104.0
[GameServer]  -> Address: [::ffff:5.44.169.65]:59973
[GameServer]  -> Connection established (given id 0)
[GameServer] Connection attempt from [PO]mishel
[GameServer]  -> Version: 104.0
[GameServer]  -> Address: [::ffff:5.44.169.81]:65490
[GameServer]  -> Connection established (given id 1)
[GameServer] Player [PO]Usaga finished loading and is now ingame
[GameServer] Player [PO]mishel finished loading and is now ingame
[GameServer] Player [PO]Usaga left the game:  normal quit
[GameServer] Server killed!
[~CDemoRecorder] writing demo "/home/jetbird/hosts/2v2/instance/demos-server/20180501_085146_Tundra_104.sdfz"
[DedicatedServer] exiting
[DedicatedServer] exited
Pls help.
0 x

abma
Spring Developer
Posts: 3493
Joined: 01 Jun 2009, 00:08

Re: SPADS shutdown

Post by abma » 08 May 2018, 12:30

https://github.com/spring/spring/blob/f ... .cpp#L2388

something sends "kill" to spring-dedicated it seems.
0 x

User avatar
bibim
Lobby Developer
Posts: 879
Joined: 06 Dec 2007, 11:12

Re: SPADS shutdown

Post by bibim » 03 Jul 2018, 16:45

Did you find the cause of your problem ?
What is the value of your autoStop setting ?

As abma said, something is sending the "kill" command to spring-dedicated.

For example this can be SPADS itself due to autoStop configuration, or someone using the !send command to send it manually through SPADS like this: "!send /kill".
0 x

Post Reply

Return to “SPADS AutoHost”