Known issue(s) with pr-downloader based (engine) downloads

Known issue(s) with pr-downloader based (engine) downloads

For the discussion of infrastructure improvements and changes.

Moderator: Moderators

Post Reply
abma
Spring Developer
Posts: 3493
Joined: 01 Jun 2009, 00:08

Known issue(s) with pr-downloader based (engine) downloads

Post by abma » 14 May 2016, 20:05

pr-downloader and programs based on it (springlobby/weblobby/flobby/spring engine) sometimes fail to download the most recent engine version.

mostly it will only complain with "download failed".

to check whats going wrong:

1. check if the requested engine version does exist at http://api.springfiles.com/
2. check if it exists at https://springrts.com/dl/buildbot/
3. check if it exists in https://springrts.com/dl/buildbot/list.php

To make it appear at api.springfiles.com a cron-job creates list.php.

A known issue currently is, that the cron job only updates list.php when https://springrts.com/dl/buildbot/defau ... lop/LATEST is newer than list.php.
Currently this file is used for all engine versions, so when its updated in the wrong order, some engine versions can be missing in list.php.

To easily solve: every engine build should create its own LATEST file, i.e. LATEST_win32, LATEST_win64, an the cron job should check for all these files if they are newer than list.php. currently LATEST is only create for the win32 build: https://github.com/spring/spring/blob/a ... er.sh#L111

The clean fix would be to migrate api.springfiles.com to springrts.com/api/ and make the buildbot add the latest build directly to the file listing service.

Usually the missing files appear then the when engine build (a new commit) is made.

Help is wanted for solving this, see also viewtopic.php?f=71&t=33804

springfiles.com itself is unstable, so sometimes it fails to update because of crashes. Thats a reason for migrating it to springrts.com, too.

mantised: https://springrts.com/mantis/view.php?id=5232
0 x

Post Reply

Return to “Infrastructure Development”

cron