mediawiki updated on test.springrts.com

mediawiki updated on test.springrts.com

For the discussion of infrastructure improvements and changes.

Moderator: Moderators

Post Reply
Tobi
Spring Developer
Posts: 4598
Joined: 01 Jun 2005, 11:36

mediawiki updated on test.springrts.com

Post by Tobi » 06 Jul 2012, 21:01

On http://test.springrts.com/wiki I've updated mediawiki to 1.19.1, since our current version, MW 1.16.0, is no longer supported.

Major change is the editor: the WYSIWYG plugin we had installed in MW 1.16 does not exist for MW 1.19, so it has been removed. We don't go back to the crappy editor we had before that though, as MW 1.19 includes the editor used also by wikipedia et. al., so I've restyled that one a bit to fit better into the Spring site.

Please test (database is a copy of this site as of a week ago), and let us know any bugs you stumble upon, so we know whether this is good enough to deploy to the main site.

PS: Also we updated phpbb to 3.0.10 (from 3.0.6) a week ago, not many changes there as far as I have seen.
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: mediawiki updated on test.springrts.com

Post by knorke » 07 Jul 2012, 11:55

the search results link to normal wiki.

i could not get the ref-tag to work. (for foot notes)
wikipedia says they do not show in preview but after saving they just showed as text still. (more likely doing it wrong than bug)
0 x

Tobi
Spring Developer
Posts: 4598
Joined: 01 Jun 2005, 11:36

Re: mediawiki updated on test.springrts.com

Post by Tobi » 10 Jul 2012, 14:53

Thanks for testing!
knorke wrote:the search results link to normal wiki.
Looks like this isn't configured in the site itself, but rather in some google control panel. Not that important though, as long as the search on the real site keeps pointing to the real site :-)
knorke wrote:i could not get the ref-tag to work. (for foot notes)
wikipedia says they do not show in preview but after saving they just showed as text still. (more likely doing it wrong than bug)
Same for me and I copied the example from the help :-)
So might be something misconfigured after all, will take a look at that.

Another point: inline help in the editor is light gray on white, aka unreadable.
0 x

Tobi
Spring Developer
Posts: 4598
Joined: 01 Jun 2005, 11:36

Re: mediawiki updated on test.springrts.com

Post by Tobi » 15 Jul 2012, 13:36

References now work as well. Deploying Deployed to main site.
0 x

User avatar
FLOZi
MC: Legacy & Spring 1944 Developer
Posts: 6109
Joined: 29 Apr 2005, 01:14

Re: mediawiki updated on test.springrts.com

Post by FLOZi » 17 Jul 2012, 16:20

Something seems to have changed the font size when using <span class="warning">

also the 'categories' box at the end of the page has lost the spacing between links, c.f. http://springrts.com/wiki/Units-UnitDefs#Examples
0 x

Tobi
Spring Developer
Posts: 4598
Joined: 01 Jun 2005, 11:36

Re: mediawiki updated on test.springrts.com

Post by Tobi » 17 Jul 2012, 18:56

FLOZi wrote:Something seems to have changed the font size when using <span class="warning">
Fixed. Also for error and success spans.
also the 'categories' box at the end of the page has lost the spacing between links, c.f. http://springrts.com/wiki/Units-UnitDefs#Examples
Thanks, also fixed.
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14599
Joined: 17 Nov 2005, 02:43

Re: mediawiki updated on test.springrts.com

Post by Forboding Angel » 17 Jul 2012, 21:31

New editor is very nice! Thanks Tobi!
0 x

User avatar
FLOZi
MC: Legacy & Spring 1944 Developer
Posts: 6109
Joined: 29 Apr 2005, 01:14

Re: mediawiki updated on test.springrts.com

Post by FLOZi » 19 Oct 2012, 21:08

0 x

Post Reply

Return to “Infrastructure Development”