Howto: Make scriptor open files correctly

Howto: Make scriptor open files correctly

Resources to get you going on your new project, or to help you over some emergent problems during your development cycle.

Moderator: Moderators

Post Reply
Gnomre
Imperial Winter Developer
Posts: 1754
Joined: 06 Feb 2005, 13:42

Howto: Make scriptor open files correctly

Post by Gnomre » 19 Dec 2009, 17:23

Simply telling windows to open .bos files in Scriptor doesn't work right (at least, it never has for me). When set up that way, you'll commonly get a window that looks something like this:

Image

And each successive bos file you open comes up in a new scriptor process instead of the same one. Scriptor needs to use dde to properly open files on double click, which is why it's fucking up. Fixing it varies on your OS, though:

Windows XP (bear with me, I'm using 7 now. I'll have Flozi correct me if necessary)
In an explorer window, go to Tools->Folder Options. Click the File Types tab. Find bos in the list and edit it. You should get a window looking vaguely like this:

Image

Edit the 'open' command, and check the 'Use DDE' checkbox so you get a window something like this:

Image

Just make sure the fields are filled out as such:
Application: "C:\Path\To\Scriptor.exe" /dde
DDE Message: [open("%1")]
Leave all the other DDE fields blank.

If you did it right, once you click OK and apply those settings it should work properly now.



Windows 7 (and probably Vista)
In their infinite wisdom, Microsoft removed the part of the file type editor used above from Vista and 7, so you're going to have to go registry diving here.

Go ahead and create a broken file association here so we can edit. Double click any bos file, choose scriptor.exe to always open it, and watch it screw up.

Open regedit and first browse to:
HKEY_CLASSES_ROOT\.bos
Make sure (Default) is set to bos_auto_file

Now, go to:
HKEY_CLASSES_ROOT\bos_auto_file
Expand it until it looks something like this:
Image

Edit the (Default) field to read:
"C:\Games\Spring\Tools\Scriptor\Scriptor.exe" /dde
(change the path as necessary)

Now, right click the "open" folder in the left tree view and go to New->Key. Name the key ddeexec. Change its (Default) value to the following:
[open("%1")]
It should look like this:
Image

Assuming you did it right, it should work correctly now.

Hopefully this will help people in the future. At the very least, it'll help me, since I run into this problem every time I reinstall windows, and 7 was certainly a new adventure in making it work right
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14599
Joined: 17 Nov 2005, 02:43

Re: Howto: Make scriptor open files correctly

Post by Forboding Angel » 19 Dec 2009, 22:35

library to scripts directory (win7), in scriptor file>open... Profit?
0 x

User avatar
overkill
Posts: 500
Joined: 02 Sep 2006, 01:15

Re: Howto: Make scriptor open files correctly

Post by overkill » 19 Dec 2009, 23:09

workarounds != solutions
0 x

User avatar
Tribulex
A.N.T.S. Developer
Posts: 1894
Joined: 26 Sep 2009, 21:26

Re: Howto: Make scriptor open files correctly

Post by Tribulex » 20 Dec 2009, 19:18

overkill wrote:workarounds != solutions
well you didnt read this its a solution.
0 x

User avatar
lurker
Posts: 3842
Joined: 08 Jan 2007, 06:13

Re: Howto: Make scriptor open files correctly

Post by lurker » 20 Dec 2009, 20:16

d_b wrote:
overkill wrote:workarounds != solutions
well you didnt read this its a solution.
Is it so hard to figure out he's replying to the post immediately above his?
0 x

8611
XTA Developer
Posts: 242
Joined: 29 Dec 2014, 08:22

Re: Howto: Make scriptor open files correctly

Post by 8611 » 13 Apr 2015, 13:32

all images dead.
Scriptor tool could just have its on wiki page, if desired.
cob/bos scripts are basically not relevant anymore.
0 x

Post Reply

Return to “Game Development Tutorials & Resources”