Mac Binary Release - Page 18

Mac Binary Release

Discuss everything related to compiling and running Spring on Mac OS X.

Moderator: Moderators

User avatar
Echrei
Posts: 33
Joined: 01 Feb 2007, 07:13

Re: Mac Binary Release

Post by Echrei » 10 Jan 2008, 07:43

I'm trying to do a network game with someone, but it wont let them connect because with both have a playerid of 0, where do you change this?

Has anyone gotten a lobby to work in Mac OS?
0 x

User avatar
Peet
Malcontent
Posts: 4381
Joined: 27 Feb 2006, 22:04

Re: Mac Binary Release

Post by Peet » 10 Jan 2008, 18:20

Echrei wrote:I'm trying to do a network game with someone, but it wont let them connect because with both have a playerid of 0, where do you change this?

Has anyone gotten a lobby to work in Mac OS?
I spent a few hours trying to get SpringLobby working, but it won't compile. Edit script.txt to suit your needs and run spring from the command line, with script.txt as an argument.
0 x

User avatar
BrainDamage
Lobby Developer
Posts: 1164
Joined: 25 Sep 2006, 13:56

Re: Mac Binary Release

Post by BrainDamage » 10 Jan 2008, 18:26

mind sharing the compile errors you got so i can fix them?

use

Code: Select all

make -k -C
so it will dump the whole error list so i can fix them in one go

PS: no lobby will be able to work properly until commander builds the unitsync lib ...
0 x

User avatar
Peet
Malcontent
Posts: 4381
Joined: 27 Feb 2006, 22:04

Re: Mac Binary Release

Post by Peet » 10 Jan 2008, 18:32

Brain Damage wrote:mind sharing the compile errors you got so i can fix them?
IIRC I sent them to tc or semi (cant remember which of them was walking me through the compile) and they said the errors were too deep or too tedious to fix, or something of the sort.
0 x

User avatar
BrainDamage
Lobby Developer
Posts: 1164
Joined: 25 Sep 2006, 13:56

Re: Mac Binary Release

Post by BrainDamage » 10 Jan 2008, 18:39

iirc the ticket was closed since the code has been changed so much since your report and a new compile test would be needed, would you mind trying again?

join #springlobby in tasserver or #springlobby@freenode if you need help
0 x

Commander
Posts: 21
Joined: 27 Dec 2007, 22:02

Re: Mac Binary Release

Post by Commander » 10 Jan 2008, 20:01

New Release!

http://fabian.herb-clan.de/Spring-0.76b ... nomaps.dmg

I fixed the S3O loader, so most mods work on PPC Macs now. I tried XTA (XTAPEV93.sdz) and Gundam (GUNDAM111f4.sd7).

XTA runs fine, except for a few explosion sounds being too loud. In Gundam, most sounds are static noise, I get LUA errors, and the terrain detail texture does not appear?!

However KAI seems to be broken in SVN, I always get:
AI/Global/KAI-0.2/DamageControl.cpp:362: failed assertion `tohitprobability >= 0'

I always had and still have all unit build icons appearing. This bug is not reproducible for me.
0 x

User avatar
Echrei
Posts: 33
Joined: 01 Feb 2007, 07:13

Re: Mac Binary Release

Post by Echrei » 11 Jan 2008, 03:38

I got the new version, thanks!

I still don't get build icons. I'm running it on a G5. Anyone on a G5 see the icons? I'm running the BA60 mod.
0 x

User avatar
Echrei
Posts: 33
Joined: 01 Feb 2007, 07:13

Re: Mac Binary Release

Post by Echrei » 11 Jan 2008, 06:16

I just played an internet game with someone, worked well other than some lag. I turned his side of the mountains into water. :P
0 x

lifeofthunder
Posts: 1
Joined: 13 Jan 2008, 04:05

Re: Mac Binary Release

Post by lifeofthunder » 13 Jan 2008, 04:08

[PowerPC iMac G5]
So no matter what AI I attempt to use, the AI controlled commander simply stands there and does nothing. Unless I send a unit right up next to him, in which case he destroys my unit. I get a bunch of "wrong version" AI errors- I'm guessing they're related?

Otherwise, it looks beautiful. Thanks for the awesome work, guys.
0 x

User avatar
DandyGnome
Posts: 61
Joined: 25 Jun 2007, 06:43

Re: Mac Binary Release

Post by DandyGnome » 13 Jan 2008, 08:01

Using Spring-0.76b1+5286-nomaps with the mod UberHack, SpringVersion 1.3 and map Chess_b2.smf and startscript GlobalAI test (TestGlobalAI.dylib) I played a very quick game with no crash. I was using the LuaUI and the build icons were not appearing. Other than that everything seemed to work. Thanks Commander.
0 x

User avatar
Echrei
Posts: 33
Joined: 01 Feb 2007, 07:13

Re: Mac Binary Release

Post by Echrei » 13 Jan 2008, 09:20

I've had 4 freezes since the latest build. Force quitting hasn't work so I've had to restart the computer by holding the power button. It's happened on multiple mods and maps.
0 x

User avatar
Echrei
Posts: 33
Joined: 01 Feb 2007, 07:13

Re: Mac Binary Release

Post by Echrei » 13 Jan 2008, 09:20

lifeofthunder wrote:[PowerPC iMac G5]
So no matter what AI I attempt to use, the AI controlled commander simply stands there and does nothing. Unless I send a unit right up next to him, in which case he destroys my unit. I get a bunch of "wrong version" AI errors- I'm guessing they're related?

Otherwise, it looks beautiful. Thanks for the awesome work, guys.
You have to make sure the AI has a config file for the specific version of the mod you are using.
0 x

User avatar
Erom
Posts: 1115
Joined: 25 Apr 2006, 05:08

Re: Mac Binary Release

Post by Erom » 13 Jan 2008, 20:13

Commander wrote:In Gundam, ... the terrain detail texture does not appear?!
This is normal. The mod overrides the default detail texture with a blank one, so that maps in general more closely match the graphical "style" of the mod.
0 x

User avatar
DandyGnome
Posts: 61
Joined: 25 Jun 2007, 06:43

Re: Mac Binary Release

Post by DandyGnome » 13 Jan 2008, 22:11

Just started a game while at work and therefore I am playing windowed instead of fullscreen and the build icons appear. So they are only missing for me with fullscreen. So something is done differently between windowed and fullscreen mode. If this helps any the graphics card is an ATI Radeon X1600. As a side note I also noticed that spring handles switching between spaces (multiple desktops) not very well, as I kina expected it to. All the textures screw up and it sometimes follows which desktop I am paying attention to. So don't jump around between spaces while using spring.

Edited for clarity and completeness now that I am not at work.
0 x

User avatar
chillaaa
Posts: 234
Joined: 16 Mar 2005, 00:12

Re: Mac Binary Release

Post by chillaaa » 15 Jan 2008, 03:28

Just attempted to download the latest file and previous build youposted a page ago and i'm getting a 404 file doesnt exist.
0 x

User avatar
DandyGnome
Posts: 61
Joined: 25 Jun 2007, 06:43

Re: Mac Binary Release

Post by DandyGnome » 15 Jan 2008, 03:44

The link to the latest file is giving me a network timeout message.

Also setting spring to always stay in one space allows one to switch spaces without it going nuts.
0 x

Commander
Posts: 21
Joined: 27 Dec 2007, 22:02

Re: Mac Binary Release

Post by Commander » 15 Jan 2008, 20:22

chillaaa wrote:Just attempted to download the latest file and previous build youposted a page ago and i'm getting a 404 file doesnt exist.
Sorry, my web server was down. Now it's up again, and I uploaded a new release:

http://fabian.herb-clan.de/Spring-0.76b1+5330.dmg

This does however not fix any Mac specific bugs, it just incorporates changes to SVN.
0 x

User avatar
chillaaa
Posts: 234
Joined: 16 Mar 2005, 00:12

Re: Mac Binary Release

Post by chillaaa » 15 Jan 2008, 21:39

Thanks mate, i shall DL this as soon as im next on my MacBook Pro (later today).
0 x

scripty
Posts: 2
Joined: 17 Jan 2008, 01:25

Re: Mac Binary Release

Post by scripty » 17 Jan 2008, 01:38

hey!

thank you so much! 0.76b1+5330 is working fine on my macbook(core2duo integrated intel graphics).
build-icons only appear if spring is run in windowed mode via Fullscreen=0 in Preferences/com.clan-sy.spring.Spring.plist, which kills performance.

i also tested the same build on an intel imac with ati graphics. same issue with build icons.

(network play & AI untested, i'm into sm3 mapping)

thanx a lot for all your effort! keep up the good work! you rock!

scripty
0 x

scripty
Posts: 2
Joined: 17 Jan 2008, 01:25

Re: Mac Binary Release

Post by scripty » 19 Jan 2008, 03:13

i tested it again in a LAN game. (custom sm3 map, both leopard)

iMac C2D Radeon X1600
white/no build icons

macbook C2D
buildicons working
both in fullscreen

started lan games with:
./Spring -s -n bar
./Spring -c -n foo
in <path-to-Spring>/Spring.app/Contents/MacOS

(took me ages to find that info how to start lan games ;) )
i dared an edited the wiki: http://spring.clan-sy.com/wiki/Spring_on_MacOSX

hope thats ok ;)

cya
0 x

Post Reply

Return to “Mac OS X”

cron