Who Can Set Minimum Engine Version?

Who Can Set Minimum Engine Version?

Discuss development of lobby clients, server, autohosts and auto-download software.

Moderators: Moderators, Lobby Developers

Locked
User avatar
FLOZi
MC: Legacy & Spring 1944 Developer
Posts: 6235
Joined: 29 Apr 2005, 01:14

Who Can Set Minimum Engine Version?

Post by FLOZi »

Who?
User avatar
FLOZi
MC: Legacy & Spring 1944 Developer
Posts: 6235
Joined: 29 Apr 2005, 01:14

Re: Who Can Set Minimum Engine Version?

Post by FLOZi »

abma
dansan
TurBoss
hokomoko
silentwings
User avatar
FLOZi
MC: Legacy & Spring 1944 Developer
Posts: 6235
Joined: 29 Apr 2005, 01:14

Re: Who Can Set Minimum Engine Version?

Post by FLOZi »

I beg you if you ever had the slightest respect for me, set minimum version to 101.

I am no longer forum admin.
User avatar
Silentwings
Moderator
Posts: 3686
Joined: 25 Oct 2008, 00:23

Re: Who Can Set Minimum Engine Version?

Post by Silentwings »

I'd add my support if/when either:
- It's clear that "enough" non-absent engine/infra developers want that.
- I felt confident that no significant future engine development will happen. (At which point, I don't stick around - but I don't think this condition is met right now. I guess games could continue alone, but central infra probably not, and I don't want to write lua again.)
User avatar
FLOZi
MC: Legacy & Spring 1944 Developer
Posts: 6235
Joined: 29 Apr 2005, 01:14

Re: Who Can Set Minimum Engine Version?

Post by FLOZi »

I simply don't understand how one has any bearing on the other.

'mature' projects will spin off onto their own infrastructure, a viewpoint I've always disagreed with but can see the merit in. If that is inevitable than it makes sense to me for the 'official' server to essentially be a sandbox of all that Spring offers. That means any version, any game, any battle room size.


How does that prevent new versions and further development?
User avatar
Silentwings
Moderator
Posts: 3686
Joined: 25 Oct 2008, 00:23

Re: Who Can Set Minimum Engine Version?

Post by Silentwings »

I simply don't understand how one has any bearing on the other.
I don't think I can/should make that judgement, others are best placed to - e.g. viewtopic.php?p=590818#p590818
User avatar
FLOZi
MC: Legacy & Spring 1944 Developer
Posts: 6235
Joined: 29 Apr 2005, 01:14

Re: Who Can Set Minimum Engine Version?

Post by FLOZi »

Lets consider that argument;
why would anyone want to contribute when all they see getting airtime is some old engine from N years ago?
How does forcing those people onto their own infrastructure change that? All it means is now you see an even more diminished pool of people playing. There is a critical mass required for a thriving server, to ensure the possibility of people finding others to play with. Which is why only well established projects with reasonable playerbase i.e., ZK, BA, BAR can host their own infrastructure. ThinkSome has suggested S44 go the same route, we have maybe 6 players. What is the point? Those larger games will push engine development. They might have hundreds of players. Those people will appreciate the new development. Why must everyone?

I see people playing (very) old versions of S44 sometimes. It saddens me, I pm them and encourage to join the up-to-date room. Often they prefer to play the old version against the AI. At least they are enjoying something I helped create.

Lets consider hoko's suggestions:
1) Port the game you want to play to a recent engine.
2) Hire someone else to do it.
3) Maintain your own infrastructure.
4) Play smaller games.
5) Play something else.
1) is not an option for mac users
2) Likewise
3) The option they are forced to take, but which is detrimental to the sustainability of player numbers in both their and the 'official' server.
4) Why should they have to after a decade of being able to play 8v8?
5) Why should they have to after a decade of being able to play BA?
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Who Can Set Minimum Engine Version?

Post by abma »

the decision heavily simplified was:

switch off springrts.com/springfiles.com/springlobby.com or restrict 103.0 on the official server. what would you choose?

i still fully agree with kloot, supporting very old versions of spring is really frustrating, i don't want to do that. Thats why i vote and voted for the restriction.
Flash
Posts: 36
Joined: 12 Dec 2010, 18:03

Re: Who Can Set Minimum Engine Version?

Post by Flash »

Who deleted my previous post and why?
No shame?
abma wrote: 21 Jun 2020, 20:21 the decision heavily simplified was:

switch off springrts.com/springfiles.com/springlobby.com or restrict 103.0 on the official server. what would you choose?

who do you want to believe that?


User was warned for this post. Felony 2. Please only constructive criticism.
side note: it was me that deleted your post, as it is not constructive. But it seems you prefer a warning. For believers i usually go to church.

please inform yourself before posting, i.e. https://springrts.com/wiki/Spring:Organization
also i've locked this thread as this leads to nothing.
-- abma
Locked

Return to “Lobby Clients & Server”