SPADS broken connection detected error

SPADS broken connection detected error

Discuss development of lobby clients, server, autohosts and auto-download software.

Moderators: Moderators, Lobby Developers

Post Reply
Teabag
Posts: 26
Joined: 26 May 2016, 19:11

SPADS broken connection detected error

Post by Teabag » 10 Jan 2018, 20:13

I had SPADS working for a few days but now i have a different problem and unable to start (AGAIN)

I have run clean installs of SPADS on two separate win10 systems both with the same error.

any ideas?
20180110190143 - NOTICE - [SPADS] Initializing SPADS 0.12.2
20180110190143 - NOTICE - [SPADS] Loading Spring archives using unitsync library version 104 ...
20180110190155 - INFO - [SPADS] Spring archives loading process took 12 seconds
20180110190155 - NOTICE - [SPADS] Spring server mode: headless
20180110190155 - NOTICE - [SimpleEvent] Event loop initialized using internal model
20180110190155 - NOTICE - [SpringAutoHostInterface] Listening on AutoHost port (127.0.0.1:8454)
20180110190155 - NOTICE - [SimpleEvent] Starting event loop...
20180110190155 - NOTICE - [SpringLobbyInterface] Connecting to lobby.springrts.com:8200
20180110190155 - WARNING - [SPADS] Unable to find network interfaces in registry, trying ipconfig workaround...
20180110190155 - INFO - [SPADS] Following local LAN IP address detected: 192.168.1.76
20180110190155 - WARNING - [SPADS] Unable to retrieve CPU info from Windows registry
20180110190155 - INFO - [SPADS] Logged on lobby server
20180110190155 - WARNING - [SpringLobbyInterface] Found invalid accountId parameter value "None" (should be integer) in lobby command ADDUSER
20180110190155 - NOTICE - [SPADS] TrueSkill service available
20180110190155 - WARNING - [SpringLobbyInterface] Ignoring duplicate ADDUSER command for user "[PinK]triton"
20180110190155 - WARNING - [SpringLobbyInterface] Ignoring duplicate ADDUSER command for user "Kodiak"
20180110190155 - WARNING - [SPADS] The lobby account currently used by SPADS is not tagged as bot. It is recommended to ask a lobby administrator for bot flag on accounts used by SPADS
20180110190156 - WARNING - [SPADS] Disconnecting from lobby server (broken connection detected)
20180110190156 - NOTICE - [SpringLobbyInterface] Disconnecting from lobby.springrts.com:8200
0 x

User avatar
FabriceFABS
Posts: 329
Joined: 28 Jul 2010, 16:20

Re: SPADS broken connection detected error

Post by FabriceFABS » 10 Jan 2018, 21:13

I changed configuration on 2 hosts this morning, and they aren't able to connect anymore.
(I did several retries all the day)

Loop :

Code: Select all

NOTICE   - [SPADS] TrueSkill service available
WARNING  - [SPADS] Disconnecting from lobby server (broken connection detected)
WARNING  - [SPADS] Disconnecting from lobby server (broken connection detected)
IMO TeaBag, this issue is from infra, not from Spads.
0 x

Teabag
Posts: 26
Joined: 26 May 2016, 19:11

Re: SPADS broken connection detected error

Post by Teabag » 10 Jan 2018, 22:19

Good to see that i am not alone :lol:
0 x

Teabag
Posts: 26
Joined: 26 May 2016, 19:11

Re: SPADS broken connection detected error

Post by Teabag » 10 Jan 2018, 22:25

working now
0 x

User avatar
FabriceFABS
Posts: 329
Joined: 28 Jul 2010, 16:20

Re: SPADS broken connection detected error

Post by FabriceFABS » 11 Jan 2018, 09:16

+1 yes same on my side.
0 x

abma
Spring Developer
Posts: 3493
Joined: 01 Jun 2009, 00:08

Re: SPADS broken connection detected error

Post by abma » 15 Jan 2018, 12:09

0 x

Teabag
Posts: 26
Joined: 26 May 2016, 19:11

Re: SPADS broken connection detected error

Post by Teabag » 17 Mar 2018, 20:22

i have this error again :?

Code: Select all

20180317192141 - NOTICE   - [SimpleEvent] Starting event loop...
20180317192141 - NOTICE   - [SpringLobbyInterface] Connecting to lobby.springrts.com:8200
20180317192141 - NOTICE   - [SPADS] Lobby server default engine is Spring 104, UnitSync is using Spring 104.0.1-151-g11de57d maintenance
20180317192141 - INFO     - [SPADS] Logged on lobby server
20180317192141 - NOTICE   - [SPADS] TrueSkill service available
20180317192141 - WARNING  - [SpringLobbyInterface] Ignoring duplicate ADDUSER command for user "notAspace029"
20180317192141 - WARNING  - [SpringLobbyInterface] Ignoring duplicate ADDUSER command for user "notAspace021"
20180317192141 - INFO     - [SPADS] Channel DarkEnergy joined
20180317192141 - INFO     - [SPADS] Channel fr joined
20180317192141 - INFO     - [SPADS] Channel es joined
20180317192141 - INFO     - [SPADS] Channel se joined
20180317192141 - INFO     - [SPADS] Channel ru joined
20180317192141 - INFO     - [SPADS] Channel en joined
20180317192141 - INFO     - [SPADS] Channel hu joined
20180317192141 - INFO     - [SPADS] Channel dk joined
20180317192141 - INFO     - [SPADS] Channel fi joined
20180317192141 - INFO     - [SPADS] Channel pt joined
20180317192141 - INFO     - [SPADS] Channel de joined
20180317192141 - INFO     - [SPADS] Channel pl joined
20180317192141 - INFO     - [SPADS] Channel it joined
20180317192141 - INFO     - [SPADS] Channel nl joined
20180317192142 - WARNING  - [SPADS] Disconnecting from lobby server (broken connection detected)
20180317192142 - NOTICE   - [SpringLobbyInterface] Disconnecting from lobby.springrts.com:8200
Last edited by Teabag on 17 Mar 2018, 20:41, edited 1 time in total.
0 x

User avatar
Silentwings
Moderator
Posts: 3433
Joined: 25 Oct 2008, 00:23

Re: SPADS broken connection detected error

Post by Silentwings » 17 Mar 2018, 21:36

For info: seems that this causes autohosts to be unable to reconnect to the lobbyserver, but I'm unsure of why. Already logged in autohosts work correctly, provided they do not log out, and non-bot users seem unaffected.
0 x

Post Reply

Return to “Lobby Clients & Server”