SpringLobby 0.267 released! - Page 11

SpringLobby 0.267 released!

Moderators: Moderators, Lobby Developers

User avatar
jamerlan
Balanced Annihilation Developer
Posts: 683
Joined: 20 Oct 2009, 13:04

Re: SpringLobby 0.242 released!

Post by jamerlan » 12 Oct 2015, 06:46

darklord42 wrote:Sorry guys I went and upgraded to 10.11. It makes it difficult to build 10.10 builds anymore. One day I'll have to look into it, but for now here is a 10.11 build of springloby 0.242
http://www.mediafire.com/download/8sdnv ... -10.11.dmg
Thanks! I think that it's OK to support only latest version of Mac OS X :-) Most of the people updating fast enough
0 x

darklord42
Posts: 96
Joined: 26 Jul 2014, 07:11

Re: SpringLobby 0.242 released!

Post by darklord42 » 12 Oct 2015, 15:56

Well I could see people waiting half a year before updating as the initial release is usually a mess.. I can also see people with older computers not wanting to update at all as an update doesn't really benefit the old hardware much. I really would like to support 10.7 and up. My laptop is 5 years old so It stands to reason 5 year old OS's should at least be supported. It's a matter of setting up macports again, and hoping for the best. (Alure too...Also I don't know if I have to rebuild boost...)
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.242 released!

Post by albator » 25 Oct 2015, 19:10

0.225 -> 0.242:

new 0.242 stall my complete X. IT actually even fuck up xkill: xkill tell me "unable to grab cursor"

SO for me I stay with the 0.225 for now. No error message to help unfortunately...

Mint 17.2 x64 cinnamon
0 x

abma
Spring Developer
Posts: 3555
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.242 released!

Post by abma » 25 Oct 2015, 19:24

albator wrote:new 0.242 stall my complete X. IT actually even fuck up xkill: xkill tell me "unable to grab cursor"
wrong conclusion. your system is broken! fix your drivers / installation! an application should never be able to such a thing. with more details i maybe can help better, but this really doesn't sound like a springlobby error / bug.

you could try to run from console with springlobby -cl to get more/verbose messages.
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.242 released!

Post by albator » 25 Oct 2015, 20:43

This is what it gives:

http://pastebin.com/R8wF6KPe

FYI, I have same GTK pb with other SL versions.

Only difference is that that time SL stalls so that is difficult to believe this:
wrong conclusion. your system is broken! fix your drivers / installation!
Maybe you can enlighten me why only that version of SL crashed
0 x

abma
Spring Developer
Posts: 3555
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.242 released!

Post by abma » 25 Oct 2015, 20:52

albator wrote:Maybe you can enlighten me why only that version of SL crashed
please first enlighten me, to give instructions on what you are doing to get springlobby crashing. also, the output of help->system info is very likely useful!
0 x

abma
Spring Developer
Posts: 3555
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.242 released!

Post by abma » 25 Oct 2015, 21:02

Code: Select all

Warning  /home/pierre/Softwares/springlobby-0.242/src/gui/mapgridctrl.cpp:277 Map Charlie in the Hills v2.1 already in grid!
this message very likely happens when a map is deleted or different engine versions are used and one of them can't read / doesn't see the map (=SpringData is configured wrong)

edit: no, this can happen when opening map dialog and selecting popluar / recent played maps but not all maps are downloaded, should be fixed here: https://github.com/springlobby/springlo ... 61aca944f0

but still this doesn't explain the crash.

btw. released 0.243 which fixes at least the message box spam in the map dialog.
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.243 released!

Post by albator » 26 Oct 2015, 20:36

Code: Select all

SpringLobby 0.243 (unix x64)
SpringLobby config file: /home/pierre/.springlobby/springlobby.conf ( writable)
LobbyWriteDir (/home/pierre/.springlobby/)
	WX: yes POSIX: yes TRY: yes
CachePath (/home/pierre/.springlobby/cache/)
	WX: yes POSIX: yes TRY: yes
ExecutableFolder (/usr/local/bin/)
	WX: no POSIX: no TRY: no
DownloadDir (/home/pierre/.spring/)
	WX: yes POSIX: yes TRY: yes
Current SpringData: (/home/pierre/.config/spring/)
	WX: yes POSIX: yes TRY: yes
Current unitsync: /home/pierre/.spring/engine/100.0/libunitsync.so
Current spring executable: /home/pierre/.spring/engine/100.0/spring
Current uikeys.txt: /home/pierre/.config/spring/uikeys.txt
Portable mode: no
Compiled with wxWidgets 3.0.0.0
Started with: 
springlobby -cl 



The overall behavior of SL is relatively slow when comparing to previous versions

At start it always freeze for 15 sec (the CPU load reach 25% continuously on a 4 threaded CPU). My X stalls as well in the mean time (not the sound however): I cannot browse my internet browser for example. I notice the replay panel is up to date when opening.
So my guess is: SL command to stall some stuff in the GUI while it browses the replay folder and that interacts somehow with some X components of my system. It should not and does not make sense to me either but it is the feeling that I have from what I tested so far.

Attached is a log. I can do many things and it does not crashed until the end when I exit. It is far less responsive than the other SL version

http://pastebin.com/mT4sDRcg

It always crashed when exiting as far as I tested
0 x

8611z
Posts: 169
Joined: 08 Jul 2015, 20:20

Re: SpringLobby 0.243 released!

Post by 8611z » 26 Oct 2015, 22:32

I set up new computer. Question before it becomes 'infected' with spring:
In past I had manually unzipped engine versions, using multiple lobbies (for ex springlobby+zKlobby) etc and there was always files appearing in "my documents" of Windows OS. No idea if that was from wrong config, or the lobbies and their downloaded engines conflicting but I do not want this anymore.
Is it possible to install springlobby to "c:\games\spring\" (or similiar) and everything lobby/spring related will stay in there?
Will setting springlobby's download-folder archive that, or also have to configure springsettings.cfg?
0 x

abma
Spring Developer
Posts: 3555
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.243 released!

Post by abma » 26 Oct 2015, 22:35

8611z wrote:Will setting springlobby's download-folder archive that, or also have to configure springsettings.cfg?
springlobby doesn't set SpringData for each downloaded engine, so you have to change SpringData for each engine you download via springlobby. not sure if its possible to create one springsettings.cfg in ~\my games\spring\ and set the data dir only once.
0 x

8611z
Posts: 169
Joined: 08 Jul 2015, 20:20

Re: SpringLobby 0.243 released!

Post by 8611z » 27 Oct 2015, 20:55

Setting all the SpringDataDirs never worked for me...but maybe it was other lobbies or maybe forgot it one time for testversions or so.
In installer is a checkbox ("portable") but it is greyed out.. will use the zip then.
Attachments
bla.jpg
(42.37 KiB) Not downloaded yet
0 x

abma
Spring Developer
Posts: 3555
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.243 released!

Post by abma » 27 Oct 2015, 21:48

8611z wrote:In installer is a checkbox ("portable") but it is greyed out.. will use the zip then.
thats by purpose, it doesn't work / isn't implemented :regret:
0 x

8611z
Posts: 169
Joined: 08 Jul 2015, 20:20

Re: SpringLobby 0.243 released!

Post by 8611z » 27 Oct 2015, 21:57

Knowing that could have saved me some hope.
Anyway, after some other issues (see github) these filders/folders were created in user-folder, and have not even managed to start to get ingame...

Code: Select all

C:\Users\otte\Documents\My Games\Spring>tree /f /a

C:.
|   springsettings.cfg
|   unitsync.log
|
\---cache
    |   ArchiveCache10.lua
    |
    +---100rel-
    |       CACHEDIR.TAG
    |
    \---98rel-
            CACHEDIR.TAG
The downloads seem to save to in the set folder though.
0 x

8611z
Posts: 169
Joined: 08 Jul 2015, 20:20

Re: SpringLobby 0.243 released!

Post by 8611z » 09 Nov 2015, 14:45

Diar diary,
After some days of playing:
Spring has mostly managed to stay in its installation path G:\Spiele\SpringLobby
At bit has leaked into "my documents folder:"
C:\Users\otte\Documents\My Games\Spring
Demos, screenshots, logfiles, archivecache and other small files are appearing there.
Mostly I just did not just did not want to clutter the system-SSD with gigabytes of downloads, so a few MB of such files there is "acceptable."


Now I wanted to download a file. I could not dl anything with springlobbys dialog https://github.com/springlobby/springlobby/issues/591 and could not find it on springfiles.com either. viewtopic.php?f=71&t=33992
So I used pr-downloader:
In springlobby folder was no pr-downloader.
But SL had created folders for all the downloaded engines, like G:\Spiele\SpringLobby\engine\100.0 , and inside each engine-folder was a pr-downloader.
This seems bit redundant, maybe pr-downloader should not be included with engine but with lobby?

pr-downloader was started from commandline like:
G:\Spiele\SpringLobby\engine\100.0>pr-downloader --download-game "Spring Feature
s v1.6"

But it downloaded to "my documents."
Now I see pr-downloader has argument --filesystem-writepath, so probally should have used that...
Attachments
pr log.txt
(2.88 KiB) Downloaded 8 times
0 x

User avatar
Sgt Doom
Posts: 144
Joined: 19 Jun 2006, 10:52

Re: SpringLobby 0.243 released!

Post by Sgt Doom » 28 Dec 2015, 11:27

For some reason, it will absolutely not recognize maps and games placed in the main directory, but only in the folder created in Documents/My Games (on Windows 10). While a minor annoyance, i'd much prefer keeping everything in one folder; how would I go about getting it to see what's right under it's nose? Tried setting the dl folder to the main Spring one, but that didn't help. And god knows where the hell it puts stuff downloaded through the Download Archives tab.
0 x

abma
Spring Developer
Posts: 3555
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.244 released!

Post by abma » 10 Apr 2016, 19:34

Sgt Doom wrote:For some reason, it will absolutely not recognize maps and games placed in the main directory, but only in the folder created in Documents/My Games (on Windows 10). While a minor annoyance, i'd much prefer keeping everything in one folder; how would I go about getting it to see what's right under it's nose? Tried setting the dl folder to the main Spring one, but that didn't help. And god knows where the hell it puts stuff downloaded through the Download Archives tab.
edit springlobby.conf / change DownloadDir there
0 x

abma
Spring Developer
Posts: 3555
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.244 released!

Post by abma » 10 Apr 2016, 19:35

released springlobby 0.244:

Code: Select all

 - fix memleaks
 - improve metadata caching (i.e. map images are stored in small + large size, json is used for metadata)
 - add "Notify me when game has ended" to context menu (sends !notify)
 - don't show rapid meta files in downloads (i.e. version.gz)
 - a lot of code simplifications / refactorings
 - use prdownloader c-api (instead of using hacks to get download info)
 - remove broken + unused crashreporter
 - speedup demo reloading: only new files are parsed
 - fix crash in FORCEJOINBATTLE
 - drop Boost.Filesystem dependency
 - add support for .sdfz replay format
 - wxWidgets >= 3.0 is required to compile springlobby
 
edit: cache format changed -> a lot of stuff needs to be recached, so expect some hangs after the update, but these should heavily reduce when the cache is (re)filled again.
0 x

User avatar
qray
Posts: 377
Joined: 02 Feb 2009, 18:49

Re: SpringLobby 0.244 released!

Post by qray » 11 Apr 2016, 00:11

Thanks for the update and all the effort you put in! :-)
On a first quick try: no problems.
0 x

raaar
Metal Factions Developer
Posts: 816
Joined: 20 Feb 2010, 12:17

Re: SpringLobby 0.244 released!

Post by raaar » 11 Apr 2016, 02:05

Good job. Thanks.
0 x

abma
Spring Developer
Posts: 3555
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.245 released!

Post by abma » 16 Apr 2016, 23:24

released springlobby 0.245, bugfix release only:
- fix crash on battle close
- fix springsettings always greyed out
- fix vote panel shown only once
- fix notification on user login
- fix osx compile
0 x

Post Reply

Return to “SpringLobby Client”