Lobby Server + Spads + Spring in one lan

Lobby Server + Spads + Spring in one lan

Discuss development of lobby clients, server, autohosts and auto-download software.

Moderators: Moderators, Lobby Developers

Post Reply
User avatar
RickHustle
Posts: 51
Joined: 13 Sep 2012, 14:40

Lobby Server + Spads + Spring in one lan

Post by RickHustle »

Hello. I have problem to configure lobby server (uberserver) + spads + spring in one lan.
uberserver and spads at one PC (Debian), player at other PC (WIn7).

uberserver running:

Started lobby server!
Connect the lobby client to
public: 178.71.9.100:8200
private: 192.168.1.40:8200

Part of spads conf:

lobbyHost:localhost
lobbyPort:8200
lobbyReconnectDelay:30
lobbyFollowRedirect:1
lobbyLogin:Metal_Server
lobbyPassword:xxxxx

# Local network configuration
localLanIp:192.168.1.40
autoHostPort:8454
forceHostIp:

At this configuration all users from internet can connect to spring lobby and can start game and play. I can connect to spring lobby too. But when spring is start it cannot connect to my external ip (178.71.9.100:8452).
If i set lobbyHost setting to 192.168.1.40 - i can connect and play, but others players cannot because their spring trying to connect at 192.168.1.40:8452 (my local address of spads).
My local PC IP 192.168.1.41.

What can i do in this situation? Is it possible to configure Lobby server + Spads + Spring to work in one lan?
Last edited by RickHustle on 01 Jan 2022, 16:10, edited 1 time in total.
raaar
Metal Factions Developer
Posts: 1019
Joined: 20 Feb 2010, 12:17

Re: Lobby Server + Spads + Spring in one lan

Post by raaar »

Hi, have you solved your problem?

Is there a particular reason to run your own uberserver? Why not connect to the official server through the internet and play there?
User avatar
RickHustle
Posts: 51
Joined: 13 Sep 2012, 14:40

Re: Lobby Server + Spads + Spring in one lan

Post by RickHustle »

No, i'm not.

I need Spring 103 and BA 9.46. springfightclub.com was closed so i have to do my own lobby server.
raaar
Metal Factions Developer
Posts: 1019
Joined: 20 Feb 2010, 12:17

Re: Lobby Server + Spads + Spring in one lan

Post by raaar »

You wrote that the other PCs are using win 7, so they should work with Spring 104.0 and later.

The BA development that kept to 9.46 for a while eventually made new versions compatible with 104.0 and then 105.0 and the battle rooms on the official server were updated (now V14.4.0).
User avatar
RickHustle
Posts: 51
Joined: 13 Sep 2012, 14:40

Re: Lobby Server + Spads + Spring in one lan

Post by RickHustle »

I know, because i want old Spring 103 and BA9.46. They worked perfect at springfightclub.com. New versions have other balance. My game partner's dislike it. Moreover, in order to switch to new versions, I would have to update the Debian version. Now it's 9. This is really bad. Dedicated server contains other projects, not spring only.
Let's return to question of topic?
I think that nothing changes in new versions of spring in this question.
Ares
Balanced Annihilation Developer
Posts: 490
Joined: 19 Mar 2011, 13:43

Re: Lobby Server + Spads + Spring in one lan

Post by Ares »

please allow Rick to host on official so the official host can gain more players
abma
Spring Developer
Posts: 3779
Joined: 01 Jun 2009, 00:08

Re: Lobby Server + Spads + Spring in one lan

Post by abma »

RickHustle wrote: 01 Jan 2022, 00:30 Part of spads conf:

lobbyHost:localhost

my guess is, that you have to use the public ip 178.71.9.100 of your uberserver instance to make it work. to debug it, you should check to which port / ip spring is connecting when a game is starting: check infolog.txt + script.txt for that.
abma
Spring Developer
Posts: 3779
Joined: 01 Jun 2009, 00:08

Re: Lobby Server + Spads + Spring in one lan

Post by abma »

Ares wrote: 01 Jan 2022, 17:26 please allow Rick to host on official so the official host can gain more players
i understand this request, but i / we don't want to deal with players which complain about old spring engine versions crashing and other related problems with it which are solved in newer engine versions.
User avatar
RickHustle
Posts: 51
Joined: 13 Sep 2012, 14:40

Re: Lobby Server + Spads + Spring in one lan

Post by RickHustle »

abma wrote: 10 Jan 2022, 09:51
RickHustle wrote: 01 Jan 2022, 00:30 Part of spads conf:

lobbyHost:localhost

my guess is, that you have to use the public ip 178.71.9.100 of your uberserver instance to make it work. to debug it, you should check to which port / ip spring is connecting when a game is starting: check infolog.txt + script.txt for that.
infolog.txt when i start alone with bot:

Spring 103.0 (Dedicated)
Build Environment: boost-105600, GNU libstdc++ version 20150623
Compiler Version: gcc-4.8.5
Operating System: Linux 4.9.0-8-amd64 #1 SMP Debian 4.9.144-3.1 (2019-02-19) x86_64
Word Size: 64-bit (native mode)
Run: /root/spads/var/spring/103.0-linux64/spring-dedicated "/root/spads/var/instance_mando/startscript.txt"
Using configuration source: "/root/spads/var/instance_mando/springsettings.cfg"
Using additional configuration source: "/root/.config/spring/springsettings.cfg"
Available log sections: GameServer, DedicatedServer, ArchiveScanner, CrashHandler, AutohostInterface, VFS
Enabled log sections: DedicatedServer(Notice)
Enable or disable log sections using the LogSections configuration key
or the SPRING_LOG_SECTIONS environment variable (both comma separated).
Use "none" to disable the default log sections.
LogOutput initialized.
Using read-write data directory: /root/spads/var/instance_mando/
Using read-only data directory: /root/.config/spring/
Using read-only data directory: /root/spads/var/spring/103.0-linux64/
Using read-only data directory: /root/spads/var/spring/data/
Scanning: /root/spads/var/spring/data/maps
Scanning: /root/spads/var/spring/data/games
Scanning: /root/spads/var/spring/data/packages
Scanning: /root/spads/var/spring/103.0-linux64/base
[DedicatedServer] report any errors to Mantis or the forums.
[DedicatedServer] loading script from file: /root/spads/var/instance_mando/startscript.txt
[DedicatedServer] starting server...
Binding UDP socket to IP (v6) :: () port 8452
[UDPListener] successfully bound socket on port 8452
[GameServer] Connecting to autohost on port 8454
[GameServer] Server started on port 8452
[DedicatedServer] recording demo: /root/spads/var/instance_mando/demos-server/20220110_232332_AltairHeckCrossing V3_103.sdfz
[DedicatedServer] using mod: Balanced Annihilation V9.46
[DedicatedServer] using map: AltairHeckCrossing V3.3
[DedicatedServer] GameID: c495dc61fd9e1fe1d3e5188cfe7088d8
[GameServer] No clients connected, shutting down server
[DedicatedServer] exiting
Writing demo: /root/spads/var/instance_mando/demos-server/20220110_232332_AltairHeckCrossing V3_103.sdfz
[DedicatedServer] exited

infolog.txt when start 2 players in other net (game is start, all is ok):

Spring 103.0 (Dedicated)
Build Environment: boost-105600, GNU libstdc++ version 20150623
Compiler Version: gcc-4.8.5
Operating System: Linux 4.9.0-8-amd64 #1 SMP Debian 4.9.144-3.1 (2019-02-19) x86_64
Word Size: 64-bit (native mode)
Run: /root/spads/var/spring/103.0-linux64/spring-dedicated "/root/spads/var/instance_mando/startscript.txt"
Using configuration source: "/root/spads/var/instance_mando/springsettings.cfg"
Using additional configuration source: "/root/.config/spring/springsettings.cfg"
Available log sections: GameServer, DedicatedServer, ArchiveScanner, CrashHandler, AutohostInterface, VFS
Enabled log sections: DedicatedServer(Notice)
Enable or disable log sections using the LogSections configuration key
or the SPRING_LOG_SECTIONS environment variable (both comma separated).
Use "none" to disable the default log sections.
LogOutput initialized.
Using read-write data directory: /root/spads/var/instance_mando/
Using read-only data directory: /root/.config/spring/
Using read-only data directory: /root/spads/var/spring/103.0-linux64/
Using read-only data directory: /root/spads/var/spring/data/
Scanning: /root/spads/var/spring/data/maps
Scanning: /root/spads/var/spring/data/games
Scanning: /root/spads/var/spring/data/packages
Scanning: /root/spads/var/spring/103.0-linux64/base
[DedicatedServer] report any errors to Mantis or the forums.
[DedicatedServer] loading script from file: /root/spads/var/instance_mando/startscript.txt
[DedicatedServer] starting server...
Binding UDP socket to IP (v6) :: () port 8452
[UDPListener] successfully bound socket on port 8452
[GameServer] Connecting to autohost on port 8454
[GameServer] Server started on port 8452
[DedicatedServer] recording demo: /root/spads/var/instance_mando/demos-server/20220107_004321_AltairHeckCrossing V3_103.sdfz
[DedicatedServer] using mod: Balanced Annihilation V9.46
[DedicatedServer] using map: AltairHeckCrossing V3.3
[DedicatedServer] GameID: 7962d761d8ad82b394c6fb5a3576e97e
[GameServer] Connection attempt from Great
[GameServer] -> Version: 103.0
[GameServer] -> Address: [::ffff:176.59.23.31]:65018
[GameServer] -> Connection established (given id 0)
[GameServer] Connection attempt from [RuR]Dixon
[GameServer] -> Version: 103.0
[GameServer] -> Address: [::ffff:80.77.163.254]:56058
[GameServer] -> Connection established (given id 1)
[GameServer] Player Great finished loading and is now ingame
[GameServer] Player [RuR]Dixon finished loading and is now ingame
[GameServer] Spectator [RuR]Dixon left the game: normal quit
[GameServer] Server killed!!!
[DedicatedServer] exiting
Writing demo: /root/spads/var/instance_mando/demos-server/20220107_004321_AltairHeckCrossing V3_103.sdfz
[DedicatedServer] exited

I don't know where is script.txt

When spring is start i can see:
connect to server: my external IP:8452
abma
Spring Developer
Posts: 3779
Joined: 01 Jun 2009, 00:08

Re: Lobby Server + Spads + Spring in one lan

Post by abma »

Binding UDP socket to IP (v6) :: () port 8452
just a guess: disable ipv6 on the host where spring dedicated is running to force it to use ipv4.
User avatar
RickHustle
Posts: 51
Joined: 13 Sep 2012, 14:40

Re: Lobby Server + Spads + Spring in one lan

Post by RickHustle »

I disabled ipv6 on the host - nothing changed. All the same.
abma
Spring Developer
Posts: 3779
Joined: 01 Jun 2009, 00:08

Re: Lobby Server + Spads + Spring in one lan

Post by abma »

RickHustle wrote: 10 Jan 2022, 23:12 I disabled ipv6 on the host - nothing changed. All the same.
did you correctly setup the firewall rules?

IMHO you need at least forward TCP 8200 and UDP 8452 to the server.
User avatar
RickHustle
Posts: 51
Joined: 13 Sep 2012, 14:40

Re: Lobby Server + Spads + Spring in one lan

Post by RickHustle »

abma wrote: 10 Jan 2022, 23:27 did you correctly setup the firewall rules?

IMHO you need at least forward TCP 8200 and UDP 8452 to the server.
This ports is opened by settings.
ports.jpg
ports2.jpg
Moreover, Spring can started perfect when i used springfightclub.com , so it means that port for spring is opened.
Now users from internet can also connect to my spads and using my uberserver - so ports for others also opened.
Post Reply

Return to “Lobby Clients & Server”

cron