Official Map Blueprint/Container - Page 3

Official Map Blueprint/Container

Tutorials & Resources For Mappers

Moderator: Moderators

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: Official Map Blueprint/Container

Post by knorke » 13 Aug 2011, 07:27

you can browse around to see changes ie
https://github.com/jk3064/Map-Blueprint ... 4c644a9bd2

Maybe a "basic blueprint" would be good, with just the mapinfo.lua and whatever else files are needed to read it. (without all the other gadgets)
Also does this allow to change the minimap or is that something in the .smt/.smf files that can not be changed?

Slightly unrelated, but have to ask since I noticed you use LuaGaia. What is the difference between LuaGaia and LuaRules?
LuaGaia does not get reloaded on /luarules reload?
http://answers.springlobby.info/questio ... is-luagaia
0 x

User avatar
smoth
Posts: 22298
Joined: 13 Jan 2005, 00:46

Re: Official Map Blueprint/Container

Post by smoth » 01 Sep 2011, 04:03

cloud color does not seem to have an effect on the cloud's color jk. Any ideas?
0 x

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: Official Map Blueprint/Container

Post by jK » 01 Sep 2011, 04:10

Forboding Angel wrote:Next issue:

Code: Select all

		cloudDensity = 0.1,
		cloudColor   = {1.0, 1.0, 1.0},
Doesn't work :-<
jK wrote:and Forb, it works fine. And when you want help with problems you got you may need to give a bit more information than "Doesn't work :-<" ...
-> can't reproduce!
0 x

User avatar
smoth
Posts: 22298
Joined: 13 Jan 2005, 00:46

Re: Official Map Blueprint/Container

Post by smoth » 01 Sep 2011, 04:19

Cloud color is supposed to control the actual color of the sky clouds. I didn't say it "doesn't work" I am saying, they are not recieving the color assigned to them.

Say I did yellow as the cloud color. the clouds should be yellow. but they stay white.
0 x

User avatar
smoth
Posts: 22298
Joined: 13 Jan 2005, 00:46

Re: Official Map Blueprint/Container

Post by smoth » 01 Sep 2011, 05:49

cloudColor = {0.0, 0.0, 0.5},
Image
white clouds, they should be blue right?
0 x

User avatar
smoth
Posts: 22298
Joined: 13 Jan 2005, 00:46

Re: Official Map Blueprint/Container

Post by smoth » 01 Sep 2011, 13:39

[23:03:59]That's a terrible example
They are white but I had to check in photoshop, the human brain doesn't perceive colours as absolutes
I can tell. I am very keen on colors..
[23:13:39] that's night ...
mapoptions override/modify input values
Yes and I saw that you were setting night values..
so I removed the overrides you set: http://pastebin.com/vGYnaQRj

So ok, maybe it isn't obvious or maybe it is a tint.. so let me post another shot..
Image
this time with cloudColor = {1.0, 0.0, 0.0},

so to me, it looks like cloudcolor has 0 effect. it may be the wrong name. I cannot investigate in the engine code today to see what the tag is supposed to be but the tint has no effect. I am trying to get with you and test your code. If I am doing it wrong, please show me an example with fushia clouds that are not receiving their color from the other parameters.

p.s. it is not the shift either, I tried removing that as well. I think we have the wrong tag jk.
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14603
Joined: 17 Nov 2005, 02:43

Re: Official Map Blueprint/Container

Post by Forboding Angel » 03 Sep 2011, 01:25

http://www.evolutionrts.info/random/Evo ... -FUBAR-.7z

^^ for you JK, special. Please stop telling me that it isn't bugged. Also, I noticed that some of the mapoptions aren't working right (most notably, inverted heightmap).

This bug report reminds me of this thread: http://springrts.com/phpbb/viewtopic.ph ... almon+pink
0 x

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: Official Map Blueprint/Container

Post by jK » 06 Sep 2011, 09:15

Forboding Angel wrote:Also, I noticed that some of the mapoptions aren't working right (most notably, inverted heightmap).
For inverted heightmap you need to set smf.minheight & smf.maxheight.
0 x

User avatar
smoth
Posts: 22298
Joined: 13 Jan 2005, 00:46

Re: Official Map Blueprint/Container

Post by smoth » 06 Sep 2011, 13:04

This is why I needed to get the new map out with all of it as a working example. Just a bit longer i had to redo the map this weekend.
0 x

User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Re: Official Map Blueprint/Container

Post by Jools » 21 Sep 2011, 00:39

--startpic = "", --// deprecated
--StartMusic = "", --// deprecated
Is it possible to have a map-specific startpic?
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: Official Map Blueprint/Container

Post by knorke » 21 Sep 2011, 00:41

appearently by putting in lots of startpictures that will overwrite the ones from the mod.
see Speedball etc
0 x

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: Official Map Blueprint/Container

Post by jK » 21 Sep 2011, 00:55

Jools wrote:
--startpic = "", --// deprecated
--StartMusic = "", --// deprecated
Is it possible to have a map-specific startpic?
Yes, but in 84 those tags won't work anymore.
0 x

User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Re: Official Map Blueprint/Container

Post by Jools » 21 Sep 2011, 01:17

Ok, but I wonder if I will ever be alive then even. We're now only at 0.82.7 ;)
0 x

User avatar
smoth
Posts: 22298
Joined: 13 Jan 2005, 00:46

Re: Official Map Blueprint/Container

Post by smoth » 09 Oct 2011, 01:27

> new issue <

storing the start points may be bad to do in the mapinfo.lua.

lobbies cannot see the start point locations to show them on the preview.

Thoughts JK?
0 x

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: Official Map Blueprint/Container

Post by jK » 09 Oct 2011, 08:44

Lobbies should stop parsing files themselves.
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14603
Joined: 17 Nov 2005, 02:43

Re: Official Map Blueprint/Container

Post by Forboding Angel » 04 Feb 2012, 05:57

SplatTexScales = { 10, 10, 10, 0.0005 },

changing these values in mapinfo.lua seems to do nothing
I've been deflating and inflating the values to huge and tiny amounts to try and get a change

Image

http://www.imagebam.com/image/bf5101173071346 << no matter what values I use, I still get this
0 x

Post Reply

Return to “Map Tutorials & Resources”