BA and Hd 5870: bad texture.

BA and Hd 5870: bad texture.

Classic game design, maintained to please you...

Moderator: Content Developer

Post Reply
H2O
Posts: 32
Joined: 27 May 2010, 23:05

BA and Hd 5870: bad texture.

Post by H2O » 28 May 2010, 10:06

Hi,
i'm playing Balanced Annihilation and I have a Ati HD 5870 vapor-x. I had Catalyst 10.3, but with this version the game sometimes froze, so I have updated to Catalyst 10.5 (doing it in the right way, first disinstalled the old one, cleaned it with driver sweeper and installed the new ones). The problem is that with this Catalyst version the texture of every unit is like alluminium.
I've uploaded an image http://img709.imageshack.us/i/balancedannihilation.jpg/

I've tried playing with another mod and no problem at all, so this bad texture problem is BA specific.

I didn't test it long, so I doesn't know if the freeze problem is gone.

I've tried changing setting in Spring and in the Control Catalyst, but nothing works.

Thanks in advance.

If you need more info, just ask for them.
0 x

H2O
Posts: 32
Joined: 27 May 2010, 23:05

Re: BA and Hd 5870: bad texture.

Post by H2O » 28 May 2010, 13:42

Update: I've played a lit bit more with Complete Annihilation and some units have the sametexture problem of Balanced Annihilation, maybe because they are direct port of BA units, like Necro or the Doomsday.
0 x

User avatar
Tribulex
A.N.T.S. Developer
Posts: 1894
Joined: 26 Sep 2009, 21:26

Re: BA and Hd 5870: bad texture.

Post by Tribulex » 01 Jun 2010, 09:23

3dos it seems.
0 x

User avatar
Mav
Posts: 258
Joined: 12 Nov 2009, 20:06

Re: BA and Hd 5870: bad texture.

Post by Mav » 02 Jun 2010, 09:21

Not trolling, but everyone talks about how much cheaper ATI cards are compared to Nvidia.

I pay more for my drivers. Forget the hardware.
0 x

User avatar
oksnoop2
Posts: 1207
Joined: 29 Aug 2009, 20:12

Re: BA and Hd 5870: bad texture.

Post by oksnoop2 » 05 Jun 2010, 05:17

http://pastebin.com/RCnD07uX

I just updated my ati driver and now i have the same problem.
0 x

H2O
Posts: 32
Joined: 27 May 2010, 23:05

Re: BA and Hd 5870: bad texture.

Post by H2O » 06 Jun 2010, 14:06

Thanks for the answers.

I hope Spring, Ba or next Ati drivers fix this problem, it is very annoying. However I'm feeling a little better knowing that i'm not the only one with this problem.


@Mav: please don't start the "Nvidia drivers are better" discussion, because everybody remember the Nvidia Driver Burning up graphics cards just a few month ago (version 196.75 IIRC).
0 x

User avatar
Hobo Joe
Posts: 1001
Joined: 02 Jan 2008, 21:55

Re: BA and Hd 5870: bad texture.

Post by Hobo Joe » 07 Jun 2010, 15:25

H2O wrote:Thanks for the answers.

I hope Spring, Ba or next Ati drivers fix this problem, it is very annoying. However I'm feeling a little better knowing that i'm not the only one with this problem.


@Mav: please don't start the "Nvidia drivers are better" discussion, because everybody remember the Nvidia Driver Burning up graphics cards just a few month ago (version 196.75 IIRC).

And everybody also remembers the last 10 years of shitty ATI drivers.
0 x

H2O
Posts: 32
Joined: 27 May 2010, 23:05

Re: BA and Hd 5870: bad texture.

Post by H2O » 10 Jun 2010, 10:53

Hobo Joe wrote: And everybody also remembers the last 10 years of shitty ATI drivers.
Oh, come on, here we go with the Nvidia-ATI debate, don't you have a better place to go flaming?

I've an ATI and this texture problem, i've made this post just to let other people who have the same problem and the developers know that this bad texture exist with catalyst 10.5.

I don't care which is better ati or nvidia, because it doesn't matter anymore, i'm not asking for an advise on which to buy, i've already bought it.

So please stop with the Nvidia-Ati flaming, because it is like if i go to a doctor because i can't breath well, and he says that i should have another man's lungs. USELESS

But if you have suggestion, like the one who says that with 10.4 this problem does exist, you are welcome.

Otherwise go flaming in another place.
0 x

User avatar
Mav
Posts: 258
Joined: 12 Nov 2009, 20:06

Re: BA and Hd 5870: bad texture.

Post by Mav » 10 Jun 2010, 17:08

This wasn't an attempt at flaming: this is advice for anyone looking to buy hardware. Look through previous posts on the forum and you'll see how many people have had problems with spring because of ATI drivers.

My advice: if you want to play Spring, get nVidia.

And this has nothing to do with "the doctor said get new lungs". You don't have a choice what lungs you get. This is more along the lines of "the doctor told me not to smoke, everything I read online said people that smoke get lung problems, I smoked anyway and now I've got cancer and want help." You had a choice to get nVidia (known for their expensive cards and drivers that work) or ATI (known for cheaper prices and shitty drivers). You chose the cheap option and now you're paying for it.

This is not a "flame war". This is an informative post from people who know about these things warning others that play games on Spring to stay away from these cards. They're cheap but not worth the driver hassle IMO.
0 x

User avatar
Zydox
Lobby Developer
Posts: 453
Joined: 23 May 2006, 13:54

Re: BA and Hd 5870: bad texture.

Post by Zydox » 30 Jun 2010, 14:59

I agree with Mav...
I've only bought Nvidia cards the last years becuase they've always worked great with Spring, not because they are better or worse than ATI
0 x

User avatar
Gota
Posts: 7151
Joined: 11 Jan 2008, 16:55

Re: BA and Hd 5870: bad texture.

Post by Gota » 01 Jul 2010, 10:08

Indeed,though if i recall nvidia cards also have some issues...
I use an ATI and there are some driver issues however i never felt i need to pay 100$ more cause i need to revert to a previous ati driver version.
0 x

User avatar
manolo_
Posts: 1370
Joined: 01 Jul 2008, 00:08

Re: BA and Hd 5870: bad texture.

Post by manolo_ » 01 Jul 2010, 21:58

i have the same problem after i updated to 10.6 (with 10.5 all was fine), so i downgraded to 10.5, but the problem remains :(, but i have to setup the system again anyway
0 x

H2O
Posts: 32
Joined: 27 May 2010, 23:05

Re: BA and Hd 5870: bad texture.

Post by H2O » 02 Jul 2010, 14:58

It is strange, everybody reported texture problem with the 10.5 and the 10.6. Your safe bet is the 10.4, i'm using it and i have no problem at all with Balanced Annihilation texture.
0 x

User avatar
Gota
Posts: 7151
Joined: 11 Jan 2008, 16:55

Re: BA and Hd 5870: bad texture.

Post by Gota » 02 Jul 2010, 15:46

Yes 10.4 is fine
0 x

H2O
Posts: 32
Joined: 27 May 2010, 23:05

Re: BA and Hd 5870: bad texture.

Post by H2O » 29 Aug 2010, 01:16

Ati has fixed the problem with the 10.8 release.
Hurray for Ati! :mrgreen:
0 x

User avatar
TradeMark
Posts: 4867
Joined: 17 Feb 2006, 15:58

Re: BA and Hd 5870: bad texture.

Post by TradeMark » 03 Sep 2010, 18:46

For my experience, i've have more problems with nvidia than ATI.
0 x

User avatar
Neddie
Community Lead
Posts: 9406
Joined: 10 Apr 2006, 05:05

Re: BA and Hd 5870: bad texture.

Post by Neddie » 03 Sep 2010, 18:49

TradeMark wrote:For my experience, i've have more problems with nvidia than ATI.
We can all assure you, your experience exemplifies the exception, not the rule.
0 x

User avatar
Echo419
Posts: 64
Joined: 31 Aug 2010, 14:09

Re: BA and Hd 5870: bad texture.

Post by Echo419 » 09 Sep 2010, 13:10

i buy whatever is best power for money at the time and have never had an issue.
0 x

Post Reply

Return to “Balanced Annihilation”