"Spring settings" warning won't go away

"Spring settings" warning won't go away

Moderator: Content Developer

Post Reply
User avatar
PauloMorfeo
Posts: 2004
Joined: 15 Dec 2004, 20:53

"Spring settings" warning won't go away

Post by PauloMorfeo »

Hi,

Running Kernel Panic 4.6 on SpringRTS 95 on Ubuntu 12.04.

When I start a game of Kernel Panic I have a pop-up in the middle of the screen saying it is the first time I'm playing Spring and asking whether I want the "game" to adjust Spring Settings.

That pop-up is always there, every game.
Clicking either of the buttons won't make it go away.
The buttons appear to recognize the mouse, since they change appearence on mouse-hover.
The window/buttons might be not accepting clicks, though, since I can order units into the play-area by clicking over the window.

---
I'm playing around with Kernel Panic to play with AI, so this isn't a show-stopper. Still, a huge annoyance! I reckon there's some setting somewhere Kernel Panic loads to make the verification of whether to load that pop-up?
User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7031
Joined: 16 Nov 2004, 13:08

Re: "Spring settings" warning won't go away

Post by zwzsg »

I had the same problem.

It turns out gadget:MousePress is not called when LoadingMT = 0

http://springrts.com/phpbb/viewtopic.php?f=11&t=30338

Suggested solutions:
- Edit springsettings.cfg to manually add: KPHasForceSettingRanOnce = 1
- Disable safemode, and set LoadingMT to 1 in your springsettings.cfg
- Ask engine devs if it's a bug or a normal behavior that gadget:MousePress isn't called
- Blame new engine version for buginess and rever to ancient engines

Of course maybe I could remove that gadget, since people are unlikely to have unknowingly disabled LuaUI nowadays. But eh, easier for me to do nothing and blame others! :P
Last edited by zwzsg on 04 Oct 2014, 23:46, edited 1 time in total.
Reason: Forgot the KPHasForceSettingRanOnce = 1
gajop
Moderator
Posts: 3040
Joined: 05 Aug 2009, 20:42

Re: "Spring settings" warning won't go away

Post by gajop »

Seems like a bug, but on another note, why do you even have gadget:MousePress? Is there a reason you insist that mouse handling is done in a gadget instead of a widget?
User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7031
Joined: 16 Nov 2004, 13:08

Re: "Spring settings" warning won't go away

Post by zwzsg »

Yes, it was made a time when LuaUI was optional, and had to be enabled in SpringSettings. This gadget was initially made to remind people to switch on LuaUI.
User avatar
PauloMorfeo
Posts: 2004
Joined: 15 Dec 2004, 20:53

Re: "Spring settings" warning won't go away

Post by PauloMorfeo »

zwzsg wrote:...
- Edit springsettings.cfg to manually add: KPHasForceSettingRanOnce = 1
...
That did the trick, thanks. I was pretty sure there would be a work-around like that.

Though now it's poping me up a message saying that LuaUI is off, and is requesting me whether to turn it on or just leave it off (which of course still doesn't work). And after the game starts it disappears and new "window" appears saying «press any key» (or similar).

It's still an improvement, since the box is much smaller and not so intrusive :)

---
EDIT
zwzsg wrote:...
- Disable safemode, and set LoadingMT to 1 in your springsettings.cfg
...
I don't know how to try that alternative...
"Disable safemode"?
"LoadingMT to 1" = adding the line «LoadingMT = 1»? (doesn't currently exist)
User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7031
Joined: 16 Nov 2004, 13:08

Re: "Spring settings" warning won't go away

Post by zwzsg »

PauloMorfeo wrote:Though now it's poping me up a message saying that LuaUI is off
Is LuaUI really off? That would be annoying. Did you want it off?

Anyway, with KPHasForceSettingRanOnce = 3 (yay, unguessable magick values!) the gadget should disable itself and show neither messages.

PauloMorfeo wrote:"LoadingMT to 1" = adding the line «LoadingMT = 1»? (doesn't currently exist)
If it doesn't exist, it defaults to the default value, which is 1 actually -1 ???, but still not 0.

Maybe my theory about how gadget:MousePress is not called when in safemode or LoadingMT = 0 is wrong, and you found another case where gadget:MousePress isn't called? Idk.

PauloMorfeo wrote:Running Kernel Panic 4.6 on SpringRTS 95 on Ubuntu 12.04.
95? But latest stable engine version is 96, and according to mantis, this bug was fixed in 96.

By the way, related mantis issue: http://springrts.com/mantis/view.php?id=4091
User avatar
PauloMorfeo
Posts: 2004
Joined: 15 Dec 2004, 20:53

Re: "Spring settings" warning won't go away

Post by PauloMorfeo »

zwzsg wrote:...
PauloMorfeo wrote:Running Kernel Panic 4.6 on SpringRTS 95 on Ubuntu 12.04.
95? But latest stable engine version is 96, and according to mantis, this bug was fixed in 96.
...
I know. I had been trying to install and use somewhere v96 even by source code, unsuccesfully.
http://springrts.com/phpbb/viewtopic.php?f=11&t=32593
I think the problem was not just to do with Spring's engine. I'm in a laptop with Optimus and at the time I was using the Intel GFX card. When I managed to force spring to run on the Nvidia one, the buttons were working fine.

I can confirm that I'm running v96 now with the NVidia card and everything runs fine as (apparently) expected.
User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7031
Joined: 16 Nov 2004, 13:08

Re: "Spring settings" warning won't go away

Post by zwzsg »

Ok, I found out why you get the message saying that LuaUI is off.

I used Spring.GetConfigInt("LuaUI")==0 to check if LuaUI is off.
A long time this worked, but nowadays, LuaUI is just a custom config key, without any signification to the engine.

I have no idea how to check if LuaUI is disabled on current engine version.
Post Reply

Return to “Kernel Panic”