"d" Key Is Not Responsive

"d" Key Is Not Responsive

Moderator: Content Developer

Post Reply
superstacker007
Posts: 1
Joined: 19 Aug 2011, 02:06

"d" Key Is Not Responsive

Post by superstacker007 » 19 Aug 2011, 02:15

Hi there.

I just downloaded Kernel Panic and I love it. At first I found that camera movement with the arrow keys to be awkward for me, so I remapped the keys to WASD:

Code: Select all

moveforward = Any+W and Any+Up Arrow
moveleft = Any+A and Any+Left Arrow
moveright = Any+D and Any+Right Arrow
moveback = Any+S and Any+Down Arrow
Unfortunately, it seems that the "D" key sometimes is not responsive. I believe this usually happens when, after a couple of minutes into the game, I pan the default camera view over a "hilly" area. At that point, moving the camera back right with the "D" key doesn't work.

Strange thing is, using the right arrow key to move the camera right does work. I don't get it.

If it helps, I am running Windows 7 64-bit.

Thanks guys.
0 x

User avatar
KaiserJ
Community Representative
Posts: 3113
Joined: 08 Sep 2008, 22:59

Re: "d" Key Is Not Responsive

Post by KaiserJ » 19 Aug 2011, 17:49

could be a conflict with standard commands layout;

A = attack, D = defend, S = stop etc

should mention that there are quite a few ways to pan other than arrow keys (and more time-effective ones too) such as middle-click-drag or pressing tab, mousing to where you want, and tab again

not sure what else the problem could be other than a binding conflict

cheers and welcome to the forum
0 x

User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7001
Joined: 16 Nov 2004, 13:08

Re: "d" Key Is Not Responsive

Post by zwzsg » 19 Aug 2011, 19:19

D is not for Defence, but for D-Gun. Ok there is no D-Gun in Kernel Panic. But D is still used for special abilities such as Bombard, Dispatch, Launch Mine, NX Flag, ...

So your D key won't work when you have a byte, a pointer, a bug, a connection, or a port selected.
0 x

Godde
Posts: 268
Joined: 29 Mar 2010, 17:54

Re: "d" Key Is Not Responsive

Post by Godde » 22 Aug 2011, 19:56

Try removing the 'Any' modifier. The Any modifier makes thoose commands be used after all other commands, bound to the same key, have been tried. There is a Kernel Panic widget that make thoose keybindings. 'Kernel Panic Hotkeys' it's called. Alternatively you can turn off that widget. You propably need to restart the game for it to have effect.
0 x

Post Reply

Return to “Kernel Panic”