Bug: Cant see any writing

Bug: Cant see any writing

A dynamic game undergoing constant development and refinement, that attempts to balance playability with fresh and innovative features.

Moderator: Content Developer

Post Reply
User avatar
the-middleman
Posts: 190
Joined: 24 Jul 2007, 12:18

Bug: Cant see any writing

Post by the-middleman » 16 Nov 2012, 15:45

After many years away from spring I came back to try Zero-K. When I get ingame in singleplayer I cant see any writing.

Any ideas?

Image
0 x

User avatar
smoth
Posts: 22300
Joined: 13 Jan 2005, 00:46

Re: Bug: Cant see any writing

Post by smoth » 16 Nov 2012, 16:49

infolog please.
0 x

User avatar
the-middleman
Posts: 190
Joined: 24 Jul 2007, 12:18

Re: Bug: Cant see any writing

Post by the-middleman » 16 Nov 2012, 17:17

There you go
Attachments
infolog.txt
(35.59 KiB) Downloaded 32 times
0 x

User avatar
smoth
Posts: 22300
Joined: 13 Jan 2005, 00:46

Re: Bug: Cant see any writing

Post by smoth » 16 Nov 2012, 17:32

have you tried not using spring MT to run zk? If so, was the result the same?
[f=0000855] [GML] Warning: (1/5) Invalid attempt to invoke LuaUI (TeamDied) from another Lua environment, this game is using engine features that may require LuaThreadingModel > 2 to work properly with Spring MT.
[f=0000855] Team 1 wins!
[f=0000855] Submitting stats
[f=0000855] [GML] Warning: (2/5) Invalid attempt to invoke LuaUI (GameOver) from another Lua environment, this game is using engine features that may require LuaThreadingModel > 2 to work properly with Spring MT.
0 x

User avatar
the-middleman
Posts: 190
Joined: 24 Jul 2007, 12:18

Re: Bug: Cant see any writing

Post by the-middleman » 16 Nov 2012, 17:46

Same with or without MT
0 x

User avatar
smoth
Posts: 22300
Joined: 13 Jan 2005, 00:46

Re: Bug: Cant see any writing

Post by smoth » 16 Nov 2012, 18:02

have you tried updating your drivers?
0 x

User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7017
Joined: 16 Nov 2004, 13:08

Re: Bug: Cant see any writing

Post by zwzsg » 16 Nov 2012, 18:59

IANAD but this smell like incompatibility between your graphic card and Spring. I've been told that the solution is to boo ATI for its poor OpenGL support and buy an NVIDIA.

Since that solution is expensive, you can also try downgrading or upgrading both your driver and your Spring, and hope to find a combination of the Spring version and driver version where the bug doesn't show. Of course you won't be able to play online without lastest Spring, and no GPU driver beside latest may be available.

Good luck!
0 x

User avatar
SinbadEV
Posts: 6475
Joined: 02 May 2005, 03:56

Re: Bug: Cant see any writing

Post by SinbadEV » 16 Nov 2012, 19:11

zwzsg wrote:you can also try downgrading or upgrading both your driver and your Spring
Yeah, the "reccomended" drivers from your computer maker are very often crap... I fixed some graphics issues I was having with Blender on my HP laptop with by downloading and installing the drivers directly from the chip-set manufacturer (Intel) instead... it's not that hard, you've just got to click "Shut Up, I know what I'm doing" a few times.
0 x

User avatar
the-middleman
Posts: 190
Joined: 24 Jul 2007, 12:18

Re: Bug: Cant see any writing

Post by the-middleman » 17 Nov 2012, 18:46

My drivers are indeed very old. Unfortunately I cannot update them. If I use Mobility Modder or Omega drivers I have issues with other games which I play more often...

If I ever by a new pc I guess it will be Nvidea...
0 x

User avatar
the-middleman
Posts: 190
Joined: 24 Jul 2007, 12:18

Re: Bug: Cant see any writing

Post by the-middleman » 18 Nov 2012, 18:55

I decided to what the fuck and just install new drivers. Now Im glad to say that zero-K works fine.

Just one thing: I have to type /advmapshading at the beginning of each game or else I just see a white map. Is there a way to turn of advmapshading by default? I tried putting it in springsettings.cfg but that didnt do very much.
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: Bug: Cant see any writing

Post by knorke » 24 Nov 2012, 20:23

Is there a way to turn of advmapshading by default? I tried putting it in springsettings.cfg but that didnt do very much.
AdvMapShading = 0
see first line of infolog.txt "Using configuration source: "blablabla\springsettings.cfg", to make sure you are editing the right springsettings.cfg
0 x

Post Reply

Return to “Zero-K”