[misc] enforcment of spring >= 104.0 for autohosts with botflag - Page 2

[misc] enforcment of spring >= 104.0 for autohosts with botflag

Happenin' news on what is happening in the community. Content releases, new tutorials, other cool stuff.
abma
Spring Developer
Posts: 3544
Joined: 01 Jun 2009, 00:08

Re: [misc] spring >= 104.0

Post by abma » 10 Apr 2019, 14:35

Flash wrote:
10 Apr 2019, 13:11
What a great idea to ban the most played mod
1. we are talking about a game
2. without the current engine beeing used, the whole spring project is dead which is more crucial
3. alternatives exist: fixed/updated games are available
4. + the reasons from viewtopic.php?f=38&t=39277#p590389
2 x

User avatar
Silentwings
Moderator
Posts: 3582
Joined: 25 Oct 2008, 00:23

Re: [misc] spring >= 104.0

Post by Silentwings » 10 Apr 2019, 14:56

3. alternatives exist: fixed/updated games are available
For BA users not wanting BA10, there actually isn't a good option with 104.0 atm - although it seems largely due to no one from this crowd playtesting if stuff worked in advance, and generally keeping heads in sand.

Phoenix Annihilation is a "plain" port of BA9 but its current version has a few jarring bugs with 104.0 (afaik they are a mix of games/engines fault). It's repo is https://github.com/phoenix-annihilation ... nihilation. I can accept PRs or give commit access to it, but I don't have the time/interest to fix it myself atm.

Subsisting on old versions, and dying the slow death of hardware progression & public exploits, may well be favoured by some communities, and may well happen elsewhere - but I don't think the engine devs are interested in having it here.
2 x

Flash
Posts: 32
Joined: 12 Dec 2010, 18:03

Re: [misc] spring >= 104.0

Post by Flash » 10 Apr 2019, 15:00

Yes its "just" a game. But for the last years it was a shared "playground" of players and devs. With this decision you brought the majority of players to find a place to play their favorite game elsewhere.
As long as we dont have a ba10.x Version the majority can live with and apple users are not excluded in new engine its just not a good idea to exclude the most played and stable 103 Version.
Just see server stats and act please!
0 x

User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Re: [misc] spring >= 104.0

Post by Jools » 10 Apr 2019, 15:10

0 x

abma
Spring Developer
Posts: 3544
Joined: 01 Jun 2009, 00:08

Re: [misc] spring >= 104.0

Post by abma » 10 Apr 2019, 15:59

Flash wrote:
10 Apr 2019, 15:00
Yes its "just" a game. But for the last years it was a shared "playground" of players and devs. With this decision you brought the majority of players to find a place to play their favorite game elsewhere.
As long as we dont have a ba10.x Version the majority can live with and apple users are not excluded in new engine its just not a good idea to exclude the most played and stable 103 Version.
Just see server stats and act please!
without beeing actively maintained, the place "elsewhere" will be soon "dead", too. The problem IMHO is, that gamedevs abandoned because players didn't want to help to run a new version. The same would happen with engine devs, too when we stay with 103.0.

No engine and game devs -> project dead. Dead project -> server will be switched of. For the project "spring" it doesn't matter much, if there are players or not.

again: this is mostly a non-commercial project. don't expect commercial like support.
0 x

Mando
Posts: 16
Joined: 10 Apr 2019, 14:47

Re: [misc] spring >= 104.0

Post by Mando » 10 Apr 2019, 16:00

Finally someone made the first post.

I knew eventually Mando had to bother writing something on this forum.
Well this is going to be another waste of time i guess but being a good boy Mando is still going to do this.
abma wrote:
25 Mar 2019, 22:23

1) using older spring versions blocks development
2) older spring versions contain crash / DoS bugs
3) we need to look forward: newer versions have more features / cleaner code / scale better / are more friendly to game devs.
1) There is a reason why everyone still want to use older engine version. Is not that after 500 updates successfully accepted by the players they became all suddenly sick of new versions ALL together.
2) This is a total marketing bullshit. Same bugs are still there and more exploits available in main lobby since last updates. The fact that noone DDoS hosts or exploits anymore make you guys think you solved the problem and eventually sell this as a reason to force new engine.
3) 100% agree with that.

Solution is simple but you and other admins wont follow cuz too much ego typical of nerdish frustrated mentality.
So i will list one more time just for the record:

1) Stop abusing admin powers and behave professionally with all players in an unbiased way.
2) Stop using botflags and SLDB as tools to blackmail hosts and force people to play the mods and versions you like.
3) Leave the goddamn hosts alone since you are not players and have no idea what happens inside hosts.
4) Stop the censorship on the forum banning or "locking", "splitting" cuz exposing uncomfortable truth to admin/devs

Optional but still important:
1) Create the forum section for ban trials so that abusive bans like Floris and Triton did in the past will be exposed and admins privileges should be instantly removed.
2) Proven that mod devs are unable to behave in an unbiased way having admin privileges, mod devs should not be admins at the same time. (this would become deprecated in case 3rd main point is fixed)

In brief, just reverting the retarded engine limitations and let the hosts host whatever they like would be enough i guess.

This is Mando for the spring community.
If you are reading this.... you are the resistance!
4 x

Flash
Posts: 32
Joined: 12 Dec 2010, 18:03

Re: [misc] spring >= 104.0

Post by Flash » 10 Apr 2019, 16:36

"again: this is mostly a non-commercial project. don't expect commercial like support."
I am not asking you to fix ba or anything i just dont want the majority of players to be excluded. Im sorry that i thought that devs would actually care about the playerbase but it seems not.
No players ---> No need for server.

btw. another post is still waiting for approval
1 x

abma
Spring Developer
Posts: 3544
Joined: 01 Jun 2009, 00:08

Re: [misc] spring >= 104.0

Post by abma » 10 Apr 2019, 16:39

Flash wrote:
10 Apr 2019, 16:36
"again: this is mostly a non-commercial project. don't expect commercial like support."
I am not asking you to fix ba or anything i just dont want the majority of players to be excluded. Im sorry that i thought that devs would actually care about the playerbase but it seems not.
No players ---> No need for server.
they care, but without devs it doesn't matter at all.
0 x

Mando
Posts: 16
Joined: 10 Apr 2019, 14:47

Re: [misc] spring >= 104.0

Post by Mando » 10 Apr 2019, 16:43

Ye i'm still waiting for my post to be published.
Censorship applied successfully again.

I'm also waiting for any admin to have courage to have a conversation with players in proper public chat.
0 x

dansan
Server Owner & Developer
Posts: 1190
Joined: 29 May 2010, 23:40

Re: [misc] spring >= 104.0

Post by dansan » 10 Apr 2019, 16:56

Mando wrote:
10 Apr 2019, 16:43
I'm also waiting for any admin to have courage to have a conversation with players in proper public chat.
It won't get more public than here, will it?
0 x

abma
Spring Developer
Posts: 3544
Joined: 01 Jun 2009, 00:08

Re: [misc] spring >= 104.0

Post by abma » 10 Apr 2019, 16:57

i can only encourage to help the project spring: report bugs or send pull requests to fix existing bugs:

engine: https://springrts.com/mantis/my_view_page.php
game: https://github.com/Balanced-Annihilatio ... nihilation (or the game you desire)
lobby server : https://github.com/spring/uberserver/
autohost: https://github.com/Yaribz/SPADS/issues
springlobby : https://github.com/springlobby/springlobby
downloader : https://github.com/spring/pr-downloader

arguing here IMHO doesn't help. The decision to enforce an engine version is well-considered and all of us had a lot of time since the release of spring 104.0 to fix or report issues about it.
0 x

dansan
Server Owner & Developer
Posts: 1190
Joined: 29 May 2010, 23:40

Re: [misc] spring >= 104.0

Post by dansan » 10 Apr 2019, 17:01

There are versions of BA that work with 104.
Just work together (as in being helpful) with game devs to get the balance OK.
Btw.: "I want it to run on a modern platform, but it should work exactly like on the ancient one." doesn't work. Not in RL, not on commercial platforms and not with springrts.
2 x

User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Re: [misc] enforcment of spring >= 104.0 for autohosts with botflag

Post by Jools » 10 Apr 2019, 17:15

Many gamedevs feel that there is no two-way communication between engine devs and gamedevs. Don't just make breaking changes to the engine and expect that everything will be patched downstream: first ask what will be okay and anchor the breaking changes before you apply them. Today the two groups are largely disconnected and that's why we have these problems.

For XTA part, the breaking changes that nobody has the energy to fix is not supporting old unit scripts but requiring us to recompile all scripts for a reason that's largely aesthetic.
1 x

User avatar
very_bad_soldier
Posts: 1371
Joined: 20 Feb 2007, 01:10

Re: [misc] enforcment of spring >= 104.0 for autohosts with botflag

Post by very_bad_soldier » 10 Apr 2019, 18:15

Pretty bad idea imo to bring the whole BA9/BA10 drama into this discussion... :roll: but ok

Is this "let's ban old engines" a one time thing or do the devs plan to do it regularly from now on? I just want to understand the plan.
0 x

Mando
Posts: 16
Joined: 10 Apr 2019, 14:47

Re: [misc] spring >= 104.0

Post by Mando » 10 Apr 2019, 18:18

abma wrote:
10 Apr 2019, 16:57
i can only encourage to help the project spring: report bugs or send pull requests to fix existing bugs:

engine: https://springrts.com/mantis/my_view_page.php
game: https://github.com/Balanced-Annihilatio ... nihilation (or the game you desire)
lobby server : https://github.com/spring/uberserver/
autohost: https://github.com/Yaribz/SPADS/issues
springlobby : https://github.com/springlobby/springlobby
downloader : https://github.com/spring/pr-downloader

arguing here IMHO doesn't help. The decision to enforce an engine version is well-considered and all of us had a lot of time since the release of spring 104.0 to fix or report issues about it.
As i said in previous post i agree 100% in changing to new code and stuff, but that should be done in the proper way.

First of all you should have never encouraged and supported BA devs in doing those massive changes to the game mechanics and UI while moving to a major engine upgrade.
As step 1 BA should have been migrated to the new engine versions without touching a single thing about balancement, UI, etc....
After that you should have checked and made sure that the engine was stable and all the mods where properly migrated to the new version and listened to the feedbacks of the players.

Instead, you guys forced people to play a mod that had completely different mechanics with an underlying engine bugged and completely ignoring any player feedback or complain.
Your support to those players was with arrogant replies or no reply at all, banning hosts and people disagreeing with you.
Anyway we all know the whole story.

So..... since players understood that there is no possible agreement about the engine version with you guys, what about the disgusting botflag abuse and the host bans?
Are you going to continue with that or are you planning to let the people freely set up their hosts and play and experiment any mod they want? (Using the unstable and abusive 104 engine of course)

Since the players have to accept that crap, at least pretend that this is a typical opensource project and let the people do their stuff in their hosts. Possibly remove that botflag bullshits while keeping the old engine version disabled.
dansan wrote:
10 Apr 2019, 17:01
There are versions of BA that work with 104.
Just work together (as in being helpful) with game devs to get the balance OK.
Btw.: "I want it to run on a modern platform, but it should work exactly like on the ancient one." doesn't work. Not in RL, not on commercial platforms and not with springrts.
You clearly have no idea how a commercial platform works xD

Best regards,
Mando
2 x

hokomoko
Spring Developer
Posts: 579
Joined: 02 Jun 2014, 00:46

Re: [misc] spring >= 104.0

Post by hokomoko » 10 Apr 2019, 18:46

Mando wrote:
10 Apr 2019, 18:18
First of all you should have never encouraged and supported BA devs in doing those massive changes to the game mechanics and UI while moving to a major engine upgrade.
:roll:
Listen y'all.
I understand that you have problems with the development of your games and you don't have the manpower to maintain and update them. I even sympathise.
But this whole thread is a futile attempt to pin all your internal problems on the engine devs, which makes the aforementioned sympathy fly out of the window.

If it weren't for the server being a shitshow, there wouldn't be any need for botflags, mandatory versions etc.
The big games on our server represent spring whether we like it or not, so we have to monitor them more closely, that's all.
I couldn't care less if you play BA7/8/9/10/XTA/ZK/ST/S44/CT/JW.

So stop professing your ineptitude on the forums, and use your time to port whatever game you want to play to the required engine version.
Don't want to do that? Play something else or somewhere else.
4 x

Kloot
Spring Developer
Posts: 1865
Joined: 08 Oct 2006, 16:58

Re: [misc] enforcment of spring >= 104.0 for autohosts with botflag

Post by Kloot » 10 Apr 2019, 18:59

very_bad_soldier wrote:Is this "let's ban old engines" a one time thing or do the devs plan to do it regularly from now on?
It may not be a regular thing, but we reserve the right.

If, for example, good boy Mando the samaritan martyr finds and abuses any exploits in 104(+), as he did with 103, that would count as a ban-worthy reason.
2 x

Ares
Posts: 314
Joined: 19 Mar 2011, 13:43

Re: [misc] enforcment of spring >= 104.0 for autohosts with botflag

Post by Ares » 10 Apr 2019, 19:06

hokomoko wrote:
10 Apr 2019, 18:46
this whole thread is a futile attempt to pin all your internal problems on the engine devs

Botflag didn't exist before 9.46, this is an idea invented by forboding angel when he joined balanced annihilation dev team as a creative way to force players to join their new version of BA, while appealing to engine devs without having to shoulder any responsibility for negative feedback from players. Sadly botflag is now being used purely for adding further restriction on an already small community.

Internal BA problem has clearly spilled out into engine land, and now 103 engine being banned is being blamed on players.
hokomoko wrote:
10 Apr 2019, 18:46
port whatever game you want to play to the required engine version
phoenix is on 104, however 104 "stable" has broken line move command which requires snapshots, meaning 103 is the last truly stable engine, but sadly it's banned
0 x

hokomoko
Spring Developer
Posts: 579
Joined: 02 Jun 2014, 00:46

Re: [misc] enforcment of spring >= 104.0 for autohosts with botflag

Post by hokomoko » 10 Apr 2019, 19:38

Ares wrote:
10 Apr 2019, 19:06
this is an idea invented by forboding angel
As far as I know (and from a search in mod discussion) this is not the case. Find another scapegoat.
Whomever did come up with the idea is irrelevant, as the decision of maintaining it is by the entirety of the moderating team. I assure you this has nothing to do with your BA versions squabble.

Ares wrote:
10 Apr 2019, 19:06
phoenix is on 104, however 104 "stable" has broken line move command which requires snapshots, meaning 103 is the last truly stable engine, but sadly it's banned
You are very welcome to use maintenance engine. The level of support is unparalleled.
2 x

Mando
Posts: 16
Joined: 10 Apr 2019, 14:47

Re: [misc] enforcment of spring >= 104.0 for autohosts with botflag

Post by Mando » 10 Apr 2019, 20:16

From the last posts from engine devs, i realised that these guys are unaware of the fact that they are using effort to develop this engine, and at the same time the abusive community admins is killing the whole player base that uses their engine.
Hokomoko thinks that we are struggling with the development and doesnt know that we are struggling to keep the hosts unbanned xD
Like they have 0 clue of what happened in the last 1 year or so.
What version of the story did Bluestone and the other admins tell them? :|

Any mod that has the potential to remove Floris/Triton BA from the market gets banned and the last BA10 crap is the result.
When you dont allow people to create stuff with your engine, and kill the competition because your boyfriend is a pussy dev and cant stand a challenge, you cant expect to end up with a successful product.

User was warned for this post, felony 1. -- FLOZi
1 x

Locked

Return to “Community Blog”