[misc] Please upgrade to SpringLobby>=0.244 / tools using unitsync

[misc] Please upgrade to SpringLobby>=0.244 / tools using unitsync

Happenin' news on what is happening in the community. Content releases, new tutorials, other cool stuff.
Post Reply
abma
Spring Developer
Posts: 3540
Joined: 01 Jun 2009, 00:08

[misc] Please upgrade to SpringLobby>=0.244 / tools using unitsync

Post by abma » 29 Jul 2016, 16:24

the next release of spring will remove a lot of deprecated functions in unitsync which is used to get info about installed games/maps and ais. Sadly this makes older versions of springlobby incompatible / unable to load unitsync.

When a deprecated function is/was used, the error "The deprecated unitsync function..." is/was logged into unitsync.log and the unitsync function GetNextError returned this error as well.

To make SpringLobby work again you need at least SpringLobby 0.244. Better upgrade to the latest version (currently 0.254).

As always, when you hit a bug, please report it to the bugtracker!

Thanks!

Note: The SpringLobby Client subforum was recently added.
0 x

User avatar
PepeAmpere
Posts: 586
Joined: 03 Jun 2010, 01:28

Re: [misc] Please upgrade to SpringLobby>=0.244 / tools using unitsync

Post by PepeAmpere » 13 Aug 2016, 00:48

Hi abma, I dont want to let you feel Im always acidic against Spring lobby, but can you please rephrase the title of the post to something human-readable sentence once it is on the front page news? "Upgrade Spring lobby to version 0.244 or higher" or something similar makes it better. Or if you want to be more general, e.g. "Deprecated unitsync functions: upgrade your clients and tools"
0 x

Post Reply

Return to “Community Blog”